Skip to content

Commit

Permalink
app-text/ansifilter: version bump 2.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
kensington committed Jun 24, 2017
1 parent b098f0b commit 464f2c8
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/ansifilter/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ansifilter-2.4.tar.bz2 114180 SHA256 c57cb878afa7191c7b7db3c086a344b4234df814aed632596619a4bda5941d48 SHA512 2eaecd7dc6027c6976775d2a817b8fde0221fb1cce967bd4f6e272230b64e0bb77ed0cbddbc41533aa6087897b94903efa9633dffdd76df57ba029f6776ae6d2 WHIRLPOOL df5f96802c4b988ee3c3326dc0a6ecc2ab594fe766c6e5118d1695a05adf3969d51b0a89b1bfbc0b94cb84325131dc39622334c549a47e0ffa76c0e3fca7a997
DIST ansifilter-2.5.tar.bz2 435332 SHA256 30d05ccfa9be98b0328ee29fe39473e55047f1d32a9a2460d3d4d1ff2475f0e2 SHA512 2fca95a5a47e72f9348beef8b09a7fd995f0b99e0d6605cf7694f8fd1ddba40c64e5c30b9134f55319c902d45011605ba30184c0205d41573ac77c3cd98debe7 WHIRLPOOL 5c3c3cd8f1cef99ad0d4ea5ce7635301776cb5ce14442d74a1949894c24becb4d3727344f7b1cf2e137bc8abfc8469c23d13e0055529c04f9aafeb991e7cf7f6
57 changes: 57 additions & 0 deletions app-text/ansifilter/ansifilter-2.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs qmake-utils

DESCRIPTION="Handles text files containing ANSI terminal escape codes"
HOMEPAGE="http://www.andre-simon.de/"
SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="qt5"

RDEPEND="
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
)"
DEPEND="${RDEPEND}"

src_prepare() {
default

# bug 431452
rm src/qt-gui/moc_mydialog.cpp || die
}

src_configure() {
if use qt5 ; then
pushd src/qt-gui > /dev/null || die
eqmake5
popd > /dev/null || die
fi
}

src_compile() {
emake -f makefile CC="$(tc-getCXX)" CFLAGS="${CFLAGS} -c -std=c++11" LDFLAGS="${LDFLAGS}"

if use qt5 ; then
pushd src/qt-gui > /dev/null || die
emake
popd > /dev/null || die
fi
}

src_install() {
dobin src/${PN}
use qt5 && dobin src/qt-gui/${PN}-gui

gunzip man/${PN}.1.gz
doman man/${PN}.1
einstalldocs
}

0 comments on commit 464f2c8

Please sign in to comment.