forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-cpp/commoncpp2: Allow for compiling with GCC 6
Gentoo-bug: 595422 * EAPI=6 * Make PATCHES -p1 compliant Package-Manager: portage-2.3.1
- Loading branch information
1 parent
09b3414
commit 46aee35
Showing
6 changed files
with
145 additions
and
10 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,71 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit autotools | ||
|
||
DESCRIPTION="C++ library offering portable support for system-related services" | ||
SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz" | ||
HOMEPAGE="https://www.gnu.org/software/commoncpp/" | ||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86" | ||
IUSE="debug doc examples ipv6 gnutls ssl static-libs" | ||
REQUIRED_USE="gnutls? ( ssl )" | ||
|
||
RDEPEND="ssl? ( gnutls? ( dev-libs/libgcrypt:0 | ||
net-libs/gnutls ) | ||
!gnutls? ( dev-libs/openssl:0 ) ) | ||
sys-libs/zlib" | ||
DEPEND="doc? ( >=app-doc/doxygen-1.3.6 ) | ||
${RDEPEND}" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/1.8.1-configure_detect_netfilter.patch" | ||
"${FILESDIR}/1.8.0-glibc212.patch" | ||
"${FILESDIR}/1.8.1-autoconf-update.patch" | ||
"${FILESDIR}/1.8.1-fix-buffer-overflow.patch" | ||
"${FILESDIR}/1.8.1-parallel-build.patch" | ||
"${FILESDIR}/1.8.1-libgcrypt.patch" | ||
"${FILESDIR}/1.8.1-fix-c++14.patch" | ||
) | ||
|
||
src_prepare() { | ||
default | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
local myconf | ||
if use gnutls; then | ||
myconf+="--with-gnutls" | ||
else | ||
use ssl && myconf+="--with-openssl" | ||
fi | ||
|
||
econf \ | ||
$(use_enable debug) \ | ||
$(use_with ipv6) \ | ||
$(use_enable static-libs static) \ | ||
$(use_with doc doxygen) \ | ||
${myconf} | ||
} | ||
|
||
src_install () { | ||
# Only install html docs | ||
# man and latex available, but seems a little wasteful | ||
use doc && HTML_DOCS=( doc/html/. ) | ||
default | ||
dodoc COPYING.addendum | ||
|
||
if use examples; then | ||
docinto examples | ||
dodoc demo/{*.cpp,*.h,*.xml,README} | ||
docompress -x /usr/share/doc/${PF}/examples | ||
fi | ||
|
||
# package provides .pc files | ||
find "${D}" -name '*.la' -delete || die | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
Fix building with C++14, which errors out due changed noexcept() | ||
semantics for dtors caught by -Werror=terminate. | ||
|
||
See also: https://bugs.gentoo.org/show_bug.cgi?id=595422 | ||
|
||
--- a/src/nat.cpp | ||
+++ b/src/nat.cpp | ||
@@ -145,11 +145,11 @@ | ||
"nat lookup successful", | ||
"nat address not in table", | ||
"nat not supported/implemented", | ||
- "unable to open device "NAT_DEVICE, | ||
+ "unable to open device " NAT_DEVICE, | ||
"unable to get socket name", | ||
"unable to get peer name", | ||
"unable to get socket type", | ||
- "unable to lookup, nat "NAT_SYSCALL" failed", | ||
+ "unable to lookup, nat " NAT_SYSCALL " failed", | ||
"unkown nat error code" | ||
}; | ||
|
||
--- a/src/socket.cpp | ||
+++ b/src/socket.cpp | ||
@@ -2971,12 +2971,7 @@ | ||
|
||
TCPStream::~TCPStream() | ||
{ | ||
-#ifdef CCXX_EXCEPTIONS | ||
- try { endStream(); } | ||
- catch( ... ) { if ( ! std::uncaught_exception()) throw;}; | ||
-#else | ||
- endStream(); | ||
-#endif | ||
+ endStream(); | ||
} | ||
|
||
#ifdef HAVE_GETADDRINFO | ||
--- a/src/ssl.cpp | ||
+++ b/src/ssl.cpp | ||
@@ -441,12 +441,7 @@ | ||
|
||
SSLStream::~SSLStream() | ||
{ | ||
-#ifdef CCXX_EXCEPTIONS | ||
- try { endStream(); } | ||
- catch( ...) { if ( ! std::uncaught_exception()) throw;}; | ||
-#else | ||
endStream(); | ||
-#endif | ||
} | ||
|
||
#ifdef CCXX_NAMESPACES |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,5 @@ | ||
--- src/Makefile.am | ||
+++ src/Makefile.am | ||
--- a/src/Makefile.am | ||
+++ b/src/Makefile.am | ||
@@ -47,6 +47,7 @@ | ||
|
||
if EXTRAS | ||
|