Skip to content

Commit

Permalink
dev-python/astroid: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
patricklauer committed Jul 17, 2016
1 parent 8a2866d commit 46d540f
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/astroid/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST astroid-1.4.3.tar.gz 181329 SHA256 8e9ce4e925a17442cec085a7fce05478b99e482c
DIST astroid-1.4.4.tar.gz 181733 SHA256 7f7e5512efe515098e77cbd3a60e87c8db8954097b0e025d8d6f72f2e8ddc298 SHA512 f78f749e9542145060ba997f2e46945c13cffda74fb77f05b358bf4c22bac8b9924889627148d205538f515413293733471d238fea62a084ab9727e8d239d6ce WHIRLPOOL 12aedaa9ad5c3cbffd641e292fc829e90ffc4aab30e35d7cdb71e88a3fcfb24a3fbda342adedddba4c3f72c3d96216a9cb6c58ad4f2183cdb0f4784dd21dd0b2
DIST astroid-1.4.5.tar.gz 182251 SHA256 729b986aa59fb77af533707c385021b04e60d136b5f21cc766618556d0816cf6 SHA512 abcc31e927ec9abd8be277f9b586f409dc2632be8c84bae0521ca2fe17b5a13325429494918357e998fb56221a72476194a7a6d3238b1cd81b88e827d97f6328 WHIRLPOOL 34578ddbb52505c33844b94c7801c46b0e6d321cfd16ee866a6955e0a0ae942c7e912675bf857248daa9b5420a50eb1cc865dd3fceb9e42b293cf686272fe72f
DIST astroid-1.4.6.tar.gz 183711 SHA256 c304b70cb792dd361f918f662e3fb9bfe4a5d7b749f2e32d3ebcba26d4e4599f SHA512 7e653aa2c2ea4fd465ca637547f221cc2dda3dbf9f0a5fbab8760337fd14fcd203aee08f466a26d7ebb5f7fb559ad39550a6bcb8ef9c57daf51d5d6cbe728e4d WHIRLPOOL 900502f27ffaf15cf49b8996802afb74188f58ba51704595d935efcb80881f026b725b9c98186cb768b13dc21ac3c50785823eb643cd01fb444fbe377e28de70
DIST astroid-1.4.7.tar.gz 183978 SHA256 7ad77b81fa8551e40837c78a85b37f0613bb682999fda69c07833d55185f6403 SHA512 6925b6b5469354f805363670e92ef0059657db2ccd712ebcd4a3f4eef02891bd9c464942d19125ee7abd41e3c26a928752baf50ca82dd52ee88315eb5ae36869 WHIRLPOOL 97f9f71d8f9103ffafaed227ee0ff3bd21b3a1eb89d2f0884593e9811117b1b33dceae15634dadf1f6e459b851e46d08fae7362153ad95d476d06b1053a43a6a
42 changes: 42 additions & 0 deletions dev-python/astroid/astroid-1.4.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )

inherit distutils-r1

DESCRIPTION="Abstract Syntax Tree for logilab packages"
HOMEPAGE="https://bitbucket.org/logilab/astroid https://pypi.python.org/pypi/astroid"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
IUSE="test"

# still broken
RESTRICT=test

# Version specified in __pkginfo__.py.
RDEPEND="
dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/wrapt[${PYTHON_USEDEP}]"
DEPEND="
app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]"
# test? (
# ${RDEPEND}
# >=dev-python/pylint-1.4.0[${PYTHON_USEDEP}]
# dev-python/pytest[${PYTHON_USEDEP}]
# $(python_gen_cond_dep 'dev-python/egenix-mx-base[${PYTHON_USEDEP}]' python2_7)
# )"
# Required for tests
DISTUTILS_IN_SOURCE_BUILD=1

python_test() {
${EPYTHON} -m unittest discover -p "unittest*.py" --verbose || die
}

0 comments on commit 46d540f

Please sign in to comment.