Skip to content

Commit

Permalink
dev-qt/qtwebkit: 5.212.0_pre20200309 (alpha4) version bump
Browse files Browse the repository at this point in the history
- Build with python3.
- Unconditionally depend on media-libs/woff2

Closes: https://bugs.gentoo.org/698990
Closes: https://bugs.gentoo.org/704748
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Mar 11, 2020
1 parent 313c531 commit 46db89e
Show file tree
Hide file tree
Showing 2 changed files with 147 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-qt/qtwebkit/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST qtwebkit-5.212.0-alpha3.tar.xz 12457896 BLAKE2B 1b6ce78706a9696f0eb1fbe287d0d095d0089daf645a9ca60f9f31b9057669180b14d67a3bdfb387fc09dbbeee658c0e895a95edc46b2020f06f2b58188ba65d SHA512 38794514b886de3fa63a41277c2bcbb970e87a12070962b527e3898466cf7ad3b65ce4588669498415d365310b37729e81aabb457808fe11120558ef8e35445f
DIST qtwebkit-5.212.0-alpha4.tar.xz 12528508 BLAKE2B 72d7444f270f47b62044cf683ed306803660bfbafe1450440ea29e43e3c0e6e841b6e860dfa8affc1b32b7c539448f04e22a7ae38cce055d37905dfb3240aab0 SHA512 33f11270bd030599beff9c1983a6c5ff2d61f407cc8a6825f7f405d46f9184c720fc7f60c7359f08f828db96a2170092875066a0d5c0a21ff09bc48a2603fbf6
146 changes: 146 additions & 0 deletions dev-qt/qtwebkit/qtwebkit-5.212.0_pre20200309.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,146 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

if [[ ${PV} = *9999 ]]; then
EGIT_BRANCH="qtwebkit-5.212"
EGIT_REPO_URI="https://github.com/qtwebkit/qtwebkit.git"
inherit git-r3
else
MY_P="${PN}-${PV/_pre20200309/-alpha4}" # present as upgrade over previous snapshot
SRC_URI="https://github.com/annulen/webkit/releases/download/${MY_P}/${MY_P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
S="${WORKDIR}/${MY_P}"
fi
PYTHON_COMPAT=( python3_{6,7,8} )
USE_RUBY="ruby25 ruby26 ruby27"
inherit check-reqs cmake flag-o-matic python-any-r1 qmake-utils ruby-single toolchain-funcs

DESCRIPTION="WebKit rendering library for the Qt5 framework (deprecated)"
HOMEPAGE="https://www.qt.io/"

LICENSE="BSD LGPL-2+"
SLOT="5/5.212"
IUSE="geolocation gles2 +gstreamer +hyphen +jit multimedia nsplugin opengl orientation +printsupport qml webp X"

REQUIRED_USE="
nsplugin? ( X )
qml? ( opengl )
?? ( gstreamer multimedia )
"

# Dependencies found at Source/cmake/OptionsQt.cmake
QT_MIN_VER="5.12.3:5"
BDEPEND="
${PYTHON_DEPS}
${RUBY_DEPS}
dev-lang/perl
dev-util/gperf
>=sys-devel/bison-2.4.3
sys-devel/flex
virtual/pkgconfig
"
DEPEND="
dev-db/sqlite:3
dev-libs/icu:=
dev-libs/libxml2
dev-libs/libxslt
>=dev-qt/qtcore-${QT_MIN_VER}
>=dev-qt/qtgui-${QT_MIN_VER}
>=dev-qt/qtnetwork-${QT_MIN_VER}
>=dev-qt/qtwidgets-${QT_MIN_VER}=
media-libs/libpng:0=
media-libs/woff2
virtual/jpeg:0
geolocation? ( >=dev-qt/qtpositioning-${QT_MIN_VER} )
gstreamer? (
dev-libs/glib:2
media-libs/gstreamer:1.0
media-libs/gst-plugins-bad:1.0
media-libs/gst-plugins-base:1.0
)
hyphen? ( dev-libs/hyphen )
multimedia? ( >=dev-qt/qtmultimedia-${QT_MIN_VER}[widgets] )
opengl? (
>=dev-qt/qtgui-${QT_MIN_VER}[gles2=]
>=dev-qt/qtopengl-${QT_MIN_VER}[gles2=]
)
orientation? ( >=dev-qt/qtsensors-${QT_MIN_VER} )
printsupport? ( >=dev-qt/qtprintsupport-${QT_MIN_VER} )
qml? (
>=dev-qt/qtdeclarative-${QT_MIN_VER}
>=dev-qt/qtwebchannel-${QT_MIN_VER}[qml]
)
webp? ( media-libs/libwebp:= )
X? (
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXrender
)
"
RDEPEND="${DEPEND}"

CHECKREQS_DISK_BUILD="16G" # bug 417307

_check_reqs() {
if [[ ${MERGE_TYPE} != binary ]] && is-flagq "-g*" && ! is-flagq "-g*0"; then
einfo "Checking for sufficient disk space to build ${PN} with debugging flags"
check-reqs_$1
fi
}

pkg_pretend() {
_check_reqs pkg_pretend
}

pkg_setup() {
_check_reqs pkg_setup
python-any-r1_pkg_setup
}

src_configure() {
# Respect CC, otherwise fails on prefix, bug #395875
tc-export CC

# Multiple rendering bugs on youtube, github, etc without this, bug #547224
append-flags $(test-flags -fno-strict-aliasing)

local mycmakeargs=(
-DPORT=Qt
-DENABLE_API_TESTS=OFF
-DENABLE_TOOLS=OFF
-DENABLE_GEOLOCATION=$(usex geolocation)
-DUSE_GSTREAMER=$(usex gstreamer)
-DUSE_LIBHYPHEN=$(usex hyphen)
-DENABLE_JIT=$(usex jit)
-DUSE_QT_MULTIMEDIA=$(usex multimedia)
-DENABLE_NETSCAPE_PLUGIN_API=$(usex nsplugin)
-DENABLE_OPENGL=$(usex opengl)
-DENABLE_PRINT_SUPPORT=$(usex printsupport)
-DENABLE_DEVICE_ORIENTATION=$(usex orientation)
-DENABLE_WEBKIT2=$(usex qml)
$(cmake_use_find_package webp WebP)
-DENABLE_X11_TARGET=$(usex X)
)

if has_version "virtual/rubygems[ruby_targets_ruby27]"; then
mycmakeargs+=( -DRUBY_EXECUTABLE=$(type -P ruby27) )
elif has_version "virtual/rubygems[ruby_targets_ruby26]"; then
mycmakeargs+=( -DRUBY_EXECUTABLE=$(type -P ruby26) )
else
mycmakeargs+=( -DRUBY_EXECUTABLE=$(type -P ruby25) )
fi

cmake_src_configure
}

src_install() {
cmake_src_install

# bug 572056
if [[ ! -f ${ED}$(qt5_get_libdir)/libQt5WebKit.so ]]; then
eerror "${CATEGORY}/${PF} could not build due to a broken ruby environment."
die 'Check "eselect ruby" and ensure you have a working ruby in your $PATH'
fi
}

0 comments on commit 46db89e

Please sign in to comment.