Skip to content

Commit

Permalink
dev-util/bazel: bump 2.0.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Jason Zaman <[email protected]>
  • Loading branch information
perfinion committed Mar 29, 2020
1 parent 0bbb9e4 commit 46fc7e4
Show file tree
Hide file tree
Showing 2 changed files with 110 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/bazel/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,3 +7,4 @@ DIST bazel-1.0.1-dist.zip 267211562 BLAKE2B ade5fcc2a799df4da24ce23a3f2f23d3f38a
DIST bazel-1.2.0-dist.zip 267514282 BLAKE2B 1c4f9dcf2c18e6880d701dab3de2e880e55278216ba051f9ad753b9f8c539e5734346bcb20c706307b677f97736587ee11e3c3accabe4c82ac1a82a0cdafcd36 SHA512 eaa3e27d0ddd6102fea4fcdf5f4379355954ba25cd2f4b3530071d077411f8a501041d8fda9ac90325244296f31072faaebd91cf6338893752b25212822a6be9
DIST bazel-1.2.0-rename-gettid-functions.patch 3303 BLAKE2B 75aaed0b8e5fe33910d1b428ad421bbf37cafdc38dc46cbe9d9fe516e957f1dc3a30333c40a6ec3e61580ca908189a8821937ddd28aa9cf119ae237d63c576fb SHA512 0d4dc5c5931ff3a16bb9ac228ec560fc0115444a3d3787f12866e11e8b3833ee8a26cc65c97aa9898c1f7a6c380820d62544d2ed7bed0d6f21aa4293e244eb04
DIST bazel-1.2.1-dist.zip 267514406 BLAKE2B f9d316ac096f503a2c7fe101b103b88e7f0247f767a8dc28eb8c9d2cd0b6df6fa785f3b187e1a3963e2f9f0ae742a3330e5104e7a8aea75cb9b9e100366a5aca SHA512 bc0e6526bfbb8725a4f2ae95fc88b22229301b64559325fca3bcf5a9bc642cec2b2284eb9a6ce0699f1f910378b89ee23657dbea7928a92cc1900f1f2f405ff3
DIST bazel-2.0.0-dist.zip 259625808 BLAKE2B 31b62fb3da1f6fc7efc4c3f44521e12f879a1e5b532fe814d8f49c01c511b34cd65df252d6d143fdcd96f72dc94d76249f79be50fc66a459132c030ef0182ca8 SHA512 db609e9d0ee0cdbfb999de850db17907af02dc26e605f4617dfeb2fbac5c30c4c0a9f48c6ba3673ffe8babb5b9e157cc51c32832015b85ed279b6b160506cdae
109 changes: 109 additions & 0 deletions dev-util/bazel/bazel-2.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,109 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit bash-completion-r1 java-pkg-2 multiprocessing

DESCRIPTION="Fast and correct automated build system"
HOMEPAGE="https://bazel.build/"

SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="examples tools"
# strip corrupts the bazel binary
# test fails with network-sandbox: An error occurred during the fetch of repository 'io_bazel_skydoc' (bug 690794)
RESTRICT="strip test"
RDEPEND=">=virtual/jdk-1.8:*"
DEPEND="${RDEPEND}
app-arch/unzip
app-arch/zip"

S="${WORKDIR}"

bazel-get-flags() {
local i fs=()
for i in ${CFLAGS}; do
fs+=( "--copt=${i}" "--host_copt=${i}" )
done
for i in ${CXXFLAGS}; do
fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
done
for i in ${CPPFLAGS}; do
fs+=( "--copt=${i}" "--host_copt=${i}" )
fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
done
for i in ${LDFLAGS}; do
fs+=( "--linkopt=${i}" "--host_linkopt=${i}" )
done
echo "${fs[*]}"
}

pkg_setup() {
echo ${PATH} | grep -q ccache && \
ewarn "${PN} usually fails to compile with ccache, you have been warned"
java-pkg-2_pkg_setup
}

src_unpack() {
# Only unpack the main distfile
unpack ${P}-dist.zip
}

src_prepare() {
default

# F: fopen_wr
# S: deny
# P: /proc/self/setgroups
# A: /proc/self/setgroups
# R: /proc/24939/setgroups
# C: /usr/lib/systemd/systemd
addpredict /proc
}

src_compile() {
export EXTRA_BAZEL_ARGS="--jobs=$(makeopts_jobs) $(bazel-get-flags) --host_javabase=@local_jdk//:jdk"
VERBOSE=yes ./compile.sh || die

./scripts/generate_bash_completion.sh \
--bazel=output/bazel \
--output=bazel-complete.bash \
--prepend=scripts/bazel-complete-header.bash \
--prepend=scripts/bazel-complete-template.bash
}

src_test() {
output/bazel test \
--verbose_failures \
--spawn_strategy=standalone \
--genrule_strategy=standalone \
--verbose_test_summary \
examples/cpp:hello-success_test || die
output/bazel shutdown
}

src_install() {
dobin output/bazel
newbashcomp bazel-complete.bash ${PN}
bashcomp_alias ${PN} ibazel
insinto /usr/share/zsh/site-functions
doins scripts/zsh_completion/_bazel

if use examples; then
docinto examples
dodoc -r examples/*
docompress -x /usr/share/doc/${PF}/examples
fi
# could really build tools but I don't know which ones
# are actually used
if use tools; then
docinto tools
dodoc -r tools/*
docompress -x /usr/share/doc/${PF}/tools
docompress -x /usr/share/doc/${PF}/tools/build_defs/pkg/testdata
fi
}

0 comments on commit 46fc7e4

Please sign in to comment.