forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-emulation/mednafen: Bump to 0.9.45.1
* Also depend on at least lzo-2.10 Bug: https://bugs.gentoo.org/show_bug.cgi?id=621214 Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
1 parent
9a4e54b
commit 47317dd
Showing
2 changed files
with
110 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST mednafen-0.9.41.tar.xz 3148348 SHA256 74736b9b52a7ba6270b67ae8e6c876a887e0e26a00a7d96bdd49af17992aac47 SHA512 d3c7707874eabbec41e5b725813d16e599f3ad89ecbd9c8e1264184d74ab2bf7a21a3f6fe177b6bc429f7bd56f9eea17a9a6fefce8e70b82e87a93d75f5d39c9 WHIRLPOOL f754a45f46a5cd18117b1b710dd7fed5ebcfb311bf4ed4b7961c99636c13559db75f83cf7b34122fb403b7794ddeec6af79469bb7743cb60a7840ffe807fa2d7 | ||
DIST mednafen-0.9.45.1.tar.xz 3183380 SHA256 f95f68acc14f9b30b201e15b8205d85ac9dc7e581ea6b61e225e990491f01e69 SHA512 b49b7638166dfb20d43c3278e7084e99e535dc9c2c1e3ecad82ebf41a1dddbeca9350dfcc26eb43d1661cbe5aa3ba4cde3010ca5680ae9398dc160cbe11d6726 WHIRLPOOL b63568d3a6a4aa055c6a1a576ad74d9bdd4ffcb8fdb41a44dedf390a591eb2f21a382d638df7343927b1a95f236ef9ab505cbc7cb0bb2f1c25406730252223bc | ||
DIST mednafen-0.9.45.tar.xz 3184340 SHA256 49715544a5eb7a678f7f01994f38aa14e2192f00d201684184665665073a600e SHA512 d2d61eef0a5ab2c3109fb3c4fbdb2509504c61ffaab14a51e413204f08a622e47c116c7333866a3406a1fa7ac4bf68349c0212bc9fcb544d4953898b03a2fb71 WHIRLPOOL 3e8466852d8c04207a307ac2d74c5d9b76b51d0f9cd2c0ae16f59d57ae884dec8fd8d62454996c574f25a530ac568f7a2c884657b2f6b85d0810dc1fb51ad9e0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,109 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit autotools flag-o-matic pax-utils | ||
|
||
DESCRIPTION="Argument-driven multi-system emulator utilizing OpenGL and SDL" | ||
HOMEPAGE="https://mednafen.github.io/" | ||
SRC_URI="https://mednafen.github.io/releases/files/${P}.tar.xz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="alsa altivec cjk debugger jack nls pax_kernel" | ||
|
||
RDEPEND=" | ||
dev-libs/libcdio | ||
>=dev-libs/lzo-2.10 | ||
media-libs/libsdl[sound,joystick,opengl,video] | ||
media-libs/libsndfile | ||
sys-libs/zlib[minizip] | ||
virtual/opengl | ||
alsa? ( media-libs/alsa-lib ) | ||
jack? ( media-sound/jack-audio-connection-kit ) | ||
nls? ( virtual/libintl )" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig | ||
nls? ( sys-devel/gettext )" | ||
|
||
S=${WORKDIR}/${PN} | ||
|
||
pkg_pretend() { | ||
if has ccache ${FEATURES}; then | ||
ewarn | ||
ewarn "If you experience build failure, try turning off ccache in FEATURES." | ||
ewarn | ||
fi | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
# Unfortunately, upstream is insane and thinks mucking with CFLAGS is okay, if | ||
# it prevents "users who don't understand the consequences of what they're doing". | ||
# We use sed's here, as they're more forward-compatible than patches which need to | ||
# be constantly rebased. DO NOT REPLACE THEM UNLESS YOU HAVE PERMISSION FROM GAMES. | ||
sed -e '/-fno-fast-math/d' \ | ||
-e '/-fno-unsafe-math-optimizations/d' \ | ||
-e '/-fno-aggressive-loop-optimizations/d' \ | ||
-e '/-fno-ipa-icf/d' \ | ||
-e '/-fno-printf-return-value/d' \ | ||
-e '/-fomit-frame-pointer/d' \ | ||
-e '/-fno-pic/d' \ | ||
-e '/-fno-pie/d' \ | ||
-e '/-fno-PIC/d' \ | ||
-e '/-fno-PIE/d' \ | ||
-e '/-nopie/d' \ | ||
-e '/-no-pie/d' \ | ||
-e '/-fno-stack-protector/d' \ | ||
-e '/-fno-stack-protector-all/d' \ | ||
-e '/-fno-stack-protector-strong/d' \ | ||
-e '/-mtune=haswell/d' \ | ||
-i configure.ac || die | ||
|
||
# Furthermore, upstream is also insane about bundling libraries and considers it | ||
# "an aesthetics issue" and is even unwilling to make unbundling optional. | ||
# Libs to unbundle: minilzo, minizip | ||
sed -e '/PKG_PROG_PKG_CONFIG/a PKG_CHECK_MODULES([LZO], [lzo2])' \ | ||
-i configure.ac || die | ||
sed -e '/bin_PROGRAMS/a mednafen_CPPFLAGS = \$(LZO_CFLAGS)' \ | ||
-i src/Makefile.am || die | ||
sed -e 's:"compress/minilzo.h":<lzo1x.h>:' \ | ||
-i src/{mednafen,qtrecord}.cpp || die | ||
sed -e 's:compress/ioapi.c::' \ | ||
-e 's:compress/unzip.c::' \ | ||
-e 's:compress/minilzo.c::' \ | ||
-i src/compress/Makefile.am.inc || die | ||
sed -e 's:"compress/unzip.h":<minizip/unzip.h>:' \ | ||
-i src/file.cpp || die | ||
sed -e 's:\(mednafen_LDADD.*trio/libtrio\.a\):\1 -lminizip \$(LZO_LIBS):' \ | ||
-i src/Makefile.am || die | ||
# delete bundled files just to be sure... | ||
rm src/compress/{ioapi.?,*lzo*,unzip.?} || die | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
# very sensitive code (bug #539992) | ||
strip-flags | ||
append-flags -fomit-frame-pointer -fwrapv | ||
econf \ | ||
$(use_enable alsa) \ | ||
$(use_enable altivec) \ | ||
$(use_enable cjk cjk-fonts) \ | ||
$(use_enable debugger) \ | ||
$(use_enable jack) \ | ||
$(use_enable nls) | ||
} | ||
|
||
src_install() { | ||
default | ||
dodoc Documentation/cheats.txt | ||
|
||
if use pax_kernel; then | ||
pax-mark m "${ED%/}"/usr/bin/mednafen || die | ||
fi | ||
} |