Skip to content

Commit

Permalink
app-arch/gzip: Bump to version 1.10
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.53, Repoman-2.3.12
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Dec 30, 2018
1 parent caf239c commit 4774d26
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/gzip/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gzip-1.10.tar.xz 775144 BLAKE2B 431dc0fd11061eabd9db86594777b86510b124b124fd74799eacd67334631af60f638be2638413bee0153a9da35528d0aecc5b5083152c395223705400c9103b SHA512 e6ba9e3906cdb6a6235b213515093d02afa1722686f73eddacbacae628542b586b449829783b6a1701e9b9e0c4d4dfa6845904d3b6b010f5cf21aec4997c9299
DIST gzip-1.8.tar.xz 728116 BLAKE2B 34b707bd403791aca8620de3520637c460dbd9167a4fb693c78438115862781350ef5e256ad0accce75b25515b82fcd3e405cc310d6ea36f2d2609b0a270c4db SHA512 efd3e2439476054badeb127d9156e24e9252129111219f13fd939596c057b2a96291630b2717181984b391abf249ac8699488bbd01ceeb8a70b121c500b10c55
DIST gzip-1.9.tar.xz 762516 BLAKE2B 4001fc7a770634916d52b026dab1b621fc96275bfb61ec2df2d0e7d7ec1c81414270d3c866034e6ef758870f38e9d4396a25832abe558915a7ded1f1511eb4b0 SHA512 c0852e7f7662141e79d14bc36e50f1940dba3e804feff3b0b8fa084ffec720ac245352282d2f1db117fadc95758424dd418d192b94621dac4367834ccf101fad
39 changes: 39 additions & 0 deletions app-arch/gzip/gzip-1.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit flag-o-matic

DESCRIPTION="Standard GNU compressor"
HOMEPAGE="https://www.gnu.org/software/gzip/"
SRC_URI="mirror://gnu/gzip/${P}.tar.xz
mirror://gnu-alpha/gzip/${P}.tar.xz
mirror://gentoo/${P}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="pic static"

PATCHES=(
"${FILESDIR}/${PN}-1.3.8-install-symlinks.patch"
)

src_configure() {
use static && append-flags -static
# avoid text relocation in gzip
use pic && export DEFS="NO_ASM"
econf --disable-gcc-warnings #663928
}

src_install() {
default
docinto txt
dodoc algorithm.doc gzip.doc

# keep most things in /usr, just the fun stuff in /
dodir /bin
mv "${ED%/}"/usr/bin/{gunzip,gzip,uncompress,zcat} "${ED%/}"/bin/ || die
sed -e "s:${EPREFIX}/usr:${EPREFIX}:" -i "${ED%/}"/bin/gunzip || die
}

0 comments on commit 4774d26

Please sign in to comment.