Skip to content

Commit

Permalink
app-i18n/librime: Fix building with >=dev-libs/boost-1.76.
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/788727
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <[email protected]>
Signed-off-by: Mike Gilbert <[email protected]>
  • Loading branch information
Arfrever Frehtes Taifersar Arahesis authored and floppym committed May 9, 2021
1 parent abef09f commit 47a8bd4
Show file tree
Hide file tree
Showing 4 changed files with 30 additions and 2 deletions.
24 changes: 24 additions & 0 deletions app-i18n/librime/files/librime-1.6.0-boost-1.76.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
https://github.com/rime/librime/issues/462
https://github.com/rime/librime/pull/463
https://github.com/rime/librime/commit/57cffcd02ac70148e21ce982be834876b3df87db

--- /src/rime/gear/script_translator.cc
+++ /src/rime/gear/script_translator.cc
@@ -8,6 +8,7 @@
//
#include <algorithm>
#include <stack>
+#include <cmath>
#include <boost/algorithm/string/join.hpp>
#include <boost/range/adaptor/reversed.hpp>
#include <rime/composition.h>
--- /src/rime/gear/table_translator.cc
+++ /src/rime/gear/table_translator.cc
@@ -6,6 +6,7 @@
//
#include <boost/algorithm/string.hpp>
#include <boost/range/adaptor/reversed.hpp>
+#include <cmath>
#include <utf8.h>
#include <rime/candidate.h>
#include <rime/common.h>
3 changes: 2 additions & 1 deletion app-i18n/librime/librime-1.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2012-2020 Gentoo Authors
# Copyright 2012-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -43,6 +43,7 @@ DEPEND="${RDEPEND}
DOCS=(CHANGELOG.md README.md)

src_prepare() {
eapply "${FILESDIR}/${PN}-1.6.0-boost-1.76.patch"
eapply "${FILESDIR}/${PN}-1.6.0-plugins.patch"

# Use headers of dev-libs/darts, dev-libs/utfcpp and x11-base/xorg-proto.
Expand Down
3 changes: 2 additions & 1 deletion app-i18n/librime/librime-1.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2012-2020 Gentoo Authors
# Copyright 2012-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
Expand Down Expand Up @@ -43,6 +43,7 @@ DEPEND="${RDEPEND}
DOCS=(CHANGELOG.md README.md)

src_prepare() {
eapply "${FILESDIR}/${PN}-1.6.0-boost-1.76.patch"
eapply "${FILESDIR}/${PN}-1.6.1-plugins.patch"

# Use headers of dev-libs/darts, dev-libs/utfcpp and x11-base/xorg-proto.
Expand Down
2 changes: 2 additions & 0 deletions app-i18n/librime/librime-1.7.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -43,6 +43,8 @@ DEPEND="${RDEPEND}
DOCS=(CHANGELOG.md README.md)

src_prepare() {
eapply "${FILESDIR}/${PN}-1.6.0-boost-1.76.patch"

# Use headers of dev-libs/darts, dev-libs/utfcpp and x11-base/xorg-proto.
sed -e "/\${PROJECT_SOURCE_DIR}\/thirdparty/d" -i CMakeLists.txt || die
rm -r thirdparty || die
Expand Down

0 comments on commit 47a8bd4

Please sign in to comment.