Skip to content

Commit

Permalink
www-apps/trac: version bump to 1.0.13
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
djc committed Sep 16, 2016
1 parent 9ba6c0d commit 47c8c29
Show file tree
Hide file tree
Showing 2 changed files with 130 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-apps/trac/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST Trac-1.0.10.tar.gz 3655342 SHA256 cb439d2ef39b71673299bffe9d042bdcd3bea9d2d02eab598bc820d415953ecd SHA512 16567f9e9843a3a682f9b3f65e57ab85a7429f20ea27f09ebf72860bbf6c6667cc656a6e053e39e7b03b1eb407e330d13380f958c139c1d208d4ba8948599aa6 WHIRLPOOL 1ec5e52f4aec2e5dc0816632961bdfd2312b9da5b3be00f1b73021f1d5f9dd46bf9c51b13442bbabd2c770f49c5aed7674b5426b11c2208d1dd49b30137b8b57
DIST Trac-1.0.11.tar.gz 3661250 SHA256 c3d0bdee4eebf107488e15248b54085da18a37508b76bfe647f6b74de471dba9 SHA512 c250853eba66f3e3996731f3cff6505c71c06b323a25d19ae311beeb9f45323b01687ed7bc865fba04c549a204eea1e7af5da000ab8706cf34dd0fcf39b42bd6 WHIRLPOOL 8be5bbd4eaca929d0be44f6024ba7852e097e78facdeb9c8b05580a2d25163d31def50882ad5e02bf2e4d36228de03938bb556be161e41ee39cf8cf34b2a6e1c
DIST Trac-1.0.12.tar.gz 6020514 SHA256 9e1d3b6b9f89f986b34604160a95cbda3fad1ee6d31818aab24bf8c18fe160ab SHA512 92b74212eed5b03212da6dbaca9ba52fa83fd16a030ce74fb1f308faee06c294b637887d50b661ac7e736c8e3264d923dbff3a64872b19b1757f57c1f8013ab3 WHIRLPOOL 1943c785c51962b725b4d6563fe36172e6a7a4f935389a68248fa42c9cb2cc916a2a53e721b3e1afcbfce42e2680df6fae853d2cd9c1cfc084604610a113ca1e
DIST Trac-1.0.13.tar.gz 3671741 SHA256 48ea3a9a23bb6bc7a9a643b90a7d7d274affedd344f21b73b81b421841cd527d SHA512 b4b2066482bdd6ba16183f2021bc069d1054177462726de1d844a28eccdc0b32405a0c510143f6ff84caaebebc571114e81cc0acc679ce94f8046b49d6854c1e WHIRLPOOL fc4151b5dc375a93413e3e1f23109644221eee6d741e442d03bccff6492c9cb816644783ec663b460279661fa8b50111456041094e531c8f24588af362ec4357
DIST Trac-1.0.9.tar.gz 3642845 SHA256 9ed3f0a2039c46132d10f35c211f9f6ee953339cc08492a41d1bf8741d6eebfa SHA512 af429db720049ab344ce3c3b430dcf0ab7530013f59ccd2334633de9babc3f31b14829b9b5aa48aa05f614ca72d1d557953c58bbfb93faae2267afeac72e6304 WHIRLPOOL 4005102b1109aac94728d22151c2192a38f9ab91af0227a24dff1a2e2097e67ceafa0cef0f307f1a1ddb1999c109d142bbb739107d4047dc296e6a8396a9427a
129 changes: 129 additions & 0 deletions www-apps/trac/trac-1.0.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,129 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='sqlite?'

DISTUTILS_SINGLE_IMPL=Yes

inherit distutils-r1 eutils user webapp

MY_PV=${PV/_p/.post}
MY_P=Trac-${MY_PV}

DESCRIPTION="Enhanced wiki and issue tracking system for software development projects"
HOMEPAGE="http://trac.edgewall.com/ https://pypi.python.org/pypi/Trac"
SRC_URI="http://ftp.edgewall.com/pub/trac/${MY_P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="cgi fastcgi i18n +highlight +restructuredtext mysql postgres +sqlite subversion test"
REQUIRED_USE="|| ( mysql postgres sqlite )"

RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/genshi[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
i18n? ( >=dev-python/Babel-0.9.5[${PYTHON_USEDEP}] )
highlight? (
|| (
dev-python/pygments[${PYTHON_USEDEP}]
app-text/silvercity
app-text/pytextile
app-text/enscript
)
)
restructuredtext? ( dev-python/docutils[${PYTHON_USEDEP}] )
cgi? ( virtual/httpd-cgi )
fastcgi? ( virtual/httpd-fastcgi )
mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
postgres? ( >=dev-python/psycopg-2[${PYTHON_USEDEP}] )
sqlite? ( >=dev-db/sqlite-3.3.4:3 )
subversion? ( dev-vcs/subversion[python,${PYTHON_USEDEP}] )
"
DEPEND="${RDEPEND}
test? (
dev-python/twill[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
)"

S="${WORKDIR}/${MY_P}"

WEBAPP_MANUAL_SLOT="yes"

pkg_setup() {
python-single-r1_pkg_setup
webapp_pkg_setup

enewgroup tracd
enewuser tracd -1 -1 -1 tracd
}

python_prepare_all() {
distutils-r1_python_prepare_all
}

src_test() {
distutils-r1_src_test
}

python_test() {
PYTHONPATH=. "${PYTHON}" trac/test.py || die "Tests fail with ${EPYTHON}"
}

python_test_all() {
if use i18n; then
make check
fi
}

python_install() {
if use cgi; then
python_scriptinto "${MY_CGIBINDIR}"
python_doscript contrib/cgi-bin/trac.cgi
fi
if use fastcgi; then
python_scriptinto "${MY_CGIBINDIR}"
python_doscript contrib/cgi-bin/trac.fcgi
fi
distutils-r1_python_install
}

# the default src_compile just calls setup.py build
# currently, this switches i18n catalog compilation based on presence of Babel

src_install() {
webapp_src_preinst
distutils-r1_src_install

# project environments might go in here
keepdir /var/lib/trac

# Use this as the egg-cache for tracd
dodir /var/lib/trac/egg-cache
keepdir /var/lib/trac/egg-cache
fowners tracd:tracd /var/lib/trac/egg-cache

# documentation
dodoc -r contrib

# tracd init script
newconfd "${FILESDIR}"/tracd.confd tracd
newinitd "${FILESDIR}"/tracd.initd tracd

for lang in en; do
webapp_postinst_txt ${lang} "${FILESDIR}"/postinst-${lang}.txt
webapp_postupgrade_txt ${lang} "${FILESDIR}"/postupgrade-${lang}.txt
done

webapp_src_install
}

pkg_postinst() {
webapp_pkg_postinst
}

0 comments on commit 47c8c29

Please sign in to comment.