Skip to content

Commit

Permalink
dev-util/valgrind: fix tests w/ gcc 13
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jan 30, 2023
1 parent 5ee2ced commit 47e9795
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
44 changes: 44 additions & 0 deletions dev-util/valgrind/files/valgrind-3.20.0-gcc-13.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
https://sourceware.org/git/?p=valgrind.git;a=commit;h=dee222c6e818ca43ac45952fc8a020f445d98781
https://sourceware.org/git/?p=valgrind.git;a=commit;h=3155bacf26237beb65edb4a572402492b2f1b050

From dee222c6e818ca43ac45952fc8a020f445d98781 Mon Sep 17 00:00:00 2001
From: Paul Floyd <[email protected]>
Date: Fri, 27 Jan 2023 08:30:41 +0100
Subject: [PATCH] Bug 464859 - Build failures with GCC-13 (drd tsan_unittest)

Patch submitted by
Khem Raj <[email protected]>
--- a/drd/tests/tsan_thread_wrappers_pthread.h
+++ b/drd/tests/tsan_thread_wrappers_pthread.h
@@ -55,6 +55,7 @@
#define NO_TLS
#endif

+#include <cstdint>
#include <string>
using namespace std;

--
2.31.1

From 3155bacf26237beb65edb4a572402492b2f1b050 Mon Sep 17 00:00:00 2001
From: Mark Wielaard <[email protected]>
Date: Sat, 28 Jan 2023 21:53:44 +0100
Subject: [PATCH] tsan_thread_wrappers_pthread.h: Only include cstdint for
C++11

Fixes build on older g++.
--- a/drd/tests/tsan_thread_wrappers_pthread.h
+++ b/drd/tests/tsan_thread_wrappers_pthread.h
@@ -55,7 +55,9 @@
#define NO_TLS
#endif

+#if __cplusplus >= 201103L
#include <cstdint>
+#endif
#include <string>
using namespace std;

--
2.31.1
1 change: 1 addition & 0 deletions dev-util/valgrind/valgrind-3.20.0-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -33,6 +33,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
"${FILESDIR}"/${PN}-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
"${FILESDIR}"/${P}-tests-clang16.patch
"${FILESDIR}"/${P}-gcc-13.patch
)

src_prepare() {
Expand Down

0 comments on commit 47e9795

Please sign in to comment.