forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-shell-extensions: bump to 3.30.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <[email protected]>
- Loading branch information
Showing
3 changed files
with
83 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
81 changes: 81 additions & 0 deletions
81
gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.30.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,81 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit gnome.org readme.gentoo-r1 meson xdg | ||
|
||
DESCRIPTION="JavaScript extensions for GNOME Shell" | ||
HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell/Extensions" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
IUSE="examples test" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
COMMON_DEPEND=" | ||
>=dev-libs/glib-2.26:2 | ||
>=gnome-base/libgtop-2.28.3[introspection] | ||
>=app-eselect/eselect-gnome-shell-extensions-20111211 | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
>=dev-libs/gjs-1.29 | ||
dev-libs/gobject-introspection:= | ||
dev-libs/atk[introspection] | ||
gnome-base/gnome-menus:3[introspection] | ||
>=gnome-base/gnome-shell-3.30 | ||
media-libs/clutter:1.0[introspection] | ||
net-libs/telepathy-glib[introspection] | ||
x11-libs/gdk-pixbuf:2[introspection] | ||
x11-libs/gtk+:3[introspection] | ||
x11-libs/pango[introspection] | ||
x11-themes/adwaita-icon-theme | ||
>=x11-wm/mutter-3.30[introspection] | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
dev-lang/sassc | ||
>=sys-devel/gettext-0.19.8 | ||
virtual/pkgconfig | ||
test? ( dev-lang/spidermonkey:52 ) | ||
" | ||
|
||
RESTRICT="!test? ( test )" | ||
|
||
DISABLE_AUTOFORMATTING="yes" | ||
DOC_CONTENTS="Installed extensions installed are initially disabled by default. | ||
To change the system default and enable some extensions, you can use | ||
# eselect gnome-shell-extensions | ||
Alternatively, to enable/disable extensions on a per-user basis, | ||
you can use the https://extensions.gnome.org/ web interface, the | ||
gnome-extra/gnome-tweaks GUI, or modify the org.gnome.shell | ||
enabled-extensions gsettings key from the command line or a script." | ||
|
||
src_configure() { | ||
meson_src_configure \ | ||
-Dextension_set=all \ | ||
-Dclassic_mode=true | ||
} | ||
|
||
src_install() { | ||
meson_src_install | ||
|
||
local example="[email protected]" | ||
if use examples; then | ||
mv "${ED}usr/share/gnome-shell/extensions/${example}" \ | ||
"${ED}usr/share/doc/${PF}/" || die | ||
else | ||
rm -r "${ED}usr/share/gnome-shell/extensions/${example}" || die | ||
fi | ||
|
||
readme.gentoo_create_doc | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
|
||
ebegin "Updating list of installed extensions" | ||
eselect gnome-shell-extensions update | ||
eend $? | ||
|
||
readme.gentoo_print_elog | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -92,6 +92,7 @@ media-video/get_flash_videos | |
~net-irc/polari-3.30.2 | ||
~x11-wm/mutter-3.30.2 | ||
~gnome-base/gnome-shell-3.30.2 | ||
~gnome-extra/gnome-shell-extensions-3.30.1 | ||
|
||
# Lars Wendler <[email protected]> (17 Mar 2019) | ||
# Breaks user crontab (#680764) | ||
|