Skip to content

Commit

Permalink
media-gfx/ufraw: Fix build with exiv2-0.27
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Dec 29, 2018
1 parent 2ab36b4 commit 47eba01
Show file tree
Hide file tree
Showing 2 changed files with 27 additions and 1 deletion.
25 changes: 25 additions & 0 deletions media-gfx/ufraw/files/ufraw-0.22-exiv2-0.27.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
--- a/ufraw_exiv2.cc 2015-06-16 05:58:38.000000000 +0200
+++ b/ufraw_exiv2.cc 2018-12-29 22:51:23.291894430 +0100
@@ -15,9 +15,7 @@
#include "ufraw.h"

#ifdef HAVE_EXIV2
-#include <exiv2/image.hpp>
-#include <exiv2/easyaccess.hpp>
-#include <exiv2/exif.hpp>
+#include <exiv2/exiv2.hpp>
#include <sstream>
#include <cassert>

@@ -67,7 +65,11 @@
if (exifData.empty()) {
std::string error(uf->filename);
error += ": No Exif data found in the file";
+#if EXIV2_TEST_VERSION(0,27,0)
+ throw Exiv2::Error(Exiv2::kerErrorMessage, error);
+#else
throw Exiv2::Error(1, error);
+#endif
}

/* List of tag names taken from exiv2's printSummary() in actions.cpp */
3 changes: 2 additions & 1 deletion media-gfx/ufraw/ufraw-0.22-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -44,6 +44,7 @@ PATCHES=(
"${FILESDIR}"/${P}-drop_superfluous_abs.patch
"${FILESDIR}"/${P}-fix-unsigned-char.patch
"${FILESDIR}"/${P}-jpeg9.patch
"${FILESDIR}"/${P}-exiv2-0.27.patch
)

src_prepare() {
Expand Down

0 comments on commit 47eba01

Please sign in to comment.