Skip to content

Commit

Permalink
app-forensics/yara: add 4.5.1
Browse files Browse the repository at this point in the history
Signed-off-by: Mario Haustein <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
hamarituc authored and thesamesam committed May 28, 2024
1 parent b67f74e commit 4839b32
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-forensics/yara/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST yara-4.4.0.tar.gz 2220068 BLAKE2B f9654592f3dbe493dc31bcda80c9f0e31a2a8998f47d1172afe7456a9d4ead8f475e3f0999140c952343cdeca1cedc8060a3b42c1bbe57ce617fd5b5a86dbfb3 SHA512 705db57b73e5165a26e0aaea728521f372b9f7f613665860dd22066c30e75a614815fb17ee8654780fcfc157f0137cbeda015ec088a698f31adcf071e233205f
DIST yara-4.5.0.tar.gz 2206492 BLAKE2B 788ed6c4989bbc2d0a113b46bcd1291e7544ab8f56ebe499725163b7b02feb016935210e8a08d9cb179fbffc09fafb461cc55156101d9616a23a480a78862d9e SHA512 c9fe8a89879d1a742236101f1754e6b25e70356cdf5c020b2583e3ac509600c3b462756c412b01f2ebcb17df351c83afcf04d1cfaa87e6753eb25bab0f797aa3
DIST yara-4.5.1.tar.gz 2207552 BLAKE2B b8983371e3ec6f0fd4208698742a576d3c76e1ce34b7ebbc10c7b414f663b570c812c10dce8eefe32f4cf6cffe033bb63a05987068c49e9235077e20d96ca06d SHA512 8bf1df7089f9bc5a448dbae0999e04f4ecdec06b4478e2cb5f42a2a3201b99fce68379e3f8f7c67a9db201205366250d7befe5c38451cced807ed692d436422c
60 changes: 60 additions & 0 deletions app-forensics/yara/yara-4.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools

DESCRIPTION="A malware identification and classification tool"
HOMEPAGE="https://virustotal.github.io/yara/"

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/VirusTotal/yara.git"
else
SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${PV/_/-}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi

LICENSE="Apache-2.0"
SLOT="0/10"
IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
RESTRICT="!test? ( test )"

DEPEND="
dev-libs/openssl:=
cuckoo? ( dev-libs/jansson:= )
magic? ( sys-apps/file:= )
"
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"

src_prepare() {
default
eautoreconf
}

src_configure() {
econf \
$(use_enable profiling) \
$(use_enable cuckoo) \
$(use_enable magic) \
$(use_enable dotnet) \
$(use_enable macho) \
$(use_enable dex) \
$(use_enable test static)
}

src_test() {
emake check
}

src_install() {
default

# TODO: Allow tests to work against dyn. lib rather than building
# statically just for tests.
find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
}

0 comments on commit 4839b32

Please sign in to comment.