Skip to content

Commit

Permalink
app-emulation/open-vm-tools: add 12.4.5
Browse files Browse the repository at this point in the history
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Jul 10, 2024
1 parent ba7a37a commit 483c065
Show file tree
Hide file tree
Showing 2 changed files with 141 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/open-vm-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST open-vm-tools-12.2.0-21223074.tar.gz 4365836 BLAKE2B ecac1ada523b9ba6e6f9e880f700a9c35200e9093c81f3367ce3b196365166f682f7d8ba290f624417b83c3573894020fe6b4cbd82a117412ebe80df283f32db SHA512 d663d8ea455264cad7d3eaac16c5d08672e8e10f7a9171be40fff69e208ae697bc0e8af498c978d8de470ed273351b42c54994b2c552fdc05b828c80f4826b84
DIST open-vm-tools-12.2.5-21855600.tar.gz 4365531 BLAKE2B 1df621aea3d349af45c41268f3ab9ef6dc012bc7b74b8ff399a3819f75c92b408f272c03e31ff74d7f1aceda8a88e5755064236b87403d8ef2717567de174434 SHA512 72db3b88f61624d26e8ff7e37e4fc52ecd0bec0b6f076d935870c03312321c5e0b406d05eae7012872734a50626ed760dff2cf872e26ec18ebf200aff5ed12ef
DIST open-vm-tools-12.4.5-23787635.tar.gz 4356612 BLAKE2B 59fab76bc740d6c8e8b76f8c2379f751a62a4d4c01add9520acafbd5601d9490c7fb7d5a3631d1198c811be33b1bd7c7b381de2f9a8f703ceec21aab6331797a SHA512 dd90622a0f1c773ed217040788a1bdbfba1e60256d4e5159a2557155f6ac642ab71488044860e417cdd853aad77a6495b98e8fd02f9755be90cc1dc71c840a3c
140 changes: 140 additions & 0 deletions app-emulation/open-vm-tools/open-vm-tools-12.4.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,140 @@
# Copyright 2007-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools linux-info pam systemd udev

MY_P="${P}-23787635"

DESCRIPTION="Tools for VMware guests"
HOMEPAGE="https://github.com/vmware/open-vm-tools"
SRC_URI="https://github.com/vmware/open-vm-tools/releases/download/stable-${PV}/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="X +deploypkg +dnet doc +fuse gtkmm +icu multimon pam +resolutionkms +ssl +vgauth"
REQUIRED_USE="
multimon? ( X )
vgauth? ( ssl )"

RDEPEND="
dev-libs/glib
net-libs/libtirpc
deploypkg? ( dev-libs/libmspack )
fuse? ( sys-fs/fuse:0 )
pam? ( sys-libs/pam )
!pam? ( virtual/libcrypt:= )
ssl? ( dev-libs/openssl:= )
vgauth? (
dev-libs/libxml2
dev-libs/xmlsec:=
)
X? (
x11-libs/gdk-pixbuf-xlib
x11-libs/gtk+:3
x11-libs/libSM
x11-libs/libXcomposite
x11-libs/libXext
x11-libs/libXi
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXtst
gtkmm? (
dev-cpp/gtkmm:3.0
dev-libs/libsigc++:2
)
multimon? ( x11-libs/libXinerama )
)
dnet? ( dev-libs/libdnet )
icu? ( dev-libs/icu:= )
resolutionkms? (
x11-libs/libdrm[video_cards_vmware]
virtual/libudev
)"
DEPEND="${RDEPEND}
net-libs/rpcsvc-proto"
BDEPEND="
dev-util/glib-utils
virtual/pkgconfig
doc? ( app-text/doxygen )"

PATCHES=(
"${FILESDIR}"/10.1.0-Werror.patch
"${FILESDIR}"/11.3.5-icu.patch
)

pkg_setup() {
local CONFIG_CHECK="~VMWARE_BALLOON ~VMWARE_PVSCSI ~VMXNET3 ~VMWARE_VMCI ~VMWARE_VMCI_VSOCKETS ~FUSE_FS"
use X && CONFIG_CHECK+=" ~DRM_VMWGFX"
kernel_is -lt 5 5 || CONFIG_CHECK+=" ~X86_IOPL_IOPERM"
linux-info_pkg_setup
}

src_prepare() {
eapply -p2 "${PATCHES[@]}"
eapply_user
eautoreconf
}

src_configure() {
local myeconfargs=(
--disable-glibc-check
--disable-tests
--without-root-privileges
$(use_enable multimon)
$(use_with X x)
$(use_with X gtk3)
$(use_with gtkmm gtkmm3)
$(use_enable doc docs)
$(use_enable resolutionkms)
$(use_enable deploypkg)
$(use_with pam)
$(use_enable vgauth)
$(use_with dnet)
$(use_with icu)
--with-udev-rules-dir="$(get_udevdir)"/rules.d
)
# Avoid a bug in configure.ac
use ssl || myeconfargs+=( --without-ssl )

econf "${myeconfargs[@]}"
}

src_install() {
default
find "${ED}" -name '*.la' -delete || die

if use pam; then
rm "${ED}"/etc/pam.d/vmtoolsd || die
pamd_mimic_system vmtoolsd auth account
fi

newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools
newconfd "${FILESDIR}/open-vm-tools.confd" vmware-tools

if use vgauth; then
systemd_newunit "${FILESDIR}"/vmtoolsd.vgauth.service vmtoolsd.service
systemd_dounit "${FILESDIR}"/vgauthd.service
else
systemd_dounit "${FILESDIR}"/vmtoolsd.service
fi

# Make fstype = vmhgfs-fuse work in fstab
dosym vmhgfs-fuse /usr/bin/mount.vmhgfs-fuse

if use X; then
fperms 4711 /usr/bin/vmware-user-suid-wrapper
dobin scripts/common/vmware-xdg-detect-de
fi
}

pkg_postinst() {
udev_reload
}

pkg_postrm() {
udev_reload
}

0 comments on commit 483c065

Please sign in to comment.