Skip to content

Commit

Permalink
sys-cluster/kube-proxy: Version bump to 1.15.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Manuel Rüger <[email protected]>
  • Loading branch information
mrueg committed Aug 5, 2019
1 parent cc32c80 commit 4850d18
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-cluster/kube-proxy/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST kubernetes-1.14.3.tar.gz 28058624 BLAKE2B 11a1bd98cf6270e0035d6f01a3b14cce6
DIST kubernetes-1.14.4.tar.gz 28066996 BLAKE2B 1738564f1a6406d934faf10f1f7dd380f9c12bf522e5a1394e591da27865695abe8f015a2776907414b335ffa619283b675b6eb9cc1de923665c027d38d80d29 SHA512 b221c34e980965c9973d2fc576fd8f55488e2d0cd7b8e03fac5f9b5a807eb604cf2230f6feb975759f893454891bdea7abd6362b948cae1469dc5c1570f93c40
DIST kubernetes-1.14.5.tar.gz 28071522 BLAKE2B 1d949f53ebae03c5ce02d32253e85e96c7c0fef85d16dac8442ca379b980ba553d1602a5ae5e984eb6ae5abe5998155f62521292a3683612a251e7b81c940b05 SHA512 3c15c3663fd81dbbfbfa15219cbf94306af1cb846f9e3a6739db8c188d90b8ae25c601e0c746e93c13cbc4734fe612f9b5ca42fad97055903ccc473e5f3e15c3
DIST kubernetes-1.15.0.tar.gz 26591862 BLAKE2B 114ae651bb1827913ff5294878956b46dba288928b9fec45796ce5f3c01ab611a7333bd955fb96e7fe970a9f4afc901570ff911dd946c1a72ff8e2c6b3bc927a SHA512 764268020e0fc27e8325058fefbc53200996e5a8f963c9156cf079425cdfed7545522ff8c779bfa074db8739e3ab97e829a049deaf0a0568f1434d7c1ed8446b
DIST kubernetes-1.15.2.tar.gz 26628888 BLAKE2B 49c72f9355e1bb00f743571f4253261b46d58fe6252b1f9284d0982a201502ef13ccc77da588087e407a7d6ed250d1ab224b9fcf99d2542225d6736a8dffb4d9 SHA512 0de798631a3bf82766b797f05084f40df4422808c8ec8651480c5c27ecd4adb51148d15c7260b06482eba11c9bbb68966abc03a2d472b98d12cb0fe2ccf38473
44 changes: 44 additions & 0 deletions sys-cluster/kube-proxy/kube-proxy-1.15.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit golang-build golang-vcs-snapshot

EGO_PN="k8s.io/kubernetes"
ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Kubernetes Proxy service"
HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
SRC_URI="${ARCHIVE_URI}"

LICENSE="Apache-2.0"
SLOT="0"

DEPEND="dev-go/go-bindata
>=dev-lang/go-1.11"

RDEPEND="net-firewall/conntrack-tools"

RESTRICT="test"

src_prepare() {
default
sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" src/${EGO_PN}/hack/lib/golang.sh || die
sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
}

src_compile() {
LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN} GOFLAGS=-v
}

src_install() {
pushd src/${EGO_PN} || die
dobin _output/bin/${PN}
popd || die
keepdir /var/log/${PN} /var/lib/${PN}
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
insinto /etc/logrotate.d
newins "${FILESDIR}"/${PN}.logrotated ${PN}
}

0 comments on commit 4850d18

Please sign in to comment.