Skip to content

Commit

Permalink
media-sound/tomahawk: Try to fix build with <cmake-3.10
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/674826
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jan 26, 2019
1 parent f821cae commit 488d531
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 2 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
From 663981b4dd28fca6cac0b079bed26c411e7d1722 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <[email protected]>
Date: Fri, 25 Jan 2019 21:13:05 +0100
Subject: [PATCH] Fix build with <cmake-3.10

---
CMakeLists.txt | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index b44d2ee43..9422a808e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,14 +2,18 @@ PROJECT( tomahawk )
CMAKE_MINIMUM_REQUIRED( VERSION 2.8.12 )
CMAKE_POLICY(SET CMP0017 NEW)
CMAKE_POLICY(SET CMP0022 NEW)
-CMAKE_POLICY(SET CMP0075 NEW)
+IF(POLICY CMP0075)
+ CMAKE_POLICY(SET CMP0075 NEW)
+ENDIF()

# TODO:
# Update to NEW and fix things up
CMAKE_POLICY(SET CMP0023 NEW)

# Let AUTOMOC and AUTOUIC process generated files
-CMAKE_POLICY(SET CMP0071 NEW)
+IF(POLICY CMP0071)
+ CMAKE_POLICY(SET CMP0071 NEW)
+ENDIF()

# TODO:
# Disable automatic qtmain linking
--
2.20.1

7 changes: 5 additions & 2 deletions media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Authors
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -53,7 +53,10 @@ RDEPEND="${COMMON_DEPEND}

S="${WORKDIR}/${PN}-${COMMIT}"

PATCHES=( "${FILESDIR}/${P}-fix-warning.patch" )
PATCHES=(
"${FILESDIR}/${P}-fix-warning.patch"
"${FILESDIR}/${P}-cmakepolicy.patch" # bug 674826
)

src_configure() {
local mycmakeargs=(
Expand Down

0 comments on commit 488d531

Please sign in to comment.