forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-action/supertuxkart: bump to 1.0
- Unbundle angelscript - New deps nettle || openssl Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://bugs.gentoo.org/683930 Signed-off-by: François-Xavier Carton <[email protected]> Closes: gentoo#11865 Signed-off-by: James Le Cuirot <[email protected]>
- Loading branch information
Showing
4 changed files
with
118 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST supertuxkart-0.9.3-src.tar.xz 544517772 BLAKE2B 84ab64371a59bf302905181ad98dd12542a9ffda18b9081ecfa6fcbb61d89c6b1f76f3598184459bbb40a42a1c968767837e76bbd0c9b2ade6b4c18831bc61fb SHA512 29eb1d8fb8e336453e590273089af09eac9a563f82c0bc797d43d5e21d5c9d1274a84ea7ee46487b3d127c47e55e3d233ad7e0e8c502c15dbafc1cc0f5c861c9 | ||
DIST supertuxkart-1.0-src.tar.xz 597012504 BLAKE2B ed1b851bad8696b4593c54f215b115528afc29bde237f67627e2918c4a9fab09eddc204d0c879fa85c6b10b5544dba5fa5fc1b437cb83e6d884ac717e3369c28 SHA512 182754610abd09545630fa1f7fda858ba1731bbacb078bc71597e143f9cb2a1cfcedd3038720760d0471a89b79cc3bb1eb292d38fcd53be05aad7cb17c474ca9 | ||
DIST supertuxkart.png 4435 BLAKE2B b48b95e1cdebe930837cc784c4c5e9a089a69077e2fcfed15fe5e8c4d649a0f8024769b2f2102bbaea3a94eb21f4b58b5d291b97493266c3c5c8d7335cf69a80 SHA512 a180332f79220431922fa8b351cb476ebc5d9d1df09f20707eb3bdd7002fd264cb027b8190c73c5221050e6e8601beb6758a5809d05aedfb18f0bdb426f47eda |
20 changes: 20 additions & 0 deletions
20
games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
diff --git a/lib/irrlicht/CMakeLists.txt b/lib/irrlicht/CMakeLists.txt | ||
index 92a881c81..1371fdf11 100644 | ||
--- a/lib/irrlicht/CMakeLists.txt | ||
+++ b/lib/irrlicht/CMakeLists.txt | ||
@@ -96,15 +96,6 @@ endif() | ||
if(WIN32) | ||
add_definitions(-D_IRR_STATIC_LIB_) | ||
add_definitions(-D_CRT_SECURE_NO_WARNINGS) # Shut up about unsafe stuff | ||
-else() | ||
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing") | ||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing") | ||
- if(CMAKE_COMPILER_IS_GNUCC) | ||
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fexpensive-optimizations") | ||
- endif() | ||
- if(CMAKE_COMPILER_IS_GNUCXX) | ||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fexpensive-optimizations") | ||
- endif() | ||
endif() | ||
|
||
if(USE_GLES2) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,96 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-utils desktop gnome2-utils | ||
|
||
DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)" | ||
HOMEPAGE="https://supertuxkart.net/" | ||
SRC_URI="mirror://sourceforge/${PN}/SuperTuxKart/${PV}/${P}-src.tar.xz | ||
mirror://gentoo/${PN}.png" | ||
|
||
LICENSE="GPL-2 GPL-3 CC-BY-SA-3.0 CC-BY-2.0 public-domain ZLIB" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="debug fribidi libressl nettle recorder wiimote" | ||
|
||
# don't unbundle irrlicht and bullet | ||
# both are modified and system versions will break the game | ||
# https://sourceforge.net/p/irrlicht/feature-requests/138/ | ||
|
||
RDEPEND=" | ||
dev-libs/angelscript:= | ||
media-libs/glew:0= | ||
media-libs/libpng:0= | ||
media-libs/libvorbis | ||
media-libs/openal | ||
net-libs/enet:1.3= | ||
net-misc/curl | ||
sys-libs/zlib | ||
virtual/glu | ||
virtual/jpeg:0 | ||
virtual/libintl | ||
virtual/opengl | ||
x11-libs/libX11 | ||
x11-libs/libXxf86vm | ||
fribidi? ( dev-libs/fribidi ) | ||
nettle? ( dev-libs/nettle:= ) | ||
!nettle? ( | ||
libressl? ( dev-libs/libressl:= ) | ||
!libressl? ( >=dev-libs/openssl-1.0.1d:0= ) | ||
) | ||
recorder? ( media-libs/libopenglrecorder ) | ||
wiimote? ( net-wireless/bluez )" | ||
DEPEND="${RDEPEND} | ||
sys-devel/gettext | ||
virtual/pkgconfig" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${PN}-0.9.3-irrlicht-arch-support.patch | ||
"${FILESDIR}"/${PN}-0.9.3-irrlicht-system-libs.patch | ||
"${FILESDIR}"/${PN}-1.0-fix-buildsystem.patch | ||
) | ||
|
||
src_prepare() { | ||
cmake-utils_src_prepare | ||
|
||
# remove bundled libraries, just to be sure | ||
rm -r lib/{angelscript,enet,glew,jpeglib,libpng,zlib} || die | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DUSE_SYSTEM_ANGELSCRIPT=ON | ||
-DUSE_SYSTEM_ENET=ON | ||
-DUSE_SYSTEM_GLEW=ON | ||
-DUSE_SYSTEM_WIIUSE=OFF | ||
-DUSE_CRYPTO_OPENSSL=$(usex nettle no yes) | ||
-DENABLE_WAYLAND_DEVICE=OFF | ||
-DUSE_FRIBIDI=$(usex fribidi) | ||
-DBUILD_RECORDER=$(usex recorder) | ||
-DUSE_WIIUSE=$(usex wiimote) | ||
-DSTK_INSTALL_BINARY_DIR=bin | ||
-DSTK_INSTALL_DATA_DIR=share/${PN} | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
dodoc CHANGELOG.md | ||
|
||
doicon -s 64 "${DISTDIR}"/${PN}.png | ||
} | ||
|
||
pkg_preinst() { | ||
gnome2_icon_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_icon_cache_update | ||
} |