forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/semantic_version: Fix tests
Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
26 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST semantic_version-2.6.0-1.tar.gz 31678 SHA256 110d9c75dc9670a188ab820503c6b40ea4ab3f1450a0aee5a90a24fd60aef358 SHA512 18db9279c2728565b13362c54bedbf569f0878cbe6bb58e631d87ffe7cff7d9131a30a2592cbf511091c03e854851159bbb298fe7469f53e8a2d92cf26ab4d0b WHIRLPOOL 1e9b0411ffe00d0544e71b3b71e78f3f6b858bb75bcf2db92bc86334f97f2c2d796924a477ddd5c43d4a1d16d70e4fce78fe9cebdfeae2836adfafb425475abc | ||
DIST semantic_version-2.6.0.tar.gz 13919 SHA256 2a4328680073e9b243667b201119772aefc5fc63ae32398d6afafff07c4f54c0 SHA512 805449e7219aaa59d28cc267c27a6abab5cbbbfd52c72d66f24bcace39c9f864e4ed944a3dc614e14a700a5bc92272fa6420312f3169b01a4cfd9ddf3ffb42d6 WHIRLPOOL 293dec8e54ea1214891642e87972955f41286f1d4ef76f59a62a00996588a43aadfec893f451aa1733186f4d76ca67a2efe496f2f20412359c08fb11d5de1206 |
25 changes: 25 additions & 0 deletions
25
dev-python/semantic_version/semantic_version-2.6.0-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Python library providing a few tools handling SemVer in Python" | ||
HOMEPAGE="https://pypi.python.org/pypi/semantic_version" | ||
SRC_URI="https://github.com/rbarrois/python-semanticversion/archive/v${PV}.tar.gz -> ${P}-1.tar.gz" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
IUSE="test" | ||
|
||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( dev-python/django[${PYTHON_USEDEP}] )" | ||
|
||
S=${WORKDIR}/python-${P/_/} | ||
|
||
python_test() { | ||
esetup.py test | ||
} |