Skip to content

Commit

Permalink
games-rpg/runescape-launcher: new ebuild, (binary) initial vn. 2.2.2
Browse files Browse the repository at this point in the history
To be maintained by user Jack Coulter under the Proxy Maintainers Project
initial ebuild supplied as attachment via the gentoo bug.
This package required a new license, added under the group 'EULA'

Gnetoo-bug: #580486

Package-Manager: portage-2.3.0_rc1
  • Loading branch information
Ian Delaney committed May 20, 2016
1 parent 51bb1ab commit 48c915c
Show file tree
Hide file tree
Showing 3 changed files with 97 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-rpg/runescape-launcher/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST runescape-launcher_2.2.2_amd64.deb 2069098 SHA256 d13051e277ad89b788252b08d4d2c7a3b060f87f41457232638d6f2b19b4cfe9 SHA512 be24aaf661fb89725c19675ea8626dc2cdac64254c7fd9e892b82e038033657dfd5dfc58537e5131fad524d11717e3b20cc824ced6e1940ce7925daaef043df5 WHIRLPOOL fca1fc4e5e0cabb3871290b8033342ba2e0d9e323038158ba9c5654113a248d90f5ca01d3394f0cd047e7c29f3593bbeba3ba0f3eb76d4a2c8d06d39104289aa
12 changes: 12 additions & 0 deletions games-rpg/runescape-launcher/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Jack Coulter</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
</pkgmetadata>
84 changes: 84 additions & 0 deletions games-rpg/runescape-launcher/runescape-launcher-2.2.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit unpacker xdg gnome2-utils

DESCRIPTION="Official RuneScape NXT client launcher"
HOMEPAGE="http://www.runescape.com"

SRC_URI="http://content.runescape.com/downloads/ubuntu/pool/non-free/r/${PN}/${PN}_${PV}_amd64.deb"

QA_PREBUILT="/opt/runescape-launcher/runescape"

SLOT="0"

IUSE="kde"

KEYWORDS="-* ~amd64"

LICENSE="RuneScape-EULA"
RESTRICT="bindist mirror strip"

S="${WORKDIR}"

RDEPEND="
media-libs/libpng:1.2
>=media-libs/libsdl2-2.0.2
>=media-libs/glew-1.10.0:0/1.10
>=media-libs/libvorbis-1.3.2
>=net-libs/webkit-gtk-2.4.8:2
>=net-misc/curl-7.35.0
"

src_prepare() {
# Fix path in launcher script
sed -i "s:/usr/share/games/$PN:/opt/$PN:" usr/bin/$PN

# Add missing trailing semicolon to .desktop MimeType entry
sed -i '/MimeType=/{/;$/!{s/$/;/}}' usr/share/applications/${PN}.desktop

# Fix path to launcher script
sed -i "s:/usr/bin/$PN:/opt/bin/$PN:" usr/share/applications/${PN}.desktop

xdg_src_prepare

eapply_user
}

src_install() {
into /opt
dobin usr/bin/$PN
dodoc usr/share/doc/$PN/*

exeinto /opt/$PN
doexe usr/share/games/$PN/runescape

insinto /usr/share/applications
doins usr/share/applications/${PN}.desktop

insinto /usr/share/icons
doins -r usr/share/icons/hicolor

if use kde ; then
insinto /usr/share/kde4
doins -r usr/share/kde4/services
fi
}

pkg_preinst() {
xdg_pkg_preinst
gnome2_icon_savelist
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_icon_cache_update
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_icon_cache_update
}

0 comments on commit 48c915c

Please sign in to comment.