forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Michael Vetter <[email protected]> Closes: gentoo#31729 Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
53868bd
commit 48d0eac
Showing
3 changed files
with
37 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST codespell-2.2.4.tar.gz 241664 BLAKE2B 5f40003fdb840b926615b6eed74df90055b2ee47c534321289c3ed895c47cd2672909b152a53640899cc21960c1b3aa80c41eb344d9e23cea8fd13e998c71af6 SHA512 efbc62a3dd49781565f6d901aa9b08fc1106adf2c516365dd8d3684846e23b23bfda1e65c6530edf0de9462ccafd9d835bd541a8f0e1de14163c723ce041052d | ||
DIST codespell-2.2.5.tar.gz 242918 BLAKE2B 18b4ff620edb54950ba2779ec610f15597d0aef5e4dded3ed2055ce7769e16d70dbac9cf990b2bdb6c216f8f6204e4a7790fe011ec53057553ca6981b4d8c851 SHA512 173eb13695ceccb4bb081907fc8d703e91922ec7adddc150aa2db1629353edff464c2318f2abaf78e8c96ab28f08e510897912f5bd48d69a6c50e025d470b53f |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,23 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( python3_{9..11} pypy3 ) | ||
|
||
inherit distutils-r1 pypi | ||
|
||
DESCRIPTION="Check text files for common misspellings" | ||
HOMEPAGE="https://pypi.org/project/codespell https://github.com/codespell-project/codespell" | ||
|
||
# Code licensed under GPL-2, dictionary licensed under CC-BY-SA-3.0 | ||
LICENSE="GPL-2 CC-BY-SA-3.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
|
||
BDEPEND="test? ( dev-python/chardet[${PYTHON_USEDEP}] )" | ||
|
||
PATCHES=( "${FILESDIR}"/${PN}-2.2.5-drop-coverage.patch ) | ||
|
||
distutils_enable_tests pytest |
13 changes: 13 additions & 0 deletions
13
dev-util/codespell/files/codespell-2.2.5-drop-coverage.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
diff -urEbw codespell-2.2.5/pyproject.toml codespell-2.2.5.new/pyproject.toml | ||
--- codespell-2.2.5/pyproject.toml 2023-06-14 19:28:54.000000000 +0200 | ||
+++ codespell-2.2.5.new/pyproject.toml 2023-07-03 16:19:11.225597607 +0200 | ||
@@ -99,7 +99,7 @@ | ||
strict = true | ||
|
||
[tool.pytest.ini_options] | ||
-addopts = "--cov=codespell_lib -rs --cov-report= --tb=short --junit-xml=junit-results.xml" | ||
+addopts = "-rs --cov-report= --tb=short --junit-xml=junit-results.xml" | ||
|
||
[tool.ruff] | ||
extend-ignore = [ | ||
|