Skip to content

Commit

Permalink
www-client/microsoft-edge-beta: bump to 93.0.961.33
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Stephan Hartmann <[email protected]>
  • Loading branch information
stha09 committed Aug 28, 2021
1 parent dc30e26 commit 48d30f0
Show file tree
Hide file tree
Showing 2 changed files with 106 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-client/microsoft-edge-beta/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST microsoft-edge-beta_92.0.902.62-1_amd64.deb 101311562 BLAKE2B f116c5d13307f
DIST microsoft-edge-beta_93.0.961.18-1_amd64.deb 104386268 BLAKE2B f8ff78aeeffa521bfd9c36047ce138342595fe85ebe14c8d048fe16990403bc7f119632b7ce57f31a26185a13bb7c9c3db2dcffd753e2f9b12d822a23a6dbd1f SHA512 8bb52d16119677d386fdfac9ab9d0026b776fff99ca0c64eed760948880214f6daa0955a092e4bb82159e113d95f0869ac2a9111004ec06b7e0be235a9d4eee3
DIST microsoft-edge-beta_93.0.961.24-1_amd64.deb 104460716 BLAKE2B 66cbc91a7576cd47131e1774b791758879e862502c7e66e8171eaffa64a15fbb2211cf4f3b716e65471aee89f559e3ac802d01d213ab30468ba9051d3099bf9a SHA512 d6aa0d8a828337e1fb8768f756b836b7c0197b565acd0195f8a4dd226fa5e7b40a10520742507284987b7fe804ae306a90ab5a8af0ec5faeda224100c94bfc7b
DIST microsoft-edge-beta_93.0.961.27-1_amd64.deb 104495696 BLAKE2B a1ff618dc7f5cbcc8daf14493403e45c59afd5b1c0d409993ed44d8197ccb49bbc3b843cd44330e3ca3ba9e83a739435b4ef2cb17633c33c70b7baf56e9be369 SHA512 72334c0aec2d55b262f3994699631df218aa3de9a207f23ebda0d78118cca8ee980fb3fdcfd3130a233c6cab5dbbbd9c7cc53ecc09ce07583c316efb0c5c1851
DIST microsoft-edge-beta_93.0.961.33-1_amd64.deb 104508496 BLAKE2B 9962a7c921fcb5d821c38a1d37d1567bf03745d9b9a880332656641e465ebc81834d405775bb89a80322f76f9ab199af145952f6a7e1efe035f7b1c11f348110 SHA512 c0b20732b964155d33916fe5ea0f274aa7edb5c302051cd2c801e5ef28c0281a0c24365aa803b2562f9269324ae365177bcb1c6c59a7dd8222eb40d0fbf64932
105 changes: 105 additions & 0 deletions www-client/microsoft-edge-beta/microsoft-edge-beta-93.0.961.33.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,105 @@
# Copyright 2011-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit chromium-2 desktop pax-utils unpacker xdg

DESCRIPTION="The web browser from Microsoft"
HOMEPAGE="https://www.microsoft.com/en-us/edge"

if [[ ${PN} == microsoft-edge ]]; then
MY_PN=${PN}-stable
else
MY_PN=${PN}
fi

KEYWORDS="-* ~amd64"

MY_P="${MY_PN}_${PV}-1"

SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"

LICENSE="microsoft-edge"
SLOT="0"
RESTRICT="bindist mirror strip"

RDEPEND="
app-accessibility/at-spi2-atk:2
app-accessibility/at-spi2-core:2
app-misc/ca-certificates
dev-libs/atk
dev-libs/expat
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
media-fonts/liberation-fonts
media-libs/alsa-lib
media-libs/mesa[gbm(+)]
net-misc/curl[ssl]
net-print/cups
sys-apps/dbus
sys-apps/util-linux
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:3[X]
x11-libs/libdrm
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXrandr
x11-libs/libxcb
x11-libs/libxkbcommon
x11-libs/libxshmfence
x11-libs/pango
x11-misc/xdg-utils
"

QA_PREBUILT="*"
QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
S=${WORKDIR}
EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"

pkg_nofetch() {
eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
}

pkg_pretend() {
# Protect against people using autounmask overzealously
use amd64 || die "microsoft-edge only works on amd64"
}

pkg_setup() {
chromium_suid_sandbox_check_kernel_config
}

src_unpack() {
:
}

src_install() {
dodir /
cd "${ED}" || die
unpacker

rm _gpgorigin || die

rm -r etc usr/share/menu || die
mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die

gzip -d usr/share/doc/${PF}/changelog.gz || die
gzip -d usr/share/man/man1/${MY_PN}.1.gz || die

local suffix=
[[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
[[ ${PN} == microsoft-edge-dev ]] && suffix=_dev

local size
for size in 16 24 32 48 64 128 256 ; do
newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
done

pax-mark m "${EDGE_HOME}/msedge"
}

0 comments on commit 48d30f0

Please sign in to comment.