Skip to content

Commit

Permalink
dev-scheme/guile: bump to 3.0.4 (masked)
Browse files Browse the repository at this point in the history
Masking this for testing in case of compatibility problems.
Guile is not slotted right now, so committing unmasked initially
could mean various packages breaking.

Bug: https://bugs.gentoo.org/705554
Bug: https://bugs.gentoo.org/689408
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Oct 5, 2020
1 parent b55c9fc commit 48d334d
Show file tree
Hide file tree
Showing 8 changed files with 107 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-scheme/guile/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST guile-1.8.8.tar.gz 3956654 BLAKE2B 4820d635ac2c57526c0c03f3e0e6e4ac4276533e
DIST guile-2.0.14.tar.gz 7823099 BLAKE2B e7fa5a4ca19dc4adfcc151350b0ed4e211b8470b0d12f65451697a818c3139a4a5992a019bd213114748230cb15ec755d1af70d42b901230854915c0ee7b05de SHA512 d69c9bdf589fedcc227f3203012f6ed11c327cef3a0147d8e016fe276abecdb4272625efe1d0c7aa68219fe8f29bbced44089a4b479e4eafe01976c6b2b83633
DIST guile-2.2.6.tar.gz 18132818 BLAKE2B 9c2f7737d74d9e56bd9e3f42f287f6b48d9e381dff44ca3ad176ad64adf9b0d200c0b8d34a41e34b15ecf24fa28ddccaa9b033cead25583ff9984b5b7c09ced5 SHA512 6a9264c2e10def5e69a0e755fb28a5f09b98bc202660d742b0ee144d4f486b049dcbce8bcece79c3af9421d43df6eca36adf82798520f75b09303f5e8c2092af
DIST guile-2.2.7.tar.gz 18129833 BLAKE2B 03c88d753f83e5a797f12808b7b053c9cf6c51f87fb8f3c3db89e54528aafb0e54de2eb951cc622e98fada82a558932bb074a8e739f4175144d4b06ba42f7d60 SHA512 ad11885ffeb7655ef6c8543e67233992dc37bdcf91ed82188e6a144169c6b7d4e31cf7a6d01509c573d00904cb002719b851f71cdf1359a86de401daf613d773
DIST guile-3.0.4.tar.gz 21619204 BLAKE2B c8639019d8d69618726f40ecd44ed5a5790c34872119e806d4851671c61fd592608d066f4584df4a8db5f971b64ba9089bbbe935176923b413621953202bbc2d SHA512 d707d89ef0f94f74eb4678bcc79dfa99ea068d68a789f47039b5f00c0b8b01ace567a567c0f971fdc0dfc620c11d9536fc003d8d8e049e2cc158ce8b171e1134
72 changes: 72 additions & 0 deletions dev-scheme/guile/guile-3.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MAJOR="3.0"
DESCRIPTION="GNU Ubiquitous Intelligent Language for Extensions"
HOMEPAGE="https://www.gnu.org/software/guile/"
SRC_URI="mirror://gnu/guile/${P}.tar.gz"

LICENSE="LGPL-3+"
SLOT="12/3.0-1" # libguile-2.2.so.1 => 2.2-1
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="debug debug-malloc +deprecated +jit +networking +nls +regex +threads" # upstream recommended +networking +nls
REQUIRED_USE="regex" # workaround for bug 596322
RESTRICT="strip"

RDEPEND="
>=dev-libs/boehm-gc-7.0:=[threads?]
dev-libs/gmp:=
dev-libs/libffi:=
dev-libs/libltdl:=
dev-libs/libunistring:0=
sys-libs/ncurses:0=
sys-libs/readline:0="
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
sys-devel/libtool
sys-devel/gettext"

PATCHES=( "${FILESDIR}/${PN}-2.2.3-gentoo-sandbox.patch" )
DOCS=( GUILE-VERSION HACKING README )

src_configure() {
# see bug #676468
mv prebuilt/32-bit-big-endian{,.broken} || die

econf \
--disable-error-on-warning \
--disable-rpath \
--disable-static \
--enable-posix \
--without-libgmp-prefix \
--without-libiconv-prefix \
--without-libintl-prefix \
--without-libltdl-prefix \
--without-libreadline-prefix \
--without-libunistring-prefix \
$(use_enable debug guile-debug) \
$(use_enable debug-malloc) \
$(use_enable deprecated) \
$(use_enable jit) \
$(use_enable networking) \
$(use_enable nls) \
$(use_enable regex) \
$(use_with threads)
}

src_install() {
default

# From Novell
# https://bugzilla.novell.com/show_bug.cgi?id=874028#c0
dodir /usr/share/gdb/auto-load/$(get_libdir)
mv "${ED}"/usr/$(get_libdir)/libguile-*-gdb.scm "${ED}"/usr/share/gdb/auto-load/$(get_libdir) || die

# necessary for registering slib, see bug 206896
keepdir /usr/share/guile/site

find "${D}" -name '*.la' -delete || die
}
5 changes: 5 additions & 0 deletions profiles/arch/amd64/package.use.mask
Original file line number Diff line number Diff line change
Expand Up @@ -17,6 +17,11 @@

#--- END OF EXAMPLES ---

# Sam James <[email protected]> (2020-10-05)
# Guile only supports JIT on some arches
# (See 9.3.8 in the Guile manual)
dev-scheme/guile -jit

# Thomas Deutschmann <[email protected]> (2020-09-07)
# dev-util/nvidia-cuda-toolkit is keyworded on amd64
app-metrics/collectd -collectd_plugins_gpu_nvidia
Expand Down
6 changes: 6 additions & 0 deletions profiles/arch/arm/armv7a/package.use.mask
Original file line number Diff line number Diff line change
@@ -1,6 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Sam James <[email protected]> (2020-10-05)
# Guile only supports JIT on some arches
# (armv7 only for arm)
# (See 9.3.8 in the Guile manual)
dev-scheme/guile -jit

# Mart Raudsepp <[email protected]> (2020-08-02)
# virtual/rust is available here
>=media-gfx/eog-3.33.1 -svg
Expand Down
5 changes: 5 additions & 0 deletions profiles/arch/arm64/package.use.mask
Original file line number Diff line number Diff line change
@@ -1,6 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Sam James <[email protected]> (2020-10-05)
# Guile only supports JIT on some arches
# (See 9.3.8 in the Guile manual)
dev-scheme/guile -jit

# Joonas Niilola <[email protected]> (2020-10-02)
# luajit not available on this arch.
dev-libs/efl luajit
Expand Down
5 changes: 5 additions & 0 deletions profiles/arch/base/package.use.mask
Original file line number Diff line number Diff line change
@@ -1,6 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Sam James <[email protected]> (2020-10-05)
# Guile only supports JIT on some arches
# (See 9.3.8 in the Guile manual)
dev-scheme/guile jit

# Sam James <[email protected]> (2020-09-20)
# (for Mikle Kolyada <[email protected]>)
# libgcrypt et al no longer support static-libs
Expand Down
6 changes: 6 additions & 0 deletions profiles/arch/x86/package.use.mask
Original file line number Diff line number Diff line change
@@ -1,6 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Sam James <[email protected]> (2020-10-05)
# Guile only supports JIT on some arches
# (armv7 only for arm)
# (See 9.3.8 in the Guile manual)
dev-scheme/guile -jit

# Georgy Yakovlev <[email protected]> (2020-09-18)
# swt 4.10 not keyworded on x86
dev-java/openjdk:8 javafx
Expand Down
7 changes: 7 additions & 0 deletions profiles/package.mask
Original file line number Diff line number Diff line change
Expand Up @@ -32,6 +32,13 @@

#--- END OF EXAMPLES ---

# Sam James <[email protected]> (2020-10-05)
# Masked for testing. New major versions of Guile
# often break reverse dependencies.
# Guile in Gentoo is not slotted, so let's be cautious.
# bug #705554, bug #689408.
>=dev-scheme/guile-3.0.4

# Ulrich Müller <[email protected]> (2020-10-04)
# Version 1.11 introduced different startup conventions for the server
# which breaks the OpenRC init script. Bug #746227.
Expand Down

0 comments on commit 48d334d

Please sign in to comment.