Skip to content

Commit

Permalink
dropbear: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20
  • Loading branch information
vapier committed Aug 9, 2015
1 parent 7c0a3f0 commit 48e9579
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/dropbear/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST dropbear-2014.63.tar.bz2 1598479 SHA256 595992de432ba586a0e7e191bbb1ad58772
DIST dropbear-2014.65.tar.bz2 1604532 SHA256 e20057aa7db0f9ea4efdcbfc6fc6b73a648b47b6ab6a01659472142b06f5f56c SHA512 21ad2568d3ad369b55d8e04b86467fb204c775fe1fd8bfd5a310557e83bbb562db9041bd79a20edbaa1c6b8658a5d41fd54d87476f5e2d7bcf54ebc28615b878 WHIRLPOOL 4c0c3107a64fab185da2139d65ca5a85e687a05527e3ee3d64de63bbac947f3655fae222d895177a73467ce8bebc6dd2aa2d651267e1a6c80c7db8f839378692
DIST dropbear-2014.66.tar.bz2 1604981 SHA256 ab3fe2670a517cc0bbe398ff5d15e9ca12cd14f2fc18930a8111ae2baa64ab76 SHA512 3005f754ad97e5eb84221740577f4dd962e38f38b3f6ba84dbb0811a7a35d487069c35b30055e129541c224769fe0a7e594084a9b0f1cc667029ad43d4988149 WHIRLPOOL c077328bf5c21faa655f3a2e6fe1aa775b046eec7cf0f527a86c0ec01b62ab9c6ae3530fcdf49db19be8208ea22f8cd198cd3ab6a5eb605a55daf0bf0c40e4ff
DIST dropbear-2015.67.tar.bz2 1606312 SHA256 7e690594645dfde5787065c78a5d2e4d15e288babfa06e140197ce05f698c8e5 SHA512 6a23f7dbe8ccd39683488a16ce4db39cdba529e9d302165742eb818d3cf520a3793660ff6c8ce0520ddb87dcac726ff34ed3dbcb7efa83115deafad2c6c0a5f3 WHIRLPOOL c1103be19c86a0b40ca262715646244911032e97aba52279be1f7a0382367554c34455497b604dacacb69da0873fd26d3d457abeb7d265e6ca6bdff8938dc065
DIST dropbear-2015.68.tar.bz2 1611161 SHA256 55ea7c1e904ffe4b1cdbe1addca8291a2533d7d285fd22ac33608e9502a62446 SHA512 7725cd4077a3968684db3646f6013c6202977e79d281619e029366e45fca9c4e33e271812626237b6e33938eeb4c8b260902fe2b57cff085086bf930713a934a WHIRLPOOL a80d3907528b0d754f1a474846794ac9ba48003bbb723164c7db84c9b46263b47631712b15e29b863e64ad924d889976250e8af98b2b1ca91fb586ff0a1d4186
98 changes: 98 additions & 0 deletions net-misc/dropbear/dropbear-2015.68.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="4"

inherit eutils savedconfig pam user

DESCRIPTION="small SSH 2 client/server designed for small memory environments"
HOMEPAGE="http://matt.ucc.asn.au/dropbear/dropbear.html"
SRC_URI="http://matt.ucc.asn.au/dropbear/releases/${P}.tar.bz2
http://matt.ucc.asn.au/dropbear/testing/${P}.tar.bz2"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="bsdpty minimal multicall pam +shadow static +syslog zlib"

LIB_DEPEND="zlib? ( sys-libs/zlib[static-libs(+)] )
dev-libs/libtommath[static-libs(+)]"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
pam? ( virtual/pam )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )"
RDEPEND+=" pam? ( >=sys-auth/pambase-20080219.1 )"

REQUIRED_USE="pam? ( !static )"

set_options() {
progs=(
dropbear dbclient dropbearkey
$(usex minimal "" "dropbearconvert scp")
)
makeopts=(
MULTI=$(usex multicall 1 0)
STATIC=$(usex static 1 0)
)
}

src_prepare() {
epatch "${FILESDIR}"/${PN}-0.46-dbscp.patch
sed -i \
-e '/SFTPSERVER_PATH/s:".*":"/usr/lib/misc/sftp-server":' \
options.h || die
sed -i \
-e '/pam_start/s:sshd:dropbear:' \
svr-authpam.c || die
restore_config options.h
}

src_configure() {
# XXX: Need to add libtomcrypt to the tree and re-enable this.
# --disable-bundled-libtom
econf \
$(use_enable zlib) \
$(use_enable pam) \
$(use_enable !bsdpty openpty) \
$(use_enable shadow) \
$(use_enable syslog)
}

src_compile() {
set_options
emake "${makeopts[@]}" PROGRAMS="${progs[*]}"
}

src_install() {
set_options
emake "${makeopts[@]}" PROGRAMS="${progs[*]}" DESTDIR="${D}" install
doman *.8
newinitd "${FILESDIR}"/dropbear.init.d dropbear
newconfd "${FILESDIR}"/dropbear.conf.d dropbear
dodoc CHANGES README TODO SMALL MULTI

# The multi install target does not install the links right.
if use multicall ; then
cd "${ED}"/usr/bin
local x
for x in "${progs[@]}" ; do
ln -sf dropbearmulti ${x} || die "ln -s dropbearmulti to ${x} failed"
done
rm -f dropbear
dodir /usr/sbin
dosym ../bin/dropbearmulti /usr/sbin/dropbear
cd "${S}"
fi
save_config options.h

if ! use minimal ; then
mv "${ED}"/usr/bin/{,db}scp || die
fi

pamd_mimic system-remote-login dropbear auth account password session
}

pkg_preinst() {
enewgroup sshd 22
enewuser sshd 22 -1 /var/empty sshd
}

0 comments on commit 48e9579

Please sign in to comment.