Skip to content

Commit

Permalink
app-misc/egads: EAPI 6 bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
monsieurp committed Nov 3, 2017
1 parent 4e82089 commit 4904b31
Showing 1 changed file with 48 additions and 0 deletions.
48 changes: 48 additions & 0 deletions app-misc/egads/egads-0.9.5-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit multilib toolchain-funcs

DESCRIPTION="Entropy Gathering And Distribution System"
HOMEPAGE="http://www.securesoftware.com/download_egads.htm"
SRC_URI="http://www.securesoftware.com/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"

EGADS_DATADIR=/var/run/egads

src_prepare() {
default
sed -i \
-e '/^BINDIR/d' \
-e '/^LIBDIR/d' \
-e '/^INCLUDEDIR/d' \
"${S}"/Makefile.in || die "Failed to fix Makefile.in"
tc-export CC AR RANLIB
}

src_configure() {
econf \
--with-egads-datadir="${EGADS_DATADIR}" \
--with-bindir=/usr/sbin
}

src_compile() {
emake LIBDIR="/usr/$(get_libdir)"
}

src_install() {
keepdir ${EGADS_DATADIR}
fperms +t ${EGADS_DATADIR}
# NOT parallel safe, and no DESTDIR support
emake -j1 install \
BINDIR="${D}"/usr/sbin \
LIBDIR="${D}"/usr/$(get_libdir) \
INCLUDEDIR="${D}"/usr/include

dodoc README* doc/*.txt doc/*.html
}

0 comments on commit 4904b31

Please sign in to comment.