forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-haskell/highlighting-kate: bump up to 0.6.2
Package-Manager: portage-2.2.28
- Loading branch information
Sergei Trofimovich
committed
May 11, 2016
1 parent
0ad10fe
commit 495086f
Showing
2 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,5 @@ | ||
DIST highlighting-kate-0.5.14.tar.gz 865527 SHA256 d9cae13a1eb476b6c014ee1eabf5a3f835258a16c47f07e42b0368608c13ef42 SHA512 da2d1a5940357c3e067e51119fb6d209b42ea76828ed90bf4feeea099eeb844d53498dad6ef0d833c903db4d39e63dc4cbc2ebd913b51e41af3799a32d2c3b89 WHIRLPOOL a0b91aa0d64b3a3f381449f31ce20d608aa063d47bb8a1882821c6cbebe648b0205d8ffe975833fb5e6648ad98434b645e6ee353737c0b79f0e2c13faebd0e77 | ||
DIST highlighting-kate-0.5.5.tar.gz 668017 SHA256 4943b59d2ebe23c73f028c449cf973bdc2ea0f3e9e1f696eb7b7f5049da6fd7a SHA512 50c24f0a7f247ff1c5410aa31b270851c88cc3c24480da332c0a344c6959a7f8748dad4650374844b36eccee0824c991797d8327bf2b15ae055918acf129bd95 WHIRLPOOL 227383e60e6b9f2eddf58eea1936eaf982757a5a54a2c1aefb2dffc36606bc6b5c76b65c19b67c90498a58cd75585a57a152a89125c5e0b401d5096af6a970f0 | ||
DIST highlighting-kate-0.6.1.tar.gz 913389 SHA256 cb57caf861bda046043575772ffc7fd4cd21dd63a0ecdf26b624c7e930e0f30e SHA512 c7b0696acaee1e7679582dde6da0bd0d46a573955249d4b6b1455ac9f29839daaf0dd9c7f2b2229d335d24fd512c802e268cd96b9b6ca2a7509490b1e66ab774 WHIRLPOOL 94675d3a68d2528bc09b6a31511fadee6bd8301fab25e8d10cbd0635e916fb2825e2e0c9b2f927aaa5cab75f19c450b68b009f8486b8688b12e74a696e740377 | ||
DIST highlighting-kate-0.6.2.tar.gz 919467 SHA256 728f10ccba6dfa1604398ae527520d2debeef870472fe104c2bf0714c513b411 SHA512 b6574957352800d359f184b91f145623b7370e3e1e92ead79c5c6c5ed7a13b85e09e6f17a4d1af2b2628e30f6f34859143dfcc226b5d6f0e5d8a2fe5022c0924 WHIRLPOOL 3b49f4b41e678b730a21118dea9b981868badadb8a4365fbf9da2283bfd5e0cda8f4c6f3d62a169b0a3da10eab911ba20e210f5659596182ce06c357587db59b | ||
DIST highlighting-kate-0.6.tar.gz 922847 SHA256 b39dc194386eb7613a5e9935023b1173010800c3a9b0b7fe09c0601f97236398 SHA512 2042e22299735e49e45cb34f2807f883da91c98ca3fd37cd1698f5d1cfea49df79cfb8da6ac9664aba0629c5500e6cd9e9c812d897f59b9bd75b2a5cd5c12933 WHIRLPOOL c0246332c3bec77a405041f05c6d7771be6ba37035768df6e8c6a3044e88e06625d4e7aa7aae2288f2740cd2b5009e31fe01ac94216c3040fa2cd4c79695c201 |
38 changes: 38 additions & 0 deletions
38
dev-haskell/highlighting-kate/highlighting-kate-0.6.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
# ebuild generated by hackport 0.4.7.9999 | ||
|
||
CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite" | ||
inherit haskell-cabal | ||
|
||
DESCRIPTION="Syntax highlighting" | ||
HOMEPAGE="https://github.com/jgm/highlighting-kate" | ||
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0/${PV}" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="executable pcre-light" | ||
|
||
RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?] <dev-haskell/blaze-html-0.9:=[profile?] | ||
dev-haskell/mtl:=[profile?] | ||
dev-haskell/parsec:=[profile?] | ||
dev-haskell/utf8-string:=[profile?] | ||
>=dev-lang/ghc-7.4.1:= | ||
pcre-light? ( >=dev-haskell/pcre-light-0.4:=[profile?] <dev-haskell/pcre-light-0.5:=[profile?] ) | ||
!pcre-light? ( >=dev-haskell/regex-pcre-builtin-0.94.4.8.8.35:=[profile?] ) | ||
" | ||
DEPEND="${RDEPEND} | ||
>=dev-haskell/cabal-1.10 | ||
test? ( dev-haskell/diff ) | ||
" | ||
|
||
src_configure() { | ||
haskell-cabal_src_configure \ | ||
$(cabal_flag executable executable) \ | ||
$(cabal_flag pcre-light pcre-light) | ||
} |