Skip to content

Commit

Permalink
app-i18n/kimera: add support for app-i18n/imsettings
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
hattya committed Jul 18, 2017
1 parent 844ad57 commit 4967093
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
4 changes: 4 additions & 0 deletions app-i18n/kimera/files/xinput-kimera
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
XIM=kimera
XIM_PROGRAM="@EPREFIX@/usr/bin/kimera"
GTK_IM_MODULE=xim
QT_IM_MODULE=xim
44 changes: 44 additions & 0 deletions app-i18n/kimera/kimera-2.11-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit qmake-utils

DESCRIPTION="A Japanese input method which supports the XIM protocol"
HOMEPAGE="http://kimera.osdn.jp/"
SRC_URI="mirror://sourceforge.jp/${PN}/37271/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+anthy"

RDEPEND="dev-qt/qt3support:4
dev-qt/qtcore:4
dev-qt/qtgui:4
anthy? ( app-i18n/anthy )
!anthy? ( app-i18n/canna )"
DEPEND="${RDEPEND}"

PATCHES=( "${FILESDIR}"/${PN}-underlinking.patch )

src_configure() {
local myconf=(
script.path="${EPREFIX}"/usr/bin
target.path="${EPREFIX}"/usr/$(get_libdir)/${P}
no_anthy=$(usex anthy 1 0)
)
eqmake4 ${PN}.pro "${myconf[@]}"
}

src_install() {
emake INSTALL_ROOT="${D}" install
einstalldocs

insinto /etc/X11/xinit/xinput.d
sed \
-e "s:@EPREFIX@:${EPREFIX}:g" \
"${FILESDIR}"/xinput-${PN} > "${T}"/${PN}.conf
doins "${T}"/${PN}.conf
}

0 comments on commit 4967093

Please sign in to comment.