Skip to content

Commit

Permalink
dev-db/rqlite: add 7.10.1
Browse files Browse the repository at this point in the history
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
zmedico committed Nov 13, 2022
1 parent 4cd8730 commit 4969dd5
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-db/rqlite/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST rqlite-7.10.1-deps.tar.xz 151513776 BLAKE2B d98bc0c24821a7ae44ddc330cdbe54bc7394763f86e56919d6ff381613a563d646871fc35caa3b3a8e35c2be6c8b669779139a8e2c6f12a66de50d6af51c1452 SHA512 f56aeb5a5b640295f1c008a75e266908faecd1d635138eb7af32d3d780d5752662cd07b69bb99d833594c3cbcaf37b92e0bf23806567c83a1aff8b12fe099e71
DIST rqlite-7.10.1.tar.gz 510146 BLAKE2B 571af2b2a9d153d4c61c721e5a5346fede87be10f7069274f6964fe1cfc415d3e52cb6587a594d7257244e25567df89202c3511e0ded19350c8f6e11d3f2b0ed SHA512 6af02eb8512dbc163cd479ff7a286b6708fe06ba31312e426fba676cae914d3da741911f24ce1c79c6c86f4c2627d90a84190b009b8ab9e162b5333a9b60877b
DIST rqlite-7.7.2-deps.tar.xz 83998504 BLAKE2B df32a7b9a664f79241033d92dd4d0c71c9f5d24b08847d09320cd672bdc74e03c49af74a7f314f368a5e197becc1dec91b362b0f6148fccd7ba206068eb0c3e6 SHA512 04fb93912b5ac549657d9690e18554006ae55bfe66d08b1e5558bb29e636ceac5ee5f6af386f56ff10880e56d9b6599450ad2719e4422705aa359d85ca18ac0e
DIST rqlite-7.9.2.tar.gz 478780 BLAKE2B 4b072e9dab1fcfdb64a38e1a59bef2a1d81cf7543d6964ad75d3d3bd50cd52686d8b6f60a5e2a192b3998b3990efbe6f758a4226b03b8520fbd0569ab5aeca07 SHA512 86b3b89396d60d73e58ced463ae4cf5caf2cc8ba39bab87153b0a5a14e97745b07545bade7fa28dfde095255b547327ff83cefdaa78a399e1976e28d54ec430a
36 changes: 36 additions & 0 deletions dev-db/rqlite/rqlite-7.10.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit go-module
EGIT_COMMIT=22af9fdcb9a1093136f1eae7e18d4067dea29c64

DESCRIPTION="Replicated SQLite using the Raft consensus protocol"
HOMEPAGE="https://github.com/rqlite/rqlite https://www.philipotoole.com/tag/rqlite/"
SRC_URI="https://github.com/rqlite/rqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"

LICENSE="MIT Apache-2.0 BSD CC0-1.0 MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

src_compile() {
GOBIN="${S}/bin" \
go install \
-ldflags="-X main.version=v${PV}
-X main.branch=master
-X main.commit=${EGIT_COMMIT}
-X main.buildtime=$(date +%Y-%m-%dT%T%z)" \
./cmd/... || die
}

src_test() {
GOBIN="${S}/bin" \
go test ./... || die
}

src_install() {
dobin bin/*
dodoc -r *.md DOC
}

0 comments on commit 4969dd5

Please sign in to comment.