Skip to content

Commit

Permalink
media-sound/mumble: Fix build with GCC 4.9.
Browse files Browse the repository at this point in the history
Gentoo-Bug: https://bugs.gentoo.org/532180

Package-Manager: portage-2.2.22
Signed-off-by: Ryan Hill <[email protected]>
  • Loading branch information
dirtyepic committed Oct 2, 2015
1 parent 4ad28e3 commit 49ba2f7
Show file tree
Hide file tree
Showing 2 changed files with 28 additions and 1 deletion.
26 changes: 26 additions & 0 deletions media-sound/mumble/files/mumble-1.2.8-gcc49.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
https://bugs.gentoo.org/532180

Avoid "jump to label crosses initialization" error.

Move variable "buffer" into the while loop to avoid a compile error
with g++ 4.9.0.

Although earlier compiler versions did accept the code, jumping into the
scope of an variable length array is not allowed:
http://gcc.gnu.org/onlinedocs/gcc-4.3.0/gcc/Variable-Length.html


--- a/src/mumble/OSS.cpp
+++ b/src/mumble/OSS.cpp
@@ -243,9 +243,9 @@ void OSSInput::run() {
eMicFormat = SampleShort;
initializeMixer();

- short buffer[iMicLength];
-
while (bRunning) {
+ short buffer[iMicLength];
+
int len = static_cast<int>(iMicLength * iMicChannels * sizeof(short));
ssize_t l = read(fd, buffer, len);
if (l != len) {
3 changes: 2 additions & 1 deletion media-sound/mumble/mumble-1.2.8.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -47,6 +47,7 @@ DEPEND="${RDEPEND}

PATCHES=(
"${FILESDIR}"/${PN}-1.2.4-speech-dispatcher.patch
"${FILESDIR}"/${PN}-1.2.8-gcc49.patch
)

S="${WORKDIR}/${MY_P}"
Expand Down

0 comments on commit 49ba2f7

Please sign in to comment.