Skip to content

Commit

Permalink
dev-util/clion: version bump to 2017.3.
Browse files Browse the repository at this point in the history
Package-Manager: 2.3.13-r1, Repoman-2.3.3
Closes: gentoo#6364
  • Loading branch information
strahlc authored and monsieurp committed Dec 2, 2017
1 parent 07b655e commit 49ed170
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/clion/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST clion-143.1186.tar.gz 220702330 SHA256 a2d6960afbfae77f59481c5ad30bc7c5afe9451bdf9d12cd9435f605b57b522b SHA512 d4ea1bad5f3da3bab569380114011798c29e633009867c8020363c9af72326ebaa3232dff9c931a67dd0a0195bf4903647e250963c7aeebe9ad83340c988cbad WHIRLPOOL 2a0855b6a32a5e23a1c7266d7a3dc00ad3ba905c5a8fa6d1e9959d6d4f67c73d35c94bfbe0837fde0d1736bd48dcb9212a219cfa81732cb169abdb1fb5dc4dd7
DIST clion-2016.2.1.tar.gz 287103613 SHA256 444f760740811d0bb135cdd7d1d3a559b4d3247cdabf4eb9f77a21eea8c74805 SHA512 a4734c1b5d544cb7f6bd4752f5853d3c44e123e8ad8584b76098ef51a00261350d49bdd628d08c171f7c04b77862e8f28b5d8f16813c282542f83a16100c7415 WHIRLPOOL 83737f1677fff6870fd4dd717d54126f6680ec7c4966bc4b89f300e1fd327a431a13ceb6b04a52287c89813a7bb0e86ebaddf5c98f0330d595314c465d4a9534
DIST clion-2017.2.3.tar.gz 317631164 SHA256 dd1979947371803a1e11f5bdaf04e3ef2d013b90b56e84495c6e67e67cb31e0a SHA512 e3318b54468b2b3fc7ee22eada95248fc3bc66ae6365b838ef40f4d14da8c122f5677f7b0f1ea1f7a11825fc0245f692e20c03ac9cd9b5b949be44d330ca8fbe WHIRLPOOL a90771490359e4c530e45534179e1efe57bc5df41958aa244c60295f9346327592894ef3538c96e7eb88023cf6cef726449d260146050ff8fc41d8bb6880fc91
DIST clion-2017.3.tar.gz 331019046 SHA256 ce5e9acfae6b885f0204ba53a965a00530dbb986b800a04b97112ee2719e693f SHA512 4535534c708b7b6ae8c1cd17b47ae23bc3da02f80b01bed1143ccc7a62773aca2d4464472f1f2a62dc410cb5711616f0097bbf7fc44a929dfa2e7c22f1081b2a WHIRLPOOL 818591bfa9ae7bfdd75a1d58d8002c0bd5aa1f2d53ac9ca0f3a1282f85f211f1ffe655fce68be79997ba94884f3b84529b2ec88fe4a6182b6ff60ec102af05ad
61 changes: 61 additions & 0 deletions dev-util/clion/clion-2017.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils

SLOT="0"

SRC_URI="http://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="A complete toolset for C and C++ development"
HOMEPAGE="http://www.jetbrains.com/clion"

KEYWORDS="~amd64 ~x86"
LICENSE="IDEA
|| ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"

# RDEPENDS may cause false positives in repoman.
# clion requires cmake and gdb at runtime to build and debug C/C++ projects
RDEPEND="
sys-devel/gdb
dev-util/cmake"

QA_PREBUILT="opt/${P}/*"

src_prepare() {
default

local remove_me=(
bin/gdb/bin
bin/gdb/lib
bin/gdb/share
bin/cmake
license/CMake*
plugins/tfsIntegration/lib/native/hpux
plugins/tfsIntegration/lib/native/solaris
)

use amd64 || remove_me+=( plugins/tfsIntegration/lib/native/linux/x86_64 )
use arm || remove_me+=( bin/fsnotifier-arm plugins/tfsIntegration/lib/native/linux/arm )
use ppc || remove_me+=( plugins/tfsIntegration/lib/native/linux/ppc )
use x86 || remove_me+=( plugins/tfsIntegration/lib/native/linux/x86 )

rm -rv "${remove_me[@]}" || die
}

src_install() {
local dir="/opt/${P}"

insinto "${dir}"
doins -r *
fperms 755 "${dir}"/bin/{clion.sh,fsnotifier{,64}}

make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
newicon "bin/${PN}.svg" "${PN}.svg"
make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"

# recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
mkdir -p "${D}/etc/sysctl.d/" || die
echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
}

0 comments on commit 49ed170

Please sign in to comment.