Skip to content

Commit

Permalink
media-sound/qsampler: 0.5.3 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Dec 16, 2018
1 parent 16fb36f commit 4a19f09
Show file tree
Hide file tree
Showing 3 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/qsampler/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST qsampler-0.4.0.tar.gz 243065 BLAKE2B 7a51b15ddc9ca80180eba8134dae400cb1cf15
DIST qsampler-0.4.1.tar.gz 243377 BLAKE2B 521dddf1e07c11bee489148f82b33663c0bfdc0357fe146548e88075de23a1224673b5ae40ea6cb0c5a45bfc6f8808d7854cb0e7c9420e6d0e8ebc6d4c5e9e19 SHA512 ffa6e2feb11f9a96580fb1803b6ddb5c56ae475c1f04b5bfa94b1403c29ed0e14f8f60e9166ca166d5b478184c37337b0de0e098a54f74a90f951260d070ce14
DIST qsampler-0.4.2.tar.gz 244794 BLAKE2B 1b94c2a60537d20e62c31e05e4fb235b832b1bb808d508e10b1390fe039f5323280dd402f0bcd8df1e345f2b199f73baa6e16cc4e257ee9a92dea25d5738f88b SHA512 edebbc801e177cce44aa4e8cdc9db9e9e5c6cb35b75f33c4c15cae5920fa869053748075179c3b4d68956e30b05e5c94513419af567e60f27ca222f77fa41f30
DIST qsampler-0.4.3.tar.gz 246314 BLAKE2B 8e4415aa8cfec8922881b569afde5cea4d6fbea27cc5518ef2abafb4a174d95031d235b7d226bde8074bd306ca09063bc5a09fb66fc56878521752dbfb7f6f58 SHA512 015b747bd7c796341c6516fec68dd3b12725f461f7e5e3898b24862af556d69d67d73354f0aaf3bfbca069ebe67de34121350dcd3ee8161ec12e6bae80227fb9
DIST qsampler-0.5.3.tar.gz 259144 BLAKE2B 9efad81f6392cc6412e7d73c0701bdd2deab635a2857825248f003a594deb1a655201ed8e313b95cfaf066b71369f910a6634252b7ad7f2c636aa089c563f33a SHA512 0d870e1df1b20aac09b11667541767ebcadb8a9a8fb458aa3f48d4d4b2ff55b32e4e56e6d00b0330ab854120ace93b57f524a5126962456223026c7e69178bfe
10 changes: 10 additions & 0 deletions media-sound/qsampler/files/qsampler-0.5.3-Makefile.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
--- a/Makefile.in 2018-12-16 23:40:26.001395069 +0100
+++ b/Makefile.in 2018-12-16 23:46:00.210638503 +0100
@@ -109,7 +109,6 @@
@install -d -v -m 0755 $(DESTDIR)$(mandir)/man1
@install -v -m 0644 $(translations_targets) $(DESTDIR)$(translations_dir)
@install -v -m 0644 $(name)*.1 $(DESTDIR)$(mandir)/man1
- @gzip -vf $(DESTDIR)$(mandir)/man1/$(name)*.1

uninstall: $(DESTDIR)$(prefix)/bin/$(name)
@$(MAKE) INSTALL_ROOT=$(DESTDIR) -f $(name).mak uninstall
58 changes: 58 additions & 0 deletions media-sound/qsampler/qsampler-0.5.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit qmake-utils xdg-utils

DESCRIPTION="Graphical frontend to the LinuxSampler engine"
HOMEPAGE="https://qsampler.sourceforge.io/ https://www.linuxsampler.org/"
SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug +libgig"

COMMON_DEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
media-libs/alsa-lib
>=media-libs/liblscp-0.5.6:=
x11-libs/libX11
libgig? ( >=media-libs/libgig-3.3.0:= )
"
RDEPEND="${COMMON_DEPEND}
>=media-sound/linuxsampler-0.5
"
DEPEND="${COMMON_DEPEND}
dev-qt/linguist-tools:5
"

DOCS=( AUTHORS ChangeLog README TODO TRANSLATORS )

PATCHES=( "${FILESDIR}/${P}-Makefile.patch" )

src_configure() {
local myeconfargs=(
$(use_enable debug)
$(use_enable libgig)
)
ac_qmake="$(qt5_get_bindir)/qmake" \
econf "${myeconfargs[@]}"

cd src || die
eqmake5 src.pro -o Makefile
}

pkg_postinst() {
xdg_mimeinfo_database_update
xdg_desktop_database_update
}

pkg_postrm() {
xdg_mimeinfo_database_update
xdg_desktop_database_update
}

0 comments on commit 4a19f09

Please sign in to comment.