Skip to content

Commit

Permalink
net-misc/aria2: Bump to 1.24.0
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Jun 23, 2016
1 parent 1e7a209 commit 4a3e0b8
Show file tree
Hide file tree
Showing 2 changed files with 150 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/aria2/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST aria2-1.19.0.tar.bz2 2155310 SHA256 ae2b6fce7a0974c9156415cccf2395cd258580a
DIST aria2-1.19.2.tar.xz 1377356 SHA256 3605486dd495cd8c2f672b7d0b763397989d831396862f15730697ebcf0ad53e SHA512 ae3fb231fa9f989a8c4f8015d7e64db2b62b922548839a884454ef1fc6dc024363b482268200efa234ac71a1dba969aaefbeb81c811223e2e117f3adae9a8468 WHIRLPOOL 10f4ad709e26f29685b05e5db4fde687c733404a994649d4f5c5a8f66bf60142ae3bc65179db7b83766e32663100b5c7c58f1b6e4a6f6a4d2f089176604a8c95
DIST aria2-1.21.0.tar.xz 1438608 SHA256 225c5f2c8acc899e0a802cdf198f82bd0d3282218e80cdce251b1f9ffacf6580 SHA512 2862d82f064de160b64705ee5ae9180e7402859c7c0d9bc5421b1368cebd143e0a0e2e971713cd27f11efbeffe6618e801309ff34b12aeb00060b9de58652251 WHIRLPOOL 07030ec26b002c98f8a76984bec1594b76dba404c40dbda8d4d80d682ee41ac7667c45c9fb723fa335906ebf0f462f4d2bd924ce64422a26d23d7da4ae5b62d9
DIST aria2-1.23.0.tar.xz 1493704 SHA256 585185866415bf1120e4bf0a484e7dfec2e9e7c5305023b15ad0f66f90391f93 SHA512 c64877f5d2a2fd9c45b0a592af508dab25c4f4610fb56243db77f660a004c48e567f0c6be707c8f44b8f6b1a3e7f90e0d1be77b421e56957b5a24b1252ffc5fd WHIRLPOOL 5a6ab2a6b002b3279a9a96071f878029928d19c29f4442fa1c1fb26099976443bb8d260105fdafe59020749e1f9f481a81ca7c80af96fb0d49f3de4d0b3e14f1
DIST aria2-1.24.0.tar.xz 1495632 SHA256 35a496d2704ffb07e0b0dcac16c6d9b2854327967f984218517403d187f7bf37 SHA512 3e7f3fc2cd30edb5813b0d0fe6742671000730aa8d7e41e5396ab673912b8492885273de740985517b4a16efccedb1bdffb9bfdc235aa0d5fc31d2b547ae61e7 WHIRLPOOL 31a22233c5aacfaf8ee93da4bc13af0138ab6bc6eec6a458cb846834d61ddf2f1082a69a1eb24ee8feaad65d426a8fd4c235ffd886dbee44fb8749ecf79c3f0e
149 changes: 149 additions & 0 deletions net-misc/aria2/aria2-1.24.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,149 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"

inherit bash-completion-r1

DESCRIPTION="A download utility with segmented downloading with BitTorrent support"
HOMEPAGE="http://aria2.sourceforge.net/"
SRC_URI="https://github.com/tatsuhiro-t/${PN}/releases/download/release-${PV}/${P}.tar.xz"

LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
IUSE="adns bittorrent +gnutls jemalloc libuv +libxml2 metalink +nettle nls sqlite scripts ssh ssl tcmalloc test xmlrpc"

CDEPEND="sys-libs/zlib:0=
ssl? (
app-misc/ca-certificates
gnutls? ( >=net-libs/gnutls-1.2.9:0= )
!gnutls? ( dev-libs/openssl:0= ) )
adns? ( >=net-dns/c-ares-1.5.0:0= )
bittorrent? (
ssl? (
gnutls? (
nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
!nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
!ssl? (
nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
!nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
jemalloc? ( dev-libs/jemalloc )
libuv? ( dev-libs/libuv:0= )
metalink? (
libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
!libxml2? ( dev-libs/expat:0= ) )
sqlite? ( dev-db/sqlite:3= )
ssh? ( net-libs/libssh2:= )
tcmalloc? ( dev-util/google-perftools )
xmlrpc? (
libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
!libxml2? ( dev-libs/expat:0= ) )"

DEPEND="${CDEPEND}
app-arch/xz-utils
virtual/pkgconfig
nls? ( sys-devel/gettext )
test? ( >=dev-util/cppunit-1.12.0:0 )"
RDEPEND="${CDEPEND}
nls? ( virtual/libiconv virtual/libintl )
scripts? ( dev-lang/ruby )"

REQUIRED_USE="jemalloc? ( !tcmalloc )
tcmalloc? ( !jemalloc )"

pkg_setup() {
if use scripts && use !xmlrpc && use !metalink; then
ewarn "Please note that you may need to enable USE=xmlrpc to run the aria2rpc"
ewarn "and aria2mon scripts against the local aria2."
fi
}

src_prepare() {
default
sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
}

src_configure() {
local myconf=(
# threads, epoll: check for best portability

# do not try to compile and run a test LIBXML program
--disable-xmltest
# enable the shared library
--enable-libaria2
# zlib should always be available anyway
--with-libz
--with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt"

# optional features
$(use_enable bittorrent)
$(use_enable metalink)
$(use_enable nls)
$(use_with sqlite sqlite3)
$(use_with adns libcares)
$(use_with libuv)
$(use_with jemalloc)
$(use_with tcmalloc)
)

# SSL := gnutls / openssl
# USE=ssl
# + USE=gnutls -> gnutls
# + USE=-gnutls -> openssl

if use ssl; then
myconf+=( $(use_with gnutls) $(use_with !gnutls openssl) )
else
myconf+=( --without-gnutls --without-openssl )
fi

# message-digest := nettle / gcrypt / openssl
# bignum := nettle+gmp / gcrypt / openssl
# bittorrent := message-digest + bignum
# USE=bittorrent
# + USE=(ssl -gnutls) -> openssl
# + USE=nettle -> nettle+gmp
# + USE=-nettle -> gcrypt

if use !bittorrent || use ssl && use !gnutls; then
myconf+=( --without-libgcrypt --without-libnettle --without-libgmp )
else
myconf+=( $(use_with !nettle libgcrypt)
$(use_with nettle libnettle) $(use_with nettle libgmp) )
fi

# metalink+xmlrpc := libxml2 / expat
# USE=(metalink || xmlrpc)
# + USE=libxml2 -> libxml2
# + USE=-libxml2 -> expat

if use metalink || use xmlrpc; then
myconf+=( $(use_with !libxml2 libexpat) $(use_with libxml2) )
else
myconf+=( --without-libexpat --without-libxml2 )
fi

# Note:
# - always enable gzip/http compression since zlib should always be available anyway
# - always enable epoll since we can assume kernel 2.6.x
# - other options for threads: solaris, pth, win32
econf "${myconf[@]}"
}

src_install() {
default
rm -rf "${D}"/usr/share/doc/aria2 \
"${D}"/usr/share/doc/${PF}/README{,.html}

dobashcomp doc/bash_completion/aria2c
use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
}

pkg_postinst() {
if use xmlrpc || use metalink; then
elog "If you would like to use the additional aria2mon and aria2rpc tools,"
elog "you need to have \033[1mdev-lang/ruby\033[0m installed."
fi
}

0 comments on commit 4a3e0b8

Please sign in to comment.