Skip to content

Commit

Permalink
dev-util/lttng-modules: add 2.12.8
Browse files Browse the repository at this point in the history
Signed-off-by: Raymond Wong <[email protected]>
Signed-off-by: Yixun Lan <[email protected]>
  • Loading branch information
infiWang authored and dlan17 committed Apr 26, 2022
1 parent 6a48961 commit 4a5159c
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/lttng-modules/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST lttng-modules-2.12.5.tar.bz2 317002 BLAKE2B 9f42f8641dca7ce55e7445495c747ce340919458a23b4d471998fe2a28dd26bc7dfa5edbccf0b11877176091dee0c4d63fdda919c03afc8dad3fcfb7e9529c33 SHA512 81524dac513384852555a6f5619dc10286a2f7d4e3032ee9ca33705e830ee3bc3dc8c96b89a9c09dd5df2bf29944e3e566d1ac1a6cd6be83718af9836e043991
DIST lttng-modules-2.12.6.tar.bz2 318479 BLAKE2B 7cac6dd7dcb12801a32179ced4bb141a7af87c864eb71b793e65b905e4a0ba3d3273609bd3cd80c9c1251914a39e62da0a85e18058480da0c4eb2d6eb44f851c SHA512 608112b960d47ed5f979c7f2de2886d3fbe78a0d2eaec0892bfbca92bdad423e8ba8c3960836f71045c79d9c1b9eac88757400726656e98fb0ae70035e0073aa
DIST lttng-modules-2.12.8.tar.bz2 319450 BLAKE2B 0ce5c6675598c1a4b6fbc0dfaf51d36638f12fe2e07095c37a811db8d7ee65bb242164cf02b1854c27b6894f0b4c73867e8ee1b80dd007290e0db203ea429f9e SHA512 5918a54d08a12cec567cdad2909846ba529d5e665a3592a69384d9546f6f3e23e7975876fc11feaef65604d36889b0598b1cf7b5f2badb4e2b11b255a2e7ca99
DIST lttng-modules-2.13.3.tar.bz2 343593 BLAKE2B a0c914af0118327cb6d785c7c018d2d9cbd2139bbc3e0524a9c96832c7214fea7fc2a0dd8a8770db0728aba6ca3e9f30ea6e790575fb4d3492d9a7485993f293 SHA512 a0329c4709cc1a5fcc8d667d7435bc57b37cfa95da5451a8ee6ab700f334365e2d78e085e537376948dfe95d433016be5f6e3b5e5aa34a05948d4fa42f9102a1
49 changes: 49 additions & 0 deletions dev-util/lttng-modules/lttng-modules-2.12.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit linux-mod

MY_P="${P/_rc/-rc}"
MY_SLOT="$(ver_cut 1-2)"

DESCRIPTION="LTTng Kernel Tracer Modules"
HOMEPAGE="https://lttng.org"
SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0/${MY_SLOT}"
KEYWORDS="~amd64 ~x86"
IUSE=""

BUILD_TARGETS="default"

CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"

MODULE_NAMES="true"

S="${WORKDIR}/${MY_P}"

pkg_pretend() {
if kernel_is lt 3 0; then
eerror "${PN} require Linux kernel >= 3.0"
die "Please update your kernel!"
fi
}

src_compile() {
BUILD_FIXES="KERNELDIR=$KERNEL_DIR" linux-mod_src_compile
}

src_install() {
for i in $(find "${S}" -name "*.ko" -print); do
local val=${i##${S}/}
local modules+="${val%%.ko}(misc:) "
done
MODULE_NAMES=${modules}

linux-mod_src_install
dodoc ChangeLog README.md TODO
}

0 comments on commit 4a5159c

Please sign in to comment.