Skip to content

Commit

Permalink
app-text/pinfo: Fix compile failure with GCC 7 / -Os.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.41, Repoman-2.3.9
  • Loading branch information
Jeroen Roovers committed Jul 7, 2018
1 parent 6fd6afb commit 4a64671
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 1 deletion.
42 changes: 42 additions & 0 deletions app-text/pinfo/files/pinfo-0.6.10-gcc-7-inline.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
--- a/src/initializelinks.c
+++ b/src/initializelinks.c
@@ -75,7 +75,7 @@
* checks if an item belongs to tag table. returns 1 on success and 0 on
* failure. It should be optimised...
*/
-inline int
+int
exists_in_tag_table(char *item)
{
if (gettagtablepos(item) != -1)
--- a/src/filehandling_functions.c
+++ b/src/filehandling_functions.c
@@ -554,7 +554,7 @@
return 1;
}

-inline void
+void
buildcommand(char *dest, char *command, char *filename, const char *tmpfilename)
{
strcpy(dest, command);
@@ -564,7 +564,7 @@
strcat(dest, tmpfilename);
}

-inline void
+void
builddircommand(char *dest, char *command, char *filename, const char *tmpfilename)
{
strcpy(dest, command);
--- a/src/utils.c
+++ b/src/utils.c
@@ -193,7 +193,7 @@
return value;
}

-inline void
+void
initlocale()
{
#ifdef ___DEBUG___
3 changes: 2 additions & 1 deletion app-text/pinfo/pinfo-0.6.10-r6.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -37,6 +37,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.6.10-ncurses-check.patch
"${FILESDIR}"/${PN}-0.6.10-libc-basename.patch
"${FILESDIR}"/${PN}-0.6.10-clearfilenameprefix.patch
"${FILESDIR}"/${PN}-0.6.10-gcc-7-inline.patch
)

src_prepare() {
Expand Down

0 comments on commit 4a64671

Please sign in to comment.