forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-sound/munt-mt32emu-alsadrv: New package
Upstream has labelled this obsolete but I still use it with DOSBox. Maybe I'll add the DOSBox patch sometime. Closes: https://bugs.gentoo.org/395307 Package-Manager: Portage-2.3.20, Repoman-2.3.6
- Loading branch information
Showing
3 changed files
with
68 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST munt_2_3_0.tar.gz 418703 BLAKE2B d9c4290f11f4114b26aa45d6591c04a73d56981e7f618c1466db81fd35be3588b2853fb60b9cf65dd523ce8ea120a5a187bd805b58ba2f75719d460929c2e4e1 SHA512 87fe4891628ea33967270fe3c6c3840e40deb14bd7c8d61490d4c0057438af6bc0099c10e24e813ef1613ca9cc9fc1567a0340c7ea1f4254b209f7fc99c8c7a1 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>James Le Cuirot</name> | ||
</maintainer> | ||
<upstream> | ||
<remote-id type="sourceforge">munt</remote-id> | ||
<remote-id type="github">munt/munt</remote-id> | ||
</upstream> | ||
<longdescription lang="en"> | ||
mt32emu_alsadrv is a module of the Munt project. It uses the mt32emu library and provides an ALSA MIDI driver which emulates (approximately) the Roland MT-32, CM-32L and LAPC-I synthesiser modules. | ||
</longdescription> | ||
</pkgmetadata> |
52 changes: 52 additions & 0 deletions
52
media-sound/munt-mt32emu-alsadrv/munt-mt32emu-alsadrv-2.3.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit toolchain-funcs prefix | ||
|
||
MY_P="munt_${PV//./_}" | ||
DESCRIPTION="ALSA MIDI driver for emulating the Roland MT-32, CM-32L, CM-64 and LAPC-I" | ||
HOMEPAGE="https://github.com/munt/munt" | ||
SRC_URI="https://github.com/munt/munt/archive/${MY_P}.tar.gz" | ||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="X" | ||
|
||
DEPEND="media-libs/alsa-lib | ||
media-libs/munt-mt32emu | ||
X? ( | ||
x11-libs/libX11 | ||
x11-libs/libXpm | ||
x11-libs/libXt | ||
)" | ||
|
||
RDEPEND="${DEPEND}" | ||
|
||
S="${WORKDIR}/munt-${MY_P}/mt32emu_alsadrv" | ||
DATA="/usr/share/mt32-rom-data" | ||
|
||
src_prepare() { | ||
default | ||
|
||
# Fix MT32 ROM path. | ||
hprefixify src/alsadrv.cpp | ||
} | ||
|
||
src_compile() { | ||
emake mt32d CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" | ||
use X && emake xmt32 CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" | ||
} | ||
|
||
src_install() { | ||
dobin mt32d | ||
use X && dobin xmt32 | ||
dodoc {AUTHORS,README}.txt | ||
keepdir "${DATA}" | ||
} | ||
|
||
pkg_postinst() { | ||
einfo "MT32_CONTROL.ROM and MT32_PCM.ROM cannot be legally included so you must" | ||
einfo "obtain them and place them in ${EPREFIX}${DATA}." | ||
} |