Skip to content

Commit

Permalink
app-benchmarks/iozone: bump to v3.484
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Nov 28, 2018
1 parent d159d18 commit 4aba3bc
Show file tree
Hide file tree
Showing 2 changed files with 78 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-benchmarks/iozone/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST iozone3_471.tar 1853440 BLAKE2B 280c821a439ad1bacbd749278385481678d644a59c14395482c8a088b0578285f389f376fb32ce3c3abde598f50d693fb0c7c9a3d6597765547a71c76d21ea1c SHA512 c61b2b8b5af3dccdb99b26aef8a0a4f2f5f467fc3985ac72ed4bb4fb36e4b7684ca6dbaa5bbc05ae0a4e73852e048e9fd2495eda9313f5abc4e631499d683aec
DIST iozone3_484.tar 1863680 BLAKE2B 72d3d3125aec2dfc504bb00684ef325e85edffe0d6efcd519cd692cfa2b9b792a44c00313dc96eabbbb3ab850a7a440b3ca3d5b955c4f6092b08f92ebe5c332b SHA512 bb1ac0c1724a5d3c20e90c56c0b4a438b4aa50384cddc76f4b77f2c465f052fd3fae9217b77688a2c6caf5e90611123a97ea0cd8074b3678068a90e6dd7857b7
77 changes: 77 additions & 0 deletions app-benchmarks/iozone/iozone-3.484.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

# TODO
# -> linux-arm (32bit) <-
# -> linux-AMD64 (64bit) <-
# -> linux-ia64 (64bit) <-
# -> linux-powerpc (32bit) <-
# -> linux-powerpc64 (64bit) <-
# -> linux-S390 (32bit) <-
# -> linux-S390X (64bit) <-
#
# -> freebsd (32bit) <-
# -> macosx (32bit) <-
# -> netbsd (32bit) <-
# -> openbsd (32bit) <-
# -> openbsd-threads (32bit) <-
#
# ~ia64 ~s390 alpha(?) x86-fbsd

inherit toolchain-funcs

DESCRIPTION="Filesystem benchmarking program"
HOMEPAGE="http://www.iozone.org/"
SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"

LICENSE="freedist"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""

S=${WORKDIR}/${PN}${PV/./_}

src_prepare() {
default

# Options FIX
sed -i -e "s:CC =.*:CC =$(tc-getCC):g" \
-e "s:-O3:${CFLAGS}:g" src/current/makefile || die
}

src_configure() {
case ${ARCH} in
x86|alpha) PLATFORM="linux";;
arm) PLATFORM="linux-arm";;
ppc) PLATFORM="linux-powerpc";;
ppc64) PLATFORM="linux-powerpc64";;
amd64) PLATFORM="linux-AMD64";;
ia64) PLATFORM="linux-ia64";;
s390) PLATFORM="linux-S390";;
x86-fbsd) PLATFORM="freebsd";;
*) PLATFORM="linux-${ARCH}";;
esac
}

src_compile() {
emake -C src/current ${PLATFORM}
}

src_test() {
cd "${T}" || die
"${S}"/src/current/iozone testfile || die "self test failed"
}

src_install() {
dosbin src/current/{iozone,fileop}

# decompress pre-compressed file to make QA check happy
gzip -d docs/Iozone_ps.gz || die

dodoc docs/I* docs/Run_rules.doc src/current/Changes.txt
doman docs/iozone.1
cd src/current || die
dodoc Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
}

0 comments on commit 4aba3bc

Please sign in to comment.