forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ml/ocaml-migrate-parsetree: bump to 1.0.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
34 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST ocaml-migrate-parsetree-0.7.tar.gz 168579 SHA256 a9048e1a9c004ec9b307452fff25e8f31853942e42d054bd052739eb838026a2 SHA512 d43a80823496670877a01a0d3b9edc0960e80e84562470723b7188922c880262268f518e8fa3dbbcccc0176fba84cc8c1a18baac8ececb13303ed402cf0bff9f WHIRLPOOL 788fc318bcc972a1b62b951ab1e4a2315e3c4922b07c74cb910716f1e41bb61babe0acf86a0fbd15d8e05a2ff7da05a683b8005119f4a65d284ea0a453098e0e | ||
DIST ocaml-migrate-parsetree-1.0.1.tar.gz 206070 SHA256 8655a95abcd1ef9e05219db19fb0f1eb79cf502276c9e8d007446575c3cbdf7f SHA512 de9992e4e8e9bbda6fcaeaab794f88f695ea69ed63ab083fb1746db53127a80d7dcc19b843c7dc9e2fa01132eacf89b000639c76c89d1010a6c4f6508af73a52 WHIRLPOOL ec9833768ec35d9d9838e47c35f34e680c0ce0e326d6b3cfe62f3016b96e8f031fcb84ddc5f5fe805dfe0dff5c82968ac44a2240c7133aeb1d3497d201ce1e22 | ||
DIST ocaml-migrate-parsetree-1.0.tar.gz 169706 SHA256 c6cfd5012d357cfbeb059d3286e9dcc003bebe98fa3901a21389b1dbb0446741 SHA512 24930b2368cfd86a489cddbe391b978a8f4c34ba7aa2dd3ce849f4fe8d836b5eaefab18a782df93ead641094f19261941754802ae1019ed7c0c8a8c1dcdecb15 WHIRLPOOL 7d314d7fd8a82ecb4dda12c12e7f5134680c351a9996b4e00226a8fc3c3ba6457afc16a3d869910a24c271561c9e6dda355fe8bb82a936f0072e6b05dcc7b9d0 |
33 changes: 33 additions & 0 deletions
33
dev-ml/ocaml-migrate-parsetree/ocaml-migrate-parsetree-1.0.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit findlib | ||
|
||
DESCRIPTION="Convert OCaml parsetrees between different major versions" | ||
HOMEPAGE="https://github.com/let-def/ocaml-migrate-parsetree" | ||
SRC_URI="https://github.com/let-def/ocaml-migrate-parsetree/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0/${PV}" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
dev-lang/ocaml:= | ||
dev-ml/result:= | ||
" | ||
RDEPEND="${DEPEND}" | ||
DEPEND="${DEPEND} | ||
dev-ml/jbuilder | ||
dev-ml/opam" | ||
|
||
src_install() { | ||
opam-installer -i \ | ||
--prefix="${ED}/usr" \ | ||
--libdir="${D}/$(ocamlc -where)" \ | ||
--docdir="${ED}/usr/share/doc/${PF}" \ | ||
--mandir="${ED}/usr/share/man" \ | ||
${PN}.install || die | ||
} |