Skip to content

Commit

Permalink
dev-embedded/libftdi: Version 1.4.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.43, Repoman-2.3.10
  • Loading branch information
Jeroen Roovers committed Jul 20, 2018
1 parent 14ce961 commit 4b24d07
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-embedded/libftdi/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libftdi-0.19.tar.gz 406671 BLAKE2B 47979967d8597584e46a5d9297ed24454d0583869110b52af7662a04a4b037ea57ec6ba133a61d355f0ccf1366b14195a8ccb13d7bb585264cdd1d528f2cf2d9 SHA512 c6deefe8c83063343321e8c2c6b6c1c2842a9f1caf4e54f47106c3c4aac638736f19fecf91582c6cc9f4917c4d140157440c360ce3a030dfb7fa027483bab972
DIST libftdi-0.20.tar.gz 423570 BLAKE2B f0aa420a704e18c4257b99a4593dbaf46a15806d980b24909fe8678b36e74b568cd5915db1e14f8b904541334fbf3d18f069dc479a0bf66b2ea8e113611cb82b SHA512 540e5eb201a65936c3dbabff70c251deba1615874b11ff27c5ca16c39d71c150cf61758a68b541135a444fe32ab403b0fba0daf55c587647aaf9b3f400f1dee7
DIST libftdi1-1.2.tar.bz2 100672 BLAKE2B 314ee2695324bc3f6adad56d7ff8fddabfb86714a689ee309afc6aa8498a19fc55d2ea8f4edf0c378d944494505def3faabf1d9c3bb98e6c228526c392d26f09 SHA512 d175e2b39dda880653a2e46db67e49a8921095e69eff6598159c3c31292d4ce76617c2f1617fd6727b08c930fcea335d8ef01857debbb60e7ac384b516d38a05
DIST libftdi1-1.4.tar.bz2 109521 BLAKE2B 4186342afb2a0118c454230a925ccff2ed0aedd942cdd3afb1ac59519f1cd48db7f04421ecdb5aa6e53993666a903de00ce447fd81d00839806f8cc0d34c6e52 SHA512 dbab74f7bc35ca835b9c6dd5b70a64816948d65da1f73a9ece37a0f0f630bd0df1a676543acc517b02a718bc34ba4f7a30cbc48b6eed1c154c917f8ef0a358fc
73 changes: 73 additions & 0 deletions dev-embedded/libftdi/libftdi-1.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
inherit cmake-utils python-single-r1

MY_P="${PN}1-${PV}"
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
else
SRC_URI="http://www.intra2net.com/en/developer/${PN}/download/${MY_P}.tar.bz2"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
fi

DESCRIPTION="Userspace access to FTDI USB interface chips"
HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"

LICENSE="LGPL-2"
SLOT="1"
IUSE="cxx doc examples python static-libs test tools"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

RDEPEND="virtual/libusb:1
cxx? ( dev-libs/boost )
python? ( ${PYTHON_DEPS} )
tools? (
!<dev-embedded/ftdi_eeprom-1.0
dev-libs/confuse:=
)"
DEPEND="${RDEPEND}
python? ( dev-lang/swig )
doc? ( app-doc/doxygen )"

pkg_setup() {
use python && python-single-r1_pkg_setup
}

S=${WORKDIR}/${MY_P}

src_configure() {
local mycmakeargs=(
-DFTDIPP=$(usex cxx)
-DDOCUMENTATION=$(usex doc)
-DEXAMPLES=$(usex examples)
-DPYTHON_BINDINGS=$(usex python)
-DSTATICLIBS=$(usex static-libs)
-DBUILD_TESTS=$(usex test)
-DFTDI_EEPROM=$(usex tools)
-DCMAKE_SKIP_BUILD_RPATH=ON
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
use python && python_optimize
dodoc AUTHORS ChangeLog README TODO

if use doc ; then
# Clean up crap man pages. #356369
rm -vf "${CMAKE_BUILD_DIR}"/doc/man/man3/_* || die

doman "${CMAKE_BUILD_DIR}"/doc/man/man3/*
dodoc -r "${CMAKE_BUILD_DIR}"/doc/html
fi
if use examples ; then
docinto examples
dodoc examples/*.c
fi
}

0 comments on commit 4b24d07

Please sign in to comment.