forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emacs/nxml-libvirt-schemas: Add 10.1.0
Signed-off-by: Michal Privoznik <[email protected]> Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
4beedc3
commit 4bb32a6
Showing
2 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST libvirt-10.0.0.tar.xz 9395076 BLAKE2B bfbea7805a949999481293a31e52a5511bcf86db2c96486cbc3b9cb776719ec973b1208cfcb4a8ae2c9220d1d68053980eaf68893f7919c3ef354efbd1abf642 SHA512 4ab28539ff0e9a78ac231b11b4ec88b91d76ff2607cabd0226f04aaece73b05cab4aa9cfcf05073cd257ea270a377cd5d2cb915971583dbec04dadf2cf7ad252 | ||
DIST libvirt-10.1.0.tar.xz 9444244 BLAKE2B bfdce9d067e3a319b81d867d27f1a6b4e724ab6aaa25d19d7383c9be26ad7dc92b3c0aaa92894b772f09e20c3c2eb0ea0a8707feee4c63be58578fa22854305f SHA512 08e73ae15de5681430b62db85ec9901242dca5e9a4ca9685614f4a67092c6e28f27f9187144b3ceb18ad6b40e6eb1a90b1a4b056b0888724d04a62002ee2bc48 | ||
DIST libvirt-9.8.0.tar.xz 9307064 BLAKE2B aae47e8d4eeaf97532a0356de23ed5a9eea71b369d025eda95b5fd74576779eb4b843d05df6c87b79a14f218c341953749e319ee7244846a2db410a74a746880 SHA512 0118725073de33eec3fa3e4616d3154707f9828fdb9ec973f503fe68f18eab72b9704da660f281152630ddc95e605c786673af9d23dc9bdfc0108422e0efbd41 | ||
DIST libvirt-9.9.0.tar.xz 9321556 BLAKE2B 21eae5a95feaf7f5c6ba8dd48732c08212904882a11c48eccfa827d85ddc3df7e064503f21710dbe1b678670e02f003674de915a43a7403fbf85685c4832e21d SHA512 77cea28acf4f3e8c92fbd5bd72ad084be183c07f14e3a9ce35d6d9d62d36ee97a30cef55fb204b3e43f282890ecd7d5827a784a517e7f4ed8b22ee502c3f09d7 |
45 changes: 45 additions & 0 deletions
45
app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-10.1.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
# Packages which get releases together: | ||
# app-emacs/nxml-libvirt-schemas | ||
# dev-python/libvirt-python | ||
# dev-perl/Sys-Virt | ||
# app-emulation/libvirt | ||
# Please bump them together! | ||
|
||
inherit elisp | ||
|
||
MY_P="libvirt-${PV}" | ||
DESCRIPTION="Extension for nxml-mode with libvirt schemas" | ||
HOMEPAGE="https://www.libvirt.org/" | ||
SRC_URI="https://libvirt.org/sources/${MY_P}.tar.xz" | ||
S="${WORKDIR}/${MY_P%-rc*}/src/conf/schemas" | ||
|
||
# This is the license of the package, but the schema files are | ||
# provided without license, maybe it's bad. | ||
LICENSE="LGPL-2.1+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
# Yes this requires Java, but I'd rather not repackage this, if you | ||
# know something better in C, I'll be glad to use that. | ||
BDEPEND="app-text/trang" | ||
|
||
SITEFILE="60${PN}-gentoo.el" | ||
|
||
src_compile() { | ||
emake -f - <<'EOF' | ||
all: $(patsubst %.rng,%.rnc,$(wildcard *.rng)) | ||
%.rnc: %.rng | ||
trang -I rng -O rnc $< $@ | ||
EOF | ||
} | ||
|
||
src_install() { | ||
insinto "${SITEETC}/${PN}" | ||
doins "${FILESDIR}"/schemas.xml *.rnc | ||
elisp-site-file-install "${FILESDIR}/${SITEFILE}" | ||
} |