Skip to content

Commit

Permalink
www-plugins/adobe-flash: Version bump (bug #579166).
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
Jeroen Roovers committed Apr 8, 2016
1 parent c3ecb79 commit 4bc01c4
Show file tree
Hide file tree
Showing 2 changed files with 238 additions and 0 deletions.
3 changes: 3 additions & 0 deletions www-plugins/adobe-flash/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,6 @@
DIST adobe-flash-11.2.202.577-debug.i386.tar.gz 7449682 SHA256 d1d5405eb5b66b0cc36d9a6866b69fc672ed1284586f778a780bb601ecaa8c6b SHA512 b5ac55a5f703aefb7f93cc99e7c038f2faf832f917a27aca17db58bce83821fbbbb37bdcf8776b5c03be335b510b6380b313057334e1b3cdf80a3c1ac8fc0378 WHIRLPOOL 79b6f83564f1ec747dface303b6ec367a685ee79b7077841974302afb186d1ef3a3f8f6c77c5498fb1cf240f88655f6211a9df27967619fd0105a29a94a89801
DIST adobe-flash-11.2.202.577.i386.tar.gz 6968176 SHA256 475d9853b25a58b3893f56db92a3de429475c3c59f4633a79aad6cf70e691b9a SHA512 d59d0f5fd31a406f40b6928ced7cffff167e58f0fa37e8702007c112d90731c84b6be4e11ffa0cfa36ea95ed424e8d78f6dd8ec507b11f5c3650c4b0c857bf6c WHIRLPOOL 567f8f9bf0596b0609723e633957c3699d11759c6fbf83d15e60dc797b4655ba173933ffda3620f89371ad096f8fd711ab0b5479845237d0de1f04595b1c5078
DIST adobe-flash-11.2.202.577.x86_64.tar.gz 7279100 SHA256 26c44aa4e0c94cff85d4d4a319f1a7ba2e5766b8c01a084999affffc634f507e SHA512 0d5075561787639f4eeb15de2c0add27ebcd2efe158599dfb9f2e2d5bcf734ade33712d74e9f6f783ef3eb952295f686f76a950eb3ce7765fbfee5bef137d80e WHIRLPOOL 6e7e7e02bf20e2fa39254efec344ff2cb9ccfd847358b39f7a8ae6894fc55ffa0cde1111f921ce72da155c6a2e39c72b6089ddfe4c49bb328423d98c8ccad39d
DIST adobe-flash-11.2.202.616-debug.i386.tar.gz 7450241 SHA256 040d938f83afed18be8e3fd3eacea898b3afe927b9fa3b92b846c4267d238f05 SHA512 25ff5e84b9289059823f559ce0c74aeb42208c32f9abafdfdcb9d293ace74bec28cd2603c2604cf39b3c575e48bdec31a7c8fa056c3fe8ba8d2ca753a497bf29 WHIRLPOOL 94bcc6cf595b8e7812de27892a3c223a40f4da81c32bdbf9c350180ccd30020a55204e2ecf8c9f4f8e9a41f41ad25623cf431a76ebdb08455acc0ebd894e23dd
DIST adobe-flash-11.2.202.616.i386.tar.gz 6968762 SHA256 607d12307bb2d8b03475e317873bc7f4c577a3383e5e79190444fb9089ece744 SHA512 174dc2d6fee47cba501a53ac352abb4583d2f83d1e36fbe18ae2e8f72559974663333e0dc3958e1da9544c809c682fdff753e75edde7c6c44bbd41834b7a9e11 WHIRLPOOL 260f3fdc09ec75292dd100642788e22576692825d4cfdea3eb91d9c626c95317b04ed6175301bc068af50f288d8bc9203ab8d073459baf38b15b2871566354a2
DIST adobe-flash-11.2.202.616.x86_64.tar.gz 7280774 SHA256 39c57f57468dff12a982a3f8fb5b9d5b85f5730d542cf361d7087868e4d3b164 SHA512 b9d96dc4a37f927ad2869ac6bb5cf6c1a6327fbd368625d24227aeb3759d3501224d07d3400cff543c151d271cb1b7a18bf8a33f85ca16509aa0114795818057 WHIRLPOOL 3a270a0431a26911e6b34bb6ad0c2176812a65a2fad7b1c88b5b9fad5a664430175b7ab2258b629f4ec553b49b2c374efe7eb4936d64e07705a68261f950bcce
235 changes: 235 additions & 0 deletions www-plugins/adobe-flash/adobe-flash-11.2.202.616.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,235 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit nsplugins toolchain-funcs versionator multilib multilib-minimal

DESCRIPTION="Adobe Flash Player"
HOMEPAGE="
http://www.adobe.com/products/flashplayer.html
http://get.adobe.com/flashplayer/
https://helpx.adobe.com/security/products/flash-player.html#version11
"

AF_URI="http://fpdownload.macromedia.com/get/flashplayer/pdc"
AF_DB_URI="http://fpdownload.macromedia.com/pub/flashplayer/updaters"
PV_M=$(get_major_version)
AF_32_URI="${AF_URI}/${PV}/install_flash_player_${PV_M}_linux.i386.tar.gz -> ${P}.i386.tar.gz"
AF_64_URI="${AF_URI}/${PV}/install_flash_player_${PV_M}_linux.x86_64.tar.gz -> ${P}.x86_64.tar.gz"
AF_32_DB_URI="${AF_DB_URI}/${PV_M}/flashplayer_${PV_M}_plugin_debug.i386.tar.gz -> ${P}-debug.i386.tar.gz"

SRC_URI="
abi_x86_32? (
!debug? ( ${AF_32_URI} )
debug? ( ${AF_32_DB_URI} )
)
abi_x86_64? ( ${AF_64_URI} )
"
IUSE="debug kde selinux cpu_flags_x86_sse2"
REQUIRED_USE="
cpu_flags_x86_sse2
debug? ( abi_x86_32 )
|| ( abi_x86_64 abi_x86_32 )
"
SLOT="0"

KEYWORDS="-* ~amd64 ~x86"
LICENSE="AdobeFlash-11.x"
RESTRICT="strip mirror"

S="${WORKDIR}"

NATIVE_DEPS="
dev-libs/atk
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
kde? (
dev-qt/qtcore:4
dev-qt/qtdbus:4
dev-qt/qtgui:4
dev-qt/qtsvg:4
kde-base/kdelibs
x11-libs/libICE
x11-libs/libSM
x11-libs/libXau
x11-libs/libXdmcp
x11-libs/libXext
x11-libs/libXft
x11-libs/libXpm
)
media-libs/fontconfig
media-libs/freetype
>=sys-libs/glibc-2.4
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:2
x11-libs/libX11
x11-libs/libXcursor
x11-libs/libXext
x11-libs/libXrender
x11-libs/libXt
x11-libs/pango
"

DEPEND="
amd64? ( abi_x86_32? ( !abi_x86_64? ( www-plugins/nspluginwrapper ) ) )
"
RDEPEND="
${DEPEND}
abi_x86_64? ( ${NATIVE_DEPS} )
abi_x86_32? (
amd64? (
>=dev-libs/atk-2.10.0[abi_x86_32(-)]
>=dev-libs/glib-2.34.3:2[abi_x86_32(-)]
>=dev-libs/nspr-4.10.4[abi_x86_32(-)]
>=dev-libs/nss-3.15.4[abi_x86_32(-)]
>=media-libs/fontconfig-2.10.92[abi_x86_32(-)]
>=media-libs/freetype-2.5.0.1[abi_x86_32(-)]
>=x11-libs/cairo-1.12.14-r4[abi_x86_32(-)]
>=x11-libs/gdk-pixbuf-2.30.7[abi_x86_32(-)]
>=x11-libs/gtk+-2.24.23:2[abi_x86_32(-)]
>=x11-libs/libX11-1.6.2[abi_x86_32(-)]
>=x11-libs/libXcursor-1.1.14[abi_x86_32(-)]
>=x11-libs/libXext-1.3.2[abi_x86_32(-)]
>=x11-libs/libXrender-0.9.8[abi_x86_32(-)]
>=x11-libs/libXt-1.1.4[abi_x86_32(-)]
>=x11-libs/pango-1.36.3[abi_x86_32(-)]
)
x86? ( ${NATIVE_DEPS} )
)
|| ( media-fonts/liberation-fonts media-fonts/corefonts )
selinux? ( sec-policy/selinux-flash )
"

# Ignore QA warnings in these closed-source binaries, since we can't fix them:
QA_PREBUILT="usr/*"

any_cpu_missing_flag() {
local value=${1}
grep '^flags' /proc/cpuinfo | grep -qv "${value}"
}

pkg_setup() {
unset need_lahf_wrapper
if use abi_x86_64 && any_cpu_missing_flag 'lahf_lm'; then
export need_lahf_wrapper=1
fi
}

src_unpack() {
local files=( ${A} )

multilib_src_unpack() {
mkdir -p "${BUILD_DIR}" || die
cd "${BUILD_DIR}" || die

# we need to filter out the other archive(s)
local other_abi
[[ ${ABI} == amd64 ]] && other_abi=i386 || other_abi=x86_64
unpack ${files[@]//*${other_abi}*/}
}

multilib_parallel_foreach_abi multilib_src_unpack
}

src_configure() { :; }

multilib_src_compile() {
if [[ ${ABI} == amd64 && ${need_lahf_wrapper} ]]; then
# This experimental wrapper, from Maks Verver via bug #268336 should
# emulate the missing lahf instruction affected platforms.
set -- $(tc-getCC) -fPIC -shared -nostdlib -lc \
-oflashplugin-lahf-fix.so "${FILESDIR}/flashplugin-lahf-fix.c"
echo "${@}" >&2
"${@}" || die "Compile of flashplugin-lahf-fix.so failed"
fi
}

multilib_src_install() {
# PLUGINS_DIR comes from nsplugins.eclass
exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
doexe libflashplayer.so

if [[ ${ABI} == amd64 && ${need_lahf_wrapper} ]]; then
# This experimental wrapper, from Maks Verver via bug #268336 should
# emulate the missing lahf instruction affected platforms.
doexe flashplugin-lahf-fix.so
fi

if multilib_is_native_abi; then
if use kde; then
local pkglibdir=lib
[[ -d usr/lib64 ]] && pkglibdir=lib64

exeinto /usr/$(get_libdir)/kde4
doexe usr/${pkglibdir}/kde4/kcm_adobe_flash_player.so
insinto /usr/share/kde4/services
doins usr/share/kde4/services/kcm_adobe_flash_player.desktop
else
# No KDE applet, so allow the GTK utility to show up in KDE:
sed -i usr/share/applications/flash-player-properties.desktop \
-e "/^NotShowIn=KDE;/d" || die "sed of .desktop file failed"
fi

# The userland 'flash-player-properties' standalone app:
dobin usr/bin/flash-player-properties

# Icon and .desktop for 'flash-player-properties'
insinto /usr/share
doins -r usr/share/{icons,applications}
dosym ../icons/hicolor/48x48/apps/flash-player-properties.png \
/usr/share/pixmaps/flash-player-properties.png
fi

# The magic config file!
insinto "/etc/adobe"
doins "${FILESDIR}/mms.cfg"
}

unregister_pluginwrapper() {
# TODO: Perhaps parse the output of 'nspluginwrapper -l'
# TODO: However, the 64b flash plugin makes
# TODO: 'nspluginwrapper -l' segfault.
local FLASH_WRAPPER="${ROOT}/usr/lib64/${PLUGINS_DIR}/npwrapper.libflashplayer.so"
if has_version 'www-plugins/nspluginwrapper' && [[ -f ${FLASH_WRAPPER} ]]; then
einfo "Removing 32-bit plugin wrapper"
nspluginwrapper -r "${FLASH_WRAPPER}"
fi
}

pkg_postinst() {
if use amd64 ; then
if [[ ${need_lahf_wrapper} ]]; then
ewarn "Your processor does not support the 'lahf' instruction which is used"
ewarn "by Adobe's 64-bit flash binary. We have installed a wrapper which"
ewarn "should allow this plugin to run. If you encounter problems, please"
ewarn "adjust your USE flags to install only the 32-bit version and reinstall:"
ewarn " ${CATEGORY}/${PN}[abi_x86_32,-abi_x86_64]"
elog
fi
# needed to clean up upgrades from older installs
if use abi_x86_64 && [[ -n ${REPLACING_VERSIONS} ]]; then
unregister_pluginwrapper
fi
if has_version 'www-plugins/nspluginwrapper'; then
if use abi_x86_32 && ! use abi_x86_64; then
einfo "nspluginwrapper detected: Installing plugin wrapper"
local oldabi="${ABI}"
ABI="x86"
local FLASH_SOURCE="${ROOT}/usr/lib32/${PLUGINS_DIR}/libflashplayer.so"
nspluginwrapper -i "${FLASH_SOURCE}"
ABI="${oldabi}"
fi
elif use abi_x86_32; then
elog "To use the 32-bit flash player in a native 64-bit browser,"
elog "you must install www-plugins/nspluginwrapper"
fi
fi
}

pkg_prerm() {
use amd64 && use abi_x86_32 && ! use abi_x86_64 && \
unregister_pluginwrapper
}

0 comments on commit 4bc01c4

Please sign in to comment.