Skip to content

Commit

Permalink
app-admin/syslog-ng: bump to 3.19.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Tomáš Mózes <[email protected]>
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
hydrapolic authored and Whissi committed Dec 22, 2018
1 parent 4d75fcd commit 4beafe5
Show file tree
Hide file tree
Showing 2 changed files with 172 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/syslog-ng/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,4 +4,5 @@ DIST syslog-ng-3.15.1.tar.gz 9147238 BLAKE2B 86c51a51569efed2c2127a6102a10224a05
DIST syslog-ng-3.16.1.tar.gz 8899693 BLAKE2B 850d83ff6f7e2db4aaf0737cc97403084bfa97855df28ccc8134c7d744cc0539e5d9efcd72f7eaa5407504897bc274419963843afa4c81964732dc5d6f0337cd SHA512 6b47e570ac19154f6158d8de0898c0a49e87d4ed51cae67224501e9460063efc53c4b2ad518d7def811d320f88cbefbf5d645de31f300498921652d7be305999
DIST syslog-ng-3.17.2.tar.gz 9119227 BLAKE2B 3268a51c587e66579b30ee8d27397eeeb3ab52c7e1939ad26ad976be2670565a389fda9dbc3a25f80710f855788c85f58d47f6a3c297b8ff6efa01e0dca386fe SHA512 2b82ea047bab125d35ab0a90e933b8a282852c6b4a9a8adc3f2a0ddf392f24210ce1296d0cfb389f98e54e50090a3ded5a64c5a9529d2a90cbecbfafd620edd7
DIST syslog-ng-3.18.1.tar.gz 4259746 BLAKE2B 3878a87bd195aadb0f9d024e1336e50268d69c00b438b5e3471f21bc4592ebd97980004c3624d9b92232b38068ebefa0c3317cb0d9b5dfeba37c479aeadc32e4 SHA512 2e6ea690f8762f3f37885118f023048c4cba59f58002c87fa1c469cb991b2ba707015b3e54c50f17c3d6e6251d798557406925a9159f4fa914331f281dc39e48
DIST syslog-ng-3.19.1.tar.gz 4224779 BLAKE2B e938c91101c18951a5c921bea51631400bf579ebc840300c6d8411da9b8db69935d104bfe00525512ab0173b932a8e24e2fb102e17bc4ecf58b268e52ef5b41a SHA512 f625073bafa9378109d5be34591247766a62cb5a76e814f42bfbf03472e96ebe2833f19779812abfdd950a3498115f57b97c1427c280ee0dab21d3e2eb92ca57
DIST syslog-ng-3.7.3.tar.gz 3511155 BLAKE2B 25ba2ca241a5847c75792c78d39a4667f55cf1fcff46be5102256ee6a9d2f39e2042ac00fa0b1559f94e0df80a0853249692b443b565dd4f46f0354c453cacaf SHA512 e58d793bd1a8b48c5836090ee244f6e8b223f234f5a27fbf81f6a838b9b1e3e45f73a66dab2bc58a0bba230bd778a247ae22bf529a28fb2e9fee52b8181d304b
171 changes: 171 additions & 0 deletions app-admin/syslog-ng/syslog-ng-3.19.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,171 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit autotools python-single-r1 systemd

MY_PV_MM=$(ver_cut 1-2)
DESCRIPTION="syslog replacement with advanced filtering features"
HOMEPAGE="https://syslog-ng.com/open-source-log-management"
SRC_URI="https://github.com/balabit/syslog-ng/releases/download/${P}/${P}.tar.gz"

LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="amqp caps dbi geoip geoip2 http ipv6 json libressl mongodb pacct python redis smtp spoof-source systemd tcpd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# unit tests require https://github.com/Snaipe/Criterion with additional deps
RESTRICT="test"

RDEPEND="
>=dev-libs/glib-2.10.1:2
>=dev-libs/ivykis-0.42.3
>=dev-libs/libpcre-6.1:=
!dev-libs/eventlog
amqp? ( >=net-libs/rabbitmq-c-0.8.0:= )
caps? ( sys-libs/libcap )
dbi? ( >=dev-db/libdbi-0.9.0 )
geoip? ( >=dev-libs/geoip-1.5.0 )
geoip2? ( dev-libs/libmaxminddb:= )
http? ( net-misc/curl )
json? ( >=dev-libs/json-c-0.9:= )
mongodb? ( >=dev-libs/mongo-c-driver-1.2.0 )
python? ( ${PYTHON_DEPS} )
redis? ( >=dev-libs/hiredis-0.11.0:= )
smtp? ( net-libs/libesmtp )
spoof-source? ( net-libs/libnet:1.1= )
systemd? ( sys-apps/systemd:= )
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )"
DEPEND="${RDEPEND}
sys-devel/flex
virtual/pkgconfig"

DOCS=( AUTHORS NEWS.md CONTRIBUTING.md contrib/syslog-ng.conf.{HP-UX,RedHat,SunOS,doc}
contrib/syslog2ng "${T}/syslog-ng.conf.gentoo.hardened"
"${T}/syslog-ng.logrotate.hardened" "${FILESDIR}/README.hardened" )

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
local f

use python && python_fix_shebang .

# remove bundled libs
rm -r lib/ivykis || die

# drop scl modules requiring json
if use !json; then
sed -i -r '/cim|elasticsearch|ewmm|graylog2|loggly|logmatic|nodejs|osquery|slack/d' scl/Makefile.am || die
fi

# drop scl modules requiring http
if use !http; then
sed -i -r '/slack|telegram/d' scl/Makefile.am || die
fi

# use gentoo default path
if use systemd; then
sed -e 's@/etc/syslog-ng.conf@/etc/syslog-ng/syslog-ng.conf@g;s@/var/run@/run@g' \
-i contrib/systemd/syslog-ng@default || die
fi

for f in syslog-ng.logrotate.hardened.in syslog-ng.logrotate.in; do
sed \
-e "s#@GENTOO_RESTART@#$(usex systemd "systemctl kill -s HUP syslog-ng@default" \
"/etc/init.d/syslog-ng reload")#g" \
"${FILESDIR}/${f}" > "${T}/${f/.in/}" || die
done

for f in syslog-ng.conf.gentoo.fbsd.in \
syslog-ng.conf.gentoo.hardened.in \
syslog-ng.conf.gentoo.in; do
sed -e "s/@SYSLOGNG_VERSION@/${MY_PV_MM}/g" "${FILESDIR}/${f}" > "${T}/${f/.in/}" || die
done

default
eautoreconf
}

src_configure() {
local myconf=(
--disable-docs
--disable-java
--disable-java-modules
--disable-riemann
--enable-manpages
--localstatedir=/var/lib/syslog-ng
--sysconfdir=/etc/syslog-ng
--with-embedded-crypto
--with-ivykis=system
--with-module-dir=/usr/$(get_libdir)/syslog-ng
--with-pidfile-dir=/var/run
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
$(use_enable amqp)
$(usex amqp --with-librabbitmq-client=system --without-librabbitmq-client)
$(use_enable caps linux-caps)
$(use_enable dbi sql)
$(use_enable geoip)
$(use_enable geoip2)
$(use_enable http)
$(use_enable ipv6)
$(use_enable json)
$(use_enable mongodb)
$(usex mongodb --with-mongoc=system "--without-mongoc --disable-legacy-mongodb-options")
$(use_enable pacct)
$(use_enable python)
$(use_enable redis)
$(use_enable smtp)
$(use_enable spoof-source)
$(use_enable systemd)
$(use_enable tcpd tcp-wrapper)
)

econf "${myconf[@]}"
}

src_install() {
default

# Install default configuration
insinto /etc/default
doins contrib/systemd/syslog-ng@default

insinto /etc/syslog-ng
if use userland_BSD ; then
newins "${T}/syslog-ng.conf.gentoo.fbsd" syslog-ng.conf
else
newins "${T}/syslog-ng.conf.gentoo" syslog-ng.conf
fi

insinto /etc/logrotate.d
newins "${T}/syslog-ng.logrotate" syslog-ng

newinitd "${FILESDIR}/syslog-ng.rc" syslog-ng
newconfd "${FILESDIR}/syslog-ng.confd" syslog-ng
keepdir /etc/syslog-ng/patterndb.d /var/lib/syslog-ng
find "${D}" -name '*.la' -delete || die

use python && python_optimize
}

pkg_postinst() {
# bug #355257
if ! has_version app-admin/logrotate ; then
elog "It is highly recommended that app-admin/logrotate be emerged to"
elog "manage the log files. ${PN} installs a file in /etc/logrotate.d"
elog "for logrotate to use."
fi

if use systemd; then
ewarn "The service file for systemd has changed to support multiple instances."
ewarn "To start the default instance issue:"
ewarn "# systemctl start syslog-ng@default"
fi
}

0 comments on commit 4beafe5

Please sign in to comment.