forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.14, Repoman-2.3.6
- Loading branch information
1 parent
835b002
commit 4bf1a62
Showing
3 changed files
with
183 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST icinga2-2.7.0.tar.gz 2435398 SHA256 8f06d23e5d922ba7a74f92dbb9af792be063d06d3aea9011aba39370935c6980 SHA512 470dd4ffa4ef608a018ede5c25b41f16213bf18c679eed8aaeed155fe6adc74a70abcc2e8be42ca20bf60f9b4b620c971ebbc96d608de2a90e480d72b93111bb WHIRLPOOL c926086c296affaafc7d55471ea5c1414b2d2cb8545657215a53bb9744c3147c32f8398317ad670e0d12fb95c83b54f0712f061e5e93bab868c4f04d833c3b47 | ||
DIST icinga2-2.7.1.tar.gz 2475348 SHA256 79f2cd2cba66b2d2a785d37cccd4a47611f7b0b7d52b9a625a22f0c7ff12f7f0 SHA512 8233c33b7191706569a236d583fff689b35eba750fca01a06cfd14ef636b01314b6b142d78777987bd08a9df1cc53f42652fd1c900532b73f0a0363aa220c6cd WHIRLPOOL be07801033b8e10d3a4aaa26e9cd6b75663aed4cf513f8d592b05ea13e0626ab3021d5a52ebeedfa754752057a1d3378fd54c1f8fd1ec5dc72338c891d6b9785 | ||
DIST icinga2-2.7.2.tar.gz 2471098 SHA256 7e9691ad3389f04a53042d88c1ac8a37e2c9aaf8287856cad3fa48825adaee84 SHA512 69cd7c56eaae832712723fcd21e2177b8180b3975bcf773223ca52d3817d1ca538cfd620002bd7a9ccf2e89deffa80d07e6281111146295b21377de99170302d WHIRLPOOL 55e55189b9a1f6646cb94748a7b22731cd5f0d576a858737530187bbab83f40c8973f1a9f508449b0dcb997af443e75a15c9b2ef775c8fe95d1740c72db214c9 | ||
DIST icinga2-2.8.0.tar.gz 2497043 SHA256 bdb1434dc1f502f350c659371c0920d68eeb982add0c5e94b5c16068dbef8fd0 SHA512 20399251c91aa3b07a0e884e0c52fa2540b645d24fd46cdb550fcc5accfbfa23a703f7d310ccde4fa68008c44e8dc6bcdc5351a21e82181e39b1add5a92d90c6 WHIRLPOOL 3af07a98c9debf2bf846e5cbb619e86cdb8b0b91b5a3796b6046ddad96ab23b4526ee47c128ee2c85e82348f6b6a11ac4681604005ac23c9aeebdd7518ce4e3e |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,180 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
if [[ ${PV} != 9999 ]]; then | ||
inherit cmake-utils depend.apache eutils systemd toolchain-funcs user wxwidgets | ||
SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86" | ||
else | ||
inherit cmake-utils depend.apache eutils git-r3 systemd toolchain-funcs user wxwidgets | ||
EGIT_REPO_URI="https://github.com/Icinga/icinga2.git" | ||
EGIT_BRANCH="master" | ||
KEYWORDS="~ppc ~ppc64" | ||
fi | ||
|
||
DESCRIPTION="Distributed, general purpose, network monitoring engine" | ||
HOMEPAGE="http://icinga.org/icinga2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins studio +vim-syntax" | ||
WX_GTK_VER="3.0" | ||
|
||
CDEPEND=" | ||
!libressl? ( dev-libs/openssl:0= ) | ||
libressl? ( dev-libs/libressl:0= ) | ||
>=dev-libs/boost-1.58-r1 | ||
console? ( dev-libs/libedit ) | ||
mysql? ( virtual/mysql ) | ||
postgres? ( dev-db/postgresql:= )" | ||
|
||
DEPEND=" | ||
${CDEPEND} | ||
sys-devel/bison | ||
>=sys-devel/flex-2.5.35" | ||
|
||
RDEPEND=" | ||
${CDEPEND} | ||
plugins? ( || ( | ||
net-analyzer/monitoring-plugins | ||
net-analyzer/nagios-plugins | ||
) ) | ||
mail? ( virtual/mailx ) | ||
classicui? ( net-analyzer/icinga[web] ) | ||
studio? ( x11-libs/wxGTK:3.0 )" | ||
|
||
REQUIRED_USE="!minimal? ( || ( mysql postgres ) )" | ||
|
||
PATCHES=( | ||
) | ||
|
||
want_apache2 | ||
|
||
pkg_setup() { | ||
depend.apache_pkg_setup | ||
if use studio ; then | ||
setup-wxwidgets | ||
fi | ||
enewgroup icinga | ||
enewgroup icingacmd | ||
enewgroup nagios # for plugins | ||
enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios" | ||
} | ||
|
||
src_configure() { | ||
sed -i 's/FLAGS\}\ \-g/FLAGS\}\ \-lpthread\ /g' CMakeLists.txt || die | ||
local mycmakeargs=( | ||
-DICINGA2_UNITY_BUILD=FALSE | ||
-DCMAKE_VERBOSE_MAKEFILE=ON | ||
-DCMAKE_BUILD_TYPE=None | ||
-DCMAKE_INSTALL_PREFIX=/usr | ||
-DCMAKE_INSTALL_SYSCONFDIR=/etc | ||
-DCMAKE_INSTALL_LOCALSTATEDIR=/var | ||
-DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2 | ||
-DICINGA2_PLUGINDIR="/usr/$(get_libdir)/nagios/plugins" | ||
-DICINGA2_USER=icinga | ||
-DICINGA2_GROUP=icingacmd | ||
-DICINGA2_COMMAND_USER=icinga | ||
-DICINGA2_COMMAND_GROUP=icingacmd | ||
-DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes | ||
-DLOGROTATE_HAS_SU=ON | ||
) | ||
# default to off if minimal, allow the flags to be set otherwise | ||
if use minimal; then | ||
mycmakeargs+=( | ||
-DICINGA2_WITH_MYSQL=OFF | ||
-DICINGA2_WITH_PGSQL=OFF | ||
) | ||
else | ||
mycmakeargs+=( | ||
-DICINGA2_WITH_PGSQL=$(usex postgres ON OFF) | ||
-DICINGA2_WITH_MYSQL=$(usex mysql ON OFF) | ||
) | ||
fi | ||
# LTO | ||
if use lto; then | ||
mycmakeargs+=( | ||
-DICINGA2_LTO_BUILD=ON | ||
) | ||
else | ||
mycmakeargs+=( | ||
-DICINGA2_LTO_BUILD=OFF | ||
) | ||
fi | ||
# STUDIO | ||
if use studio; then | ||
mycmakeargs+=( | ||
-DICINGA2_WITH_STUDIO=ON | ||
) | ||
else | ||
mycmakeargs+=( | ||
-DICINGA2_WITH_STUDIO=OFF | ||
) | ||
fi | ||
|
||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
BUILDDIR="${WORKDIR}"/icinga2-${PV}_build | ||
cd "${BUILDDIR}" || die | ||
|
||
emake DESTDIR="${D}" install | ||
|
||
einstalldocs | ||
|
||
newinitd "${FILESDIR}"/icinga2.initd icinga2 | ||
|
||
if use mysql ; then | ||
docinto schema | ||
newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql | ||
docinto schema/upgrade | ||
dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/* | ||
elif use postgres ; then | ||
docinto schema | ||
newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql | ||
docinto schema/upgrade | ||
dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/* | ||
fi | ||
|
||
keepdir /etc/icinga2 | ||
keepdir /var/lib/icinga2/api/zones | ||
keepdir /var/lib/icinga2/api/repository | ||
keepdir /var/lib/icinga2/api/log | ||
keepdir /var/spool/icinga2/perfdata | ||
|
||
rm -r "${D}/var/run" || die "failed to remove /var/run" | ||
rm -r "${D}/var/cache" || die "failed to remove /var/cache" | ||
|
||
fowners root:icinga /etc/icinga2 | ||
fperms 0750 /etc/icinga2 | ||
fowners icinga:icinga /var/lib/icinga2 | ||
fowners icinga:icinga /var/spool/icinga2 | ||
fowners -R icinga:icingacmd /var/lib/icinga2/api | ||
fowners icinga:icinga /var/spool/icinga2/perfdata | ||
fowners icinga:icingacmd /var/log/icinga2 | ||
|
||
fperms ug+rwX,o-rwx /etc/icinga2 | ||
fperms ug+rwX,o-rwx /var/lib/icinga2 | ||
fperms ug+rwX,o-rwx /var/spool/icinga2 | ||
fperms ug+rwX,o-rwx /var/log/icinga2 | ||
|
||
if use vim-syntax; then | ||
insinto /usr/share/vim/vimfiles | ||
doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect | ||
doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax | ||
fi | ||
|
||
if use nano-syntax; then | ||
insinto /usr/share/nano | ||
doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} && ${REPLACING_VERSIONS} != ${PV} ]]; then | ||
elog "DB IDO schema upgrade may be required required. | ||
http://docs.icinga.org/icinga2/snapshot/doc/module/icinga2/chapter/upgrading-icinga-2" | ||
fi | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters