forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-portage/smart-live-rebuild: Bump to 1.3.5
- Loading branch information
Showing
2 changed files
with
35 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST smart-live-rebuild-1.3.4.1.tar.bz2 15980 SHA256 dd1e780937322a4cdee5a8f9af48d24283bda203e40167d02c7bb18924a4335f SHA512 65b864532e662d0fa032962673c2c2d6c1e21c557c82e295591086aea22de90ca9fed0e90bb0da0f6926ab19176a04ab41ee80c88dd8c5c05c3751c30ca39a92 WHIRLPOOL 329ea91bba103c6b2728905dac33532030d2c0ae802deb19056b1719bec6d85bd9b9a039cad4b3add92620c003cc573c797080cb2e02f09e670a0475439904be | ||
DIST smart-live-rebuild-1.3.5.tar.bz2 16004 SHA256 f7d304bb00ec32ab48bb3062a89896dbd0df344e010e91ea40417d162f5ad881 SHA512 46933334c8c46a056c837e60a5d8aed30a35b1ddd20d7c0f03e813f6cac11cc2dc9469674b1e9c23d94c9ebc474e5eacc7aa0e8f82492554a7f49b438ed740d2 WHIRLPOOL d9a5ab93057cc3070f46fec49eee0c71237481a8e3dc84a9de40df5eb78d2fe3617b5fd1f82c04b24e9bfaef81de0883d0c8696c00ff8e7a685f175e30783370 |
34 changes: 34 additions & 0 deletions
34
app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Check live packages for updates and emerge them as necessary" | ||
HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/" | ||
SRC_URI="https://github.com/mgorny/smart-live-rebuild/releases/download/v${PV}/${P}.tar.bz2" | ||
|
||
LICENSE="BSD-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~mips ~x86 ~x86-fbsd" | ||
IUSE="" | ||
|
||
RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]" | ||
|
||
# Tests need to be fixed | ||
RESTRICT=test | ||
|
||
python_test() { | ||
esetup.py test | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
|
||
insinto /etc/portage | ||
newins smart-live-rebuild.conf{.example,} | ||
insinto /usr/share/portage/config/sets | ||
newins sets.conf.example smart-live-rebuild.conf | ||
} |