forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/gdbus-codegen: Version bump
Package-Manager: portage-2.2.26
- Loading branch information
1 parent
3f2de4c
commit 4c0d81f
Showing
2 changed files
with
48 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST glib-2.44.1.tar.xz 7132940 SHA256 8811deacaf8a503d0a9b701777ea079ca6a4277be10e3d730d2112735d5eca07 SHA512 c24d307408e061b2657f7e7d1b8245c55605ebda26ee2dcc3497ee9d90bfc137d8e5f42f0cd5acf4b49ea28c424fa901e81f75ecf81833f6d0fe51d5e36e5888 WHIRLPOOL 6a1eef94b3ffed4d5cb551f4def6859ddff8ea0aac50048e706863f2bd4957c40b7034946852fa4604a109eb121c55b94ec51b3708a325ace5692f61fd1babb7 | ||
DIST glib-2.46.2.tar.xz 7344636 SHA256 5031722e37036719c1a09163cc6cf7c326e4c4f1f1e074b433c156862bd733db SHA512 8b5298712710d77b4a47367071f782d2bb3042b149ec8fde8c065f80bf3c5375c94318d19665c0092572e4895e590231a47324d25f371310f02b43feb3009588 WHIRLPOOL 700b69360110351544780ace4dcb14f29505f63d8840882532a4b7c017860b6da86e09cbabca691b7b24cb08b8722e772555de044b8b21e4b0952c8a8e4e6ecb | ||
DIST glib-2.48.0.tar.xz 7487800 SHA256 744be6931ca914c68af98dc38ff6b0cf8381d65e335060faddfbf04c17147c34 SHA512 684544bc594d9f6c905495d895daed40b074bcf5fa835aefb9a1034afc9564b2bd464e68d4c378c210e96918ef5d5202350da53a7104794420e990049ddbebf5 WHIRLPOOL 39ddd7fd17ecc2100f2156165210d2cf68ae13724b252e42705bc89d0c4145cddca3a30f9e3bf9b6a2971cbffe0e108d2acae1200c8fe6d9db91b4b3953c4950 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
GNOME_ORG_MODULE="glib" | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5} ) | ||
PYTHON_REQ_USE="xml" | ||
|
||
inherit eutils gnome.org distutils-r1 | ||
|
||
DESCRIPTION="GDBus code and documentation generator" | ||
HOMEPAGE="http://www.gtk.org/" | ||
|
||
LICENSE="LGPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos" | ||
IUSE="" | ||
|
||
RDEPEND="${PYTHON_DEPS}" | ||
DEPEND="${RDEPEND}" | ||
|
||
# To prevent circular dependencies with glib[test] | ||
PDEPEND=">=dev-libs/glib-${PV}:2" | ||
|
||
S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen" | ||
|
||
python_prepare_all() { | ||
PATCHES=( | ||
"${FILESDIR}/${PN}-2.40.0-sitedir.patch" | ||
) | ||
distutils-r1_python_prepare_all | ||
|
||
sed -e 's:#!@PYTHON@:#!/usr/bin/env python:' gdbus-codegen.in > gdbus-codegen || die | ||
cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed" | ||
sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed" | ||
} | ||
|
||
src_test() { | ||
einfo "Skipping tests. This package is tested by dev-libs/glib" | ||
einfo "when merged with FEATURES=test" | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all # no-op, but prevents QA warning | ||
doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1" | ||
} |