Skip to content

Commit

Permalink
gui-apps/waybar: subslot libmfmt to 0/5
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/692920
Package-Manager: Portage-2.3.73, Repoman-2.3.17
Signed-off-by: Bernardo Meurer <[email protected]>
Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
lovesegfault authored and FuzzyGophers committed Aug 29, 2019
1 parent ea1c6d1 commit 4c0dd98
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 1 deletion.
58 changes: 58 additions & 0 deletions gui-apps/waybar/waybar-0.7.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors."
HOMEPAGE="https://github.com/Alexays/Waybar"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
else
SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="MIT"
SLOT="0"
IUSE="libcxx mpd network pulseaudio tray +udev"

DEPEND="
dev-cpp/gtkmm:3.0
dev-libs/jsoncpp:=
dev-libs/libinput:=
dev-libs/libsigc++:2
>=dev-libs/libfmt-5.3.0:0/5
>=dev-libs/spdlog-1.3.1:=
dev-libs/wayland
dev-libs/wayland-protocols
gui-libs/wlroots
libcxx? ( sys-libs/libcxx )
mpd? ( media-libs/libmpdclient )
network? ( dev-libs/libnl:3 )
pulseaudio? ( media-sound/pulseaudio )
tray? ( dev-libs/libdbusmenu[gtk3] )
udev? ( virtual/libudev:= )"

RDEPEND="${DEPEND}"

BDEPEND="virtual/pkgconfig"

if [[ ${PV} != 9999 ]]; then
S="${WORKDIR}/${PN^}-${PV}"
fi

src_configure() {
local emesonargs=(
$(meson_use libcxx)
$(meson_feature mpd)
$(meson_feature network libnl)
$(meson_feature pulseaudio)
$(meson_feature tray dbusmenu-gtk)
$(meson_feature udev libudev)
)
meson_src_configure
}
2 changes: 1 addition & 1 deletion gui-apps/waybar/waybar-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,7 @@ DEPEND="
dev-libs/jsoncpp:=
dev-libs/libinput:=
dev-libs/libsigc++:2
>=dev-libs/libfmt-5.3.0:=
>=dev-libs/libfmt-5.3.0:0/5
>=dev-libs/spdlog-1.3.1:=
dev-libs/wayland
dev-libs/wayland-protocols
Expand Down

0 comments on commit 4c0dd98

Please sign in to comment.