Skip to content

Commit

Permalink
dev-cpp/edencommon: add 2023.06.19.00
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jun 24, 2023
1 parent 8640d53 commit 4c15e3d
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/edencommon/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST edencommon-2023.02.06.00.gh.tar.gz 144809 BLAKE2B bfde04282eff3ad745ed02708ba550e81c3d7916c634f01bc3fa9f2232953b4ccc8f319378636add4122cdf4c944212d7ecb649072c82f44dd8751640bc8f260 SHA512 c5763aa6a035febc6ce2a8b32c7ffb576b0a73448cf44e4a3788d87c45507a429065a02c37bce2165b2b51b3139cef51dc5ecd6cce203093f9043387b8912b15
DIST edencommon-2023.05.22.00.gh.tar.gz 146695 BLAKE2B 23003c0d9d5364d840ec8e286ec2512a28740df70480593086b2c969f4f785b3ff9000e074729fdaa561f3bd917ee204bd2719878996d606567f38fb50884149 SHA512 20b645250c41f1db95ae9950577f020a0c1240178411e3fcf7eb1219dd2bf0e3d7ceb0e98a17df7ba82259a52856d8001baea7ff8b1c178e22e7efb48b41587a
DIST edencommon-2023.06.19.00.gh.tar.gz 146697 BLAKE2B 8b2419671c50eea43aa4b8d5d85eee75ed24ff9745a71c2d11b1994605552ffc288b55520639585631aed0e2528482a01daa9b47ef676fed7c14b4c7d75d018f SHA512 47b37a6acf93a6c6f2903f3113021aa1d54230cf3e31a8071aa7f276601a8eae56bd95767ec23c3027695367261d4db1483b637513c72ce220778f1f1a4c42ce
41 changes: 41 additions & 0 deletions dev-cpp/edencommon/edencommon-2023.06.19.00.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

# These must be bumped together:
# dev-cpp/edencommon
# dev-cpp/folly
# dev-util/watchman

inherit cmake

DESCRIPTION="Shared library for Watchman and Eden projects"
HOMEPAGE="https://github.com/facebookexperimental/edencommon"
SRC_URI="https://github.com/facebookexperimental/edencommon/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"

LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="llvm-libunwind"

RDEPEND="
dev-cpp/gflags:=
dev-cpp/glog:=[gflags]
dev-cpp/folly:=
llvm-libunwind? ( sys-libs/llvm-libunwind:= )
!llvm-libunwind? ( sys-libs/libunwind:= )
"
DEPEND="
${RDEPEND}
dev-cpp/gtest
"

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
-DLIB_INSTALL_DIR="$(get_libdir)"
)

cmake_src_configure
}

0 comments on commit 4c15e3d

Please sign in to comment.