Skip to content

Commit

Permalink
dev-python/jsonschema: add 4.6.1
Browse files Browse the repository at this point in the history
Signed-off-by: Arthur Zamarin <[email protected]>
  • Loading branch information
arthurzam committed Jun 28, 2022
1 parent d178622 commit 4c3d001
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/jsonschema/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST jsonschema-4.5.1.tar.gz 282414 BLAKE2B 5b1d4e591e48c760e89a438b3bf9ea6b27b0959030be4558d5a863ceea218bdc4db19d09e2783724026fc2e10eeb6c969a939f4d1a5b44c16dbf7ff39c61a743 SHA512 3866a649ece45c1c69d3d5e9810cfdb094f1af82fcc08a186f9babd7516ad311c4bffa52f61f013bc84e7ab1be06605c5fab738c1c920ff8ce85a73429d9efde
DIST jsonschema-4.6.0.tar.gz 269939 BLAKE2B f214f65fbb908029f221789ab3857db9cbc1a7bb355f04a46bc7798514ba73ac3ba6f78cc3eaf985c19b16607ea6cf38bf46c9a8e19b1b1aef0138ef74239a4c SHA512 82d9e0c7de867c4a53b67b9dc79a38a76e384f5d41c66b52c57d407e03eb97faf8ebf41370ef08b30966f13eca210f94916b6a40347a2a75088e33017ccc2f5f
DIST jsonschema-4.6.1.tar.gz 278452 BLAKE2B 0b5c90b790cf7430bfbea4b38f90acec6fc256bf521d9552b463489751da3f889b43021e9d94c3ed4bd7704c462141d73d25273eea1331c85a0d2d04d5c9ad18 SHA512 5c0e2806915ef4545092b0bffe4cc1207d9a6f2a6920c10894d5b7b2a9ed665093b7a9a68114d1a05528869e7d8aed902e7569800db4393fa810c0f6853f713d
53 changes: 53 additions & 0 deletions dev-python/jsonschema/jsonschema-4.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( pypy3 python3_{8..11} )

inherit distutils-r1

DESCRIPTION="An implementation of JSON-Schema validation for Python"
HOMEPAGE="
https://pypi.org/project/jsonschema/
https://github.com/python-jsonschema/jsonschema/
"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"

RDEPEND="
>=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
>=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
' 3.8)
"
BDEPEND="
dev-python/hatch-vcs[${PYTHON_USEDEP}]
"

# formatter deps
RDEPEND+="
dev-python/fqdn[${PYTHON_USEDEP}]
dev-python/idna[${PYTHON_USEDEP}]
dev-python/isoduration[${PYTHON_USEDEP}]
>=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
dev-python/rfc3339-validator[${PYTHON_USEDEP}]
dev-python/rfc3986-validator[${PYTHON_USEDEP}]
dev-python/rfc3987[${PYTHON_USEDEP}]
dev-python/uri_template[${PYTHON_USEDEP}]
>=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
"

distutils_enable_tests pytest

EPYTEST_DESELECT=(
# requires pip, does not make much sense for the users
jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
# wtf?
jsonschema/tests/test_deprecations.py::TestDeprecations::test_version
)

0 comments on commit 4c3d001

Please sign in to comment.