Skip to content

Commit

Permalink
dev-perl/FileHandle-Unget: Bump to version 0.163.400
Browse files Browse the repository at this point in the history
- EAPI7
- Neuter bad test generation

Upstream:
- Switch to File::Slurper
- Fix various tests
- Add various missing dependencies
- Fix support for Perl w/o '.' in @inc

Keywords:
- New dependency dev-perl/Test-Compile drops keywords:
  ia64 ppc sparc

Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Kent Fredric <[email protected]>
  • Loading branch information
kentfredric committed Sep 8, 2020
1 parent 547d871 commit 4c4f4d5
Show file tree
Hide file tree
Showing 3 changed files with 92 additions and 0 deletions.
32 changes: 32 additions & 0 deletions dev-perl/FileHandle-Unget/FileHandle-Unget-0.163.400.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DIST_AUTHOR=DCOPPIT
DIST_VERSION=0.1634
inherit perl-module

DESCRIPTION="A FileHandle which supports ungetting of multiple bytes"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND=">=virtual/perl-Scalar-List-Utils-1.140.0"
DEPEND="${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.360.0
virtual/perl-File-Spec
dev-perl/UNIVERSAL-require
dev-perl/URI
test? (
dev-perl/File-Slurper
dev-perl/Test-Compile
virtual/perl-Test-Simple
)
"
PATCHES=(
"${FILESDIR}/${PN}-0.1634-no-authortest-generation.patch"
)
1 change: 1 addition & 0 deletions dev-perl/FileHandle-Unget/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST FileHandle-Unget-0.1628.tar.gz 40259 BLAKE2B 6f63e89d8a25e1296c8af63ab138b0032de63a5e9557a77ab99a76747516ed6c098e23a2b1542d88da5034db28b2c5a9884712f42e83b5818b773bdfddb5dff1 SHA512 7c4aca0c7d22ab7091c19b7bc5876ed4f83ff961e49900e0ec70124cedc4e34109a31edf5180c6958772f85a021e2be6a8a9e69c393b495e413c24a8b2b6ff3f
DIST FileHandle-Unget-0.1634.tar.gz 42660 BLAKE2B b7f4993e1247ac5b80828ba56137acde6660576934d42abb9628ef4afbd82b69849a95670625ce56044c12636fc81b5aab4297135b17cc4af2f4651beabaff4a SHA512 a649eb586897d4ae305e2e71325e322bfb5fd26e1352c92241c9a2a499bfca85d3322897598abcb25404a06d4f32dd4f945c5d7369024eabea793c6a500bc36c
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
From a042303a6e1858cf3b09062c4856eb0fff2ea3f9 Mon Sep 17 00:00:00 2001
From: Kent Fredric <[email protected]>
Date: Tue, 8 Sep 2020 20:51:31 +1200
Subject: Patch out generation of author tests

---
inc/Module/Install/StandardTests.pm | 8 +++-----
1 file changed, 3 insertions(+), 5 deletions(-)

diff --git a/inc/Module/Install/StandardTests.pm b/inc/Module/Install/StandardTests.pm
index cd693ff..b565990 100644
--- a/inc/Module/Install/StandardTests.pm
+++ b/inc/Module/Install/StandardTests.pm
@@ -14,7 +14,7 @@ our $VERSION = '0.05';
sub use_standard_tests {
my ($self, %specs) = @_;

- my %with = map { $_ => 1 } qw/compile pod pod_coverage perl_critic/;
+ my %with = map { $_ => 1 } qw/compile/;
if (exists $specs{without}) {
$specs{without} = [ $specs{without} ] unless ref $specs{without};
delete $with{$_} for @{ $specs{without} };
@@ -27,9 +27,6 @@ sub use_standard_tests {
$self->build_requires('Test::Compile');

$self->write_standard_test_compile; # no if; this is mandatory
- $self->write_standard_test_pod if $with{pod};
- $self->write_standard_test_pod_coverage if $with{pod_coverage};
- $self->write_standard_test_perl_critic if $with{perl_critic};
}


@@ -65,7 +62,6 @@ TEST
$self->realclean_files($filename);
}

-
sub write_standard_test_compile {
my $self = shift;
$self->write_test_file('000_standard__compile.t', q/
@@ -79,6 +75,7 @@ sub write_standard_test_compile {
/);
}

+=cut

sub write_standard_test_pod {
my $self = shift;
@@ -130,6 +127,7 @@ sub write_standard_test_perl_critic {
/);
}

+=cut

1;

--
2.28.0

0 comments on commit 4c4f4d5

Please sign in to comment.