Skip to content

Commit

Permalink
media-gfx/geeqie: fix keywords widget with GTK3
Browse files Browse the repository at this point in the history
Patch provided by Tomasz Golinski <[email protected]>
Bug: 561912

Package-Manager: portage-2.2.26
  • Loading branch information
voyageur committed Jan 4, 2016
1 parent 9a715ee commit 4c6a7c9
Show file tree
Hide file tree
Showing 2 changed files with 88 additions and 0 deletions.
12 changes: 12 additions & 0 deletions media-gfx/geeqie/files/geeqie-1.2.2-fix_keywords_gtk3.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
--- a/src/bar_keywords.c 2015-05-23 14:20:43.000000000 +0200
+++ b/src/bar_keywords.c 2015-12-30 00:34:21.453531792 +0100
@@ -1295,6 +1295,9 @@
g_object_set_data(G_OBJECT(pkd->widget), "pane_data", pkd);
g_signal_connect(G_OBJECT(pkd->widget), "destroy",
G_CALLBACK(bar_pane_keywords_destroy), pkd);
+#if GTK_CHECK_VERSION(3,0,0)
+ gtk_widget_set_size_request(pkd->widget, -1, 400);
+#endif
gtk_widget_show(hbox);

scrolled = gtk_scrolled_window_new(NULL, NULL);
76 changes: 76 additions & 0 deletions media-gfx/geeqie/geeqie-1.2.2-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit autotools eutils

DESCRIPTION="A lightweight GTK image viewer forked from GQview"
HOMEPAGE="http://www.geeqie.org"
SRC_URI="http://www.geeqie.org/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug doc exif gtk3 jpeg lcms lirc lua tiff xmp"

RDEPEND="gtk3? ( x11-libs/gtk+:3 )
!gtk3? ( x11-libs/gtk+:2 )
virtual/libintl
doc? ( app-text/gnome-doc-utils )
jpeg? ( virtual/jpeg:0 )
lcms? ( media-libs/lcms:2 )
lirc? ( app-misc/lirc )
lua? ( >=dev-lang/lua-5.1:= )
xmp? ( >=media-gfx/exiv2-0.17:=[xmp] )
!xmp? ( exif? ( >=media-gfx/exiv2-0.17 ) )
tiff? ( media-libs/tiff:0 )"
DEPEND="${RDEPEND}
virtual/pkgconfig
dev-util/intltool
sys-devel/gettext"

src_prepare() {
epatch "${FILESDIR}"/${P}-fix_keywords_gtk3.patch

epatch_user

eautoreconf
}

src_configure() {
# clutter does not compile, gps depends on clutter
local myconf="--disable-dependency-tracking
--with-readmedir=/usr/share/doc/${PF}
--disable-clutter
--disable-gps
$(use_enable debug debug-log)
$(use_enable gtk3)
$(use_enable jpeg)
$(use_enable lcms)
$(use_enable lua)
$(use_enable lirc)
$(use_enable tiff)"

if use exif || use xmp; then
myconf="${myconf} --enable-exiv2"
else
myconf="${myconf} --disable-exiv2"
fi

econf ${myconf}
}

src_install() {
emake DESTDIR="${D}" install

rm -f "${D}/usr/share/doc/${PF}/COPYING"
# Application needs access to the uncompressed file
docompress -x /usr/share/doc/${PF}/README
}

pkg_postinst() {
elog "Some plugins may require additional packages"
elog "- Image rotate plugin: media-gfx/fbida (JPEG), media-gfx/imagemagick (TIFF/PNG)"
elog "- RAW images plugin: media-gfx/ufraw"
}

0 comments on commit 4c6a7c9

Please sign in to comment.