Skip to content

Commit

Permalink
dev-python/tqdm: Bump to 4.61.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 25, 2021
1 parent b38d34b commit 4c6dc19
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/tqdm/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST tqdm-4.60.0.tar.gz 174201 BLAKE2B 78f4e2c2189621b5d276b8a9c75bae1566b05888cce81d8281de358ad2817e9751395bcf529c07620cd1ec4431c78ed7c1400dc96e9c3a99ac92daf2551b2da5 SHA512 e76dda97323353725c8e30b254bacfa328b4708d37ba2d21dadd30fd26e76605d8f077f02f2047030c6ab9761710a0e86640153fee0e3a3f972db12266fcfde2
DIST tqdm-4.61.0.tar.gz 169471 BLAKE2B 6710b057bc5cab7afc72681c469618b442d47a0aec4300f52a360af41fff082a96d3f67cb650978c924df210a1c56e2856f181d55cdcc5692713d53581932144 SHA512 7c13c98572ac2800b695cf38d6de84b348c20967187dfcd3a358fc3a9999bfda509d3b4fbb77272840e1568ed975fc038cfb4034288c72560e09a58fbdc636f1
51 changes: 51 additions & 0 deletions dev-python/tqdm/tqdm-4.61.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( pypy3 python3_{7..9} )
inherit distutils-r1

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/tqdm/tqdm"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
fi

DESCRIPTION="Add a progress meter to your loops in a second"
HOMEPAGE="https://github.com/tqdm/tqdm"

LICENSE="MIT"
SLOT="0"
IUSE="examples"

BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
test? (
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/pytest-timeout[${PYTHON_USEDEP}]
)"

distutils_enable_tests pytest

python_test() {
# Skip unpredictable performance tests
epytest --ignore 'tests/tests_perf.py'
}

python_install() {
doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
distutils-r1_python_install
}

python_install_all() {
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
distutils-r1_python_install_all
}

0 comments on commit 4c6dc19

Please sign in to comment.