Skip to content

Commit

Permalink
www-client/opera: automated bump (93.0.4585.64)
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Dec 14, 2022
1 parent 4353cd9 commit 4c6f07f
Show file tree
Hide file tree
Showing 2 changed files with 157 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-client/opera/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST opera-ffmpeg-codecs-105.0.5195.19.tar.xz 1413912 BLAKE2B 52e951eb93b2ed91b4053002a43e79884c46aab7b2218a08717927e3f43bc247b340bafc18488fcf6596d4441c318d6fe734869c8daad047107aeff0fade4c71 SHA512 f29bc9146fa67b71fa2df83a9b731e9cb4ce7827a573b63fa1c10baba5980f0375cfab2c6e1edce01415753b6f3e0b65de7d361d9400550d7a2d637236e2e414
DIST opera-stable_93.0.4585.37_amd64.deb 100009688 BLAKE2B 51d983798ea9a869b7cb4faf6ce822ea8680b5f311ae0bd62ae24c5658babbbea7ac132093ef103253dcbe772e00dba53db64c77974c4ef26169a25b115bdc76 SHA512 7f20b906691233a2fe9ed76aa0f424aebab4848ed3d288c8dc0ea96844ac126684dd0f575f8790d79ab65ae0f0b50d8cd974c65884167648e510fcfd3d2762ed
DIST opera-stable_93.0.4585.64_amd64.deb 100054140 BLAKE2B c59a3ad78e36cbbb655c4360700f9559890f85dbcfc5b8765cc4130958ea0e1925d3afacd25db6f048844e433b366ccf76fdadbb82e44a902f395fa258514d24 SHA512 3827c861e0fdebeabbe93b641827976669ac940c9fbcb8e9d02291019233e0e1c6fec5d0705863535edbc90a99553bd516b4af277610595d33b600f6e47bd960
156 changes: 156 additions & 0 deletions www-client/opera/opera-93.0.4585.64.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,156 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
CHROMIUM_LANGS="
bg bn ca cs da de el en-GB en-US es-419 es fil fi fr hi hr hu id
it ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
zh-CN zh-TW
"

# These are intended for ebuild maintainer use to force RPM if DEB is not available.
: ${OPERA_FORCE_RPM=no}

inherit chromium-2 pax-utils xdg

if [[ ${OPERA_FORCE_RPM} == yes ]]; then
inherit rpm
OPERA_ARCHIVE_EXT="rpm"
else
inherit unpacker
OPERA_ARCHIVE_EXT="deb"
fi

DESCRIPTION="A fast and secure web browser"
HOMEPAGE="https://www.opera.com/"
LICENSE="OPERA-2018"
SLOT="0"

SRC_URI_BASE=(
"https://download1.operacdn.com/pub/${PN}"
"https://download2.operacdn.com/pub/${PN}"
"https://download3.operacdn.com/pub/${PN}"
"https://download4.operacdn.com/pub/${PN}"
)

if [[ ${PN} == opera ]]; then
MY_PN=${PN}-stable
SRC_URI_BASE=( "${SRC_URI_BASE[@]/%//desktop}" )
else
MY_PN=${PN}
fi

KEYWORDS="-* ~amd64"

FFMPEG_VERSION="105.0.5195.19"

SRC_URI="${SRC_URI_BASE[@]/%//${PV}/linux/${MY_PN}_${PV}_amd64.${OPERA_ARCHIVE_EXT}}
proprietary-codecs? (
mirror+https://dev.gentoo.org/~sultan/distfiles/www-client/opera/opera-ffmpeg-codecs-${FFMPEG_VERSION}.tar.xz
)"

IUSE="+proprietary-codecs suid"
RESTRICT="bindist mirror strip"

RDEPEND="
>=app-accessibility/at-spi2-core-2.46.0:2
dev-libs/expat
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
gnome-base/gsettings-desktop-schemas
media-libs/alsa-lib
media-libs/mesa[gbm(+)]
net-misc/curl
net-print/cups
sys-apps/dbus
sys-libs/glibc
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:3
x11-libs/libdrm
x11-libs/libxcb
x11-libs/libxkbcommon
x11-libs/libxshmfence
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXrandr
x11-libs/pango
"

QA_PREBUILT="*"
S=${WORKDIR}
OPERA_HOME="opt/opera${PN#opera}"

pkg_pretend() {
# Protect against people using autounmask overzealously
use amd64 || die "opera only works on amd64"
}

pkg_setup() {
chromium_suid_sandbox_check_kernel_config
}

src_unpack() {
:
}

src_install() {
dodir /
cd "${ED}" || die
if [[ ${OPERA_FORCE_RPM} == yes ]]; then
rpm_src_unpack "${A[0]}"
else
unpacker
fi

# move to /opt, bug #573052
mkdir -p "${OPERA_HOME%${PN}}"
if [[ ${OPERA_FORCE_RPM} == yes ]]; then
mv "usr/lib64/${PN}" "${OPERA_HOME%${PN}}" || die
else
mv "usr/lib/x86_64-linux-gnu/${PN}" "${OPERA_HOME%${PN}}" || die
fi
rm -r "usr/lib" || die

# disable auto update
rm "${OPERA_HOME}/${PN%-*}_autoupdate"{,.licenses,.version} || die

if [[ ${OPERA_FORCE_RPM} == yes ]]; then
rm "${OPERA_HOME}/setup_repo.sh" || die
else
rm -r "usr/share/lintian" || die

# fix docs
mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
gzip -d usr/share/doc/${PF}/changelog.gz || die
fi

# fix desktop file
sed -i \
-e 's|^TargetEnvironment|X-&|g' \
usr/share/applications/${PN}.desktop || die

# remove unused language packs
pushd "${OPERA_HOME}/localization" > /dev/null || die
chromium_remove_language_paks
popd > /dev/null || die

# setup opera symlink
rm "usr/bin/${PN}" || die
dosym "../../${OPERA_HOME}/${PN}" "/usr/bin/${PN}"

# install proprietary codecs
rm "${OPERA_HOME}/resources/ffmpeg_preload_config.json" || die
if use proprietary-codecs; then
mv lib_extra "${OPERA_HOME}"
fi

# pax mark opera, bug #562038
pax-mark m "${OPERA_HOME}/opera"
# enable suid sandbox if requested
use suid && fperms 4711 "${OPERA_HOME}/opera_sandbox"
}

0 comments on commit 4c6f07f

Please sign in to comment.